[COMO] Sincronizar Nokia N95 con Evolution

Imagen de cbrman
0 puntos

Los usuarios de windows lo tienen muy fácil ya que poseen el Nokia PC Suite y tras instalar este programa, sus problemas de sincronización se acabaron. Pero en Linux la cosa cambia. El emulador de windows (wine) no puede con la instalación del PC Suite, por un problema de librerias y flash, por lo que la sincronización se ha de hacer desde otro sitio. Por supuesto los magníficos desarrolladores de Linux han pensado en ello y existen soluciones al respecto. La mayoría de la literatura de este tema viene dada para los symbian de 2ª generación, pero en nuestro caso es casi la misma manera.

La idea va a ser sincronizar el N95 con ubuntu por medio de Evolution. Para ello necesitaremos tener instalado evolution: (posiblemente lo tendreis por defecto)

sudo apt-get install evolution

Luego tenemos que añadir unos repositorios:

sudo gedit /etc/apt/sources.list y añadir

deb http://opensync.gforge.punktart.de/repo/opensync-svn/ sid main
deb-src http://opensync.gforge.punktart.de/repo/opensync-svn/ sid main

y también unos paquetes necesarios:

sudo apt-get install multisync libopensync1 libopensync-plugin-syncml libopensync-plugin-evolution2 libopensync-plugin-syncml multisync-cli libopensync-plugin-file gnokii libsyncml-utils msynctool xgnokii msynctool

Llegados a este punto ya tenemos todo lo necesario.

En Menú- Accesorios, tenemos una nueva entrada: Multisync-gui. La ejecutamos. Le damos al botón añadir:

Nos pedirá un nombre de grupo: evo2-n95

Dentro de este grupo, le damos a editar y nos pedirá Add member, seleccionamos: evo2-sync

Aqui seleccionaremos todo en privado.

NOTA. Para que esto funcione tenemos que tener inicializado (arrancado aunque sólo sea una vez) el Evolution.

Luego seleccionamos al otro miembro: syncml-obex-client.

Nos saldrá texto a la derecha. Tranquilos es muy fácil

<?xml version="1.0"?> <config> <!-- (Only for bluetooth) The bluetooth address if the bluetooth mode is selected --> <bluetooth_address>XX:XX:XX:XX:XX:XX</bluetooth_address> <!-- (Only for bluetooth) The bluetooth channel to use. `sdptool browse $MAC` to search for the correct channel --> <bluetooth_channel>10</bluetooth_channel> <!-- (Only for USB) The usb interface number of the SYNCML-SYNC target. use syncml-obex-client -u (you will need access to the USB raw device) to find it. --> <interface>0</interface> <!-- The string that the plugin will use to identify itself. Some devices need a special string here. --> <identifier>PC Suite</identifier> <!-- The syncml version to use: 0 for 1.0, 1 for 1.1 and 2 for 1.2 --> <version>0</version> <!-- if the plugin should use wbxml --> <wbxml>1</wbxml> <!-- The username to use. Leave empty to not require a username --> <username></username> <!-- the password for the username --> <password></password> <!-- sets the connection type to use. 5 means obex over usb, 2 means obex over bluetooth --> <type>2</type> <!-- If wbxml is enabled, defines wether the wbxml should use string tables --> <usestringtable>0</usestringtable> <!-- Never send ADD command, but send REPLACE (not needed normally) --> <onlyreplace>0</onlyreplace> <!-- Workaround around for mobile phones which only use local timestamps and _no_ UTC timestamps! --> <onlyLocaltime>0</onlyLocaltime> <!-- Sets the maximum allowed size in bytes of incoming messages (some device need this option set). Example: 10000 --> <recvLimit>10000</recvLimit> <maxObjSize>0</maxObjSize> <!-- The name of the contacts db. Must be the same as the phones sends --> <contact_db>Contacts</contact_db> <!-- The name of the calendar db. Must be the same as the phones sends --> <calendar_db>Calendar</calendar_db> <!-- The name of the note db. Must be the same as the phones sends --> <note_db>Notes</note_db> </config> "

NOTA: La dirección de bluetooth se saca mediante el comando: $ hcitool scan

esto nos dará todas las direcciones MAC al alcance. Buscamos el nombre de nuestro móvil y la MAC está al lado.

El canal que yo le he puesto es el que me da cuando ejecuto sdptool browse XX:XX:XX:XX:XX en el apartado de SyncMLClient, el canal es 10. Creo que para todos es igual, pero si no os funciona comprobadlo.

Y ya está. Ahora sólo hay que darle al botón refrescar.

(Vía:http://movile65.blogspot.com/2007/11/howto-sincronizar-n95-y-ubuntu.html

Imagen de Cocuaz
+1
0
-1

 

 Me da un error al recargar los repositorios, me dice que puede ser que no esté disponible. También dice que compruebe lo escrito pero lo he copiado tal cual, ¿Alguna sugerencia?

 

Nos vemos en los bares . . .

+1
0
-1

 

 

 

Nos vemos en los bares . . .

Imagen de jorgelanz
+1
0
-1

Me da un error de: "No se pudo encontrar el paquete libopensync1" y no se a qué se debe.

Por otro lado me aparece el Multisync y el Multisync-qad pero no el Multisync-gdi.

Aunque le permite agregar un grupo no me permite agregar sub grupos.

A qué se puede deber?

Gracias.

+1
0
-1
Imagen de jorgelanz
+1
0
-1

Me da un error de: "No se pudo encontrar el paquete libopensync1" y no se a qué se debe.

Por otro lado me aparece el Multisync y el Multisync-qad pero no el Multisync-gdi.

Aunque le permite agregar un grupo no me permite agregar sub grupos.

A qué se puede deber?

Gracias.

+1
0
-1
Imagen de jorgelanz
+1
0
-1

Me da un error de: "No se pudo encontrar el paquete libopensync1" y no se a qué se debe.

Por otro lado me aparece el Multisync y el Multisync-qad pero no el Multisync-gdi.

Aunque le permite agregar un grupo no me permite agregar sub grupos.

A qué se puede deber?

Gracias.

+1
0
-1