Problemas para trabajar con dos GeForce 7600 en SLI

Imagen de pakus
0 puntos

Hola,

Recientemente he comprado dos nvidia GeForce 7600 GS y las he conectado mediante el bridge SLI adecuado para que trabajen como una única tarjeta. Estoy usando los siguientes drivers y versiones:

  • kernel 2.6.22-14-generic
  • driver NVIDIA 100.14.19(del paquete nvidia-glx-new)
  • VBIOS de la tarjeta: 05.73.22.50.57

He usado la aplicación nvidia-xconfig para configurar el SLI:

hal9000:~$ sudo nvidia-xconfig --sli=on 

El fichero /etc/X11/xorg.conf muestra las lines correspondientes al SLI activado, sin embargo el SLI no esta funcionando. Lo he comprobado mediante el programa nvidia-settings.

Asi mismo obtengo este error en el /var/log /Xorg.0.log:

(**) NVIDIA(0): Option "SLI" "on"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): NVIDIA SLI auto-select rendering option.
(WW) NVIDIA(0): DamageEvents are not currently compatible with SLI. Disabling
(WW) NVIDIA(0): DamageEvents.
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to find a valid SLI configuration.
(EE) NVIDIA(0): Invalid SLI configuration 1 of 1:
(EE) NVIDIA(0): GPUs:
(EE) NVIDIA(0): 1) NVIDIA GPU at PCI:1:0:0
(EE) NVIDIA(0): 2) NVIDIA GPU at PCI:4:0:0
(EE) NVIDIA(0): Errors:
(EE) NVIDIA(0): - Chipset not approved for SLI
(WW) NVIDIA(0): Failed to find a valid SLI configuration for the NVIDIA
(WW) NVIDIA(0): graphics device PCI:1:0:0. Please see Chapter 25: SLI and
(WW) NVIDIA(0): Multi-GPU FrameRendering in the README for troubleshooting
(WW) NVIDIA(0): suggestions.
(EE) NVIDIA(0): Only one GPU will be used for this X screen.
(II) NVIDIA(0): NVIDIA GPU GeForce 7600 GS (G73) at PCI:1:0:0 (GPU-0)

De lo que se deduciría que mi chipset no esta soportado para trabajar en SLI, de no ser porque en M$ funciona correctamente y porque en la documentación del driver para linux de NVIDIA también esta soportado.

Esta es la configuración fisica:

hal9000:~$ lspci | grep -i vga
01:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)
04:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)
hal9000:~$ lspci -t
-[0000:00]-+-00.0
+-01.0-[0000:01]----00.0
+-1a.0
+-1a.1
+-1a.2
+-1a.7
+-1b.0
+-1c.0-[0000:04]----00.0
+-1c.4-[0000:03]--+-00.0
| \-00.1
+-1c.5-[0000:02]----00.0
+-1d.0
+-1d.1
+-1d.2
+-1d.7
+-1e.0-[0000:05]----03.0
+-1f.0
+-1f.2
+-1f.3
\-1f.5

¿Alguien tiene algo similar funcionando y puede echarme una mano?

Muchas gracias