Desactivar dispositivo de audio default (solucionado)

Imagen de nosreg
0 puntos

hola llevo un tiempo con mi ubuntu 7.10 vanguardista =P... hice muchos esfuerzos por googlear y no tener que molestar en el foro pero creo que mi problema le ocurre a varios, el problema esta en la escasa información que encontré de esto. Gracias de antemano por la ayuda :D

Problema: (dispositivo de audio que cambia solo, o que no pesca mis configuraciones -__-)

mi problema es que amarok reproduce sonido pero cuando apago y prendo el computador no toma el audio mp3 en amarok y tampoco al iniciar el sonido de bienvenida... estuve observando que tengo dos tarjetas de sonido una integrada que dejo de funcionar correctamente y la otra es la que compre para remplazar a la nvidia... mis parlantes están conectados a esta ultima pero ubuntu se esfuerza en tomar por default en sistema/preferencias/sonido dispositivo: Nvidia nforce2(Alsa mixer)

mientras que yo coloco en vano al dispositivo C-Media PCI CMI8738 (Alsa mixer) porque solo lo reconoce cuando reinicio y luego al volver a iniciar el pc ubuntu toma de nuevo como dispositivo a Nvidia force2(Alsa mixer) ... pfff jajaja espero no haberlo dejado muy confuso =)...

pero en resumen quiero colocar el dispositivo de audio de la tarjeta pci y no la integrada q toma por default ubuntu

muchas gracias solo por tratar de entender mi sopa de letras =)

Imagen de ivanovich23
+1
0
-1

por que  no intenta  agregar  el nombre  del dispositivo  a la black list,  edite blacklist escriba en consola: 

sudo nano /etc/modprobe.d/blacklist  

  y  en la ultima  linea escribe  blacklist  y  agrega el nombre del  dispositivo que desea  deshabilitar, esa fue la solución  que me  funciono  hace un tiempo para que eliminar un conflicto que se presentaba entre la tarjeta de  video agp y el video integrado en la board, espero le sirva.

+1
0
-1
Imagen de nosreg
+1
0
-1

porfavor nose si podrias detallarme un poco comodebe formular esa linea para colocarla en el  blacklist... yo la escribiria:

blacklist_Nvidia_Nforce2(Alsa mixer)

xD dime si estoy muy lejos y como es porfavor y gracias =)

+1
0
-1
Imagen de serlibre
+1
0
-1

desde la bios puedes desabilitarla para entrar en la bios tienes que oprimir o la tecla suprimir o tal vez la f2 o una convinacion de varias teclas como por ejemplo ctrl-alt-esc o tal vez alguna convinacion de teclas con una de las teclas de funcion 

no se lo que hago

+1
0
-1

no se lo que hago

Imagen de Gabriel_M
+1
0
-1

Hola nos...:

No es paranormal es anormal.

Linux en general y Ubuntu en particular, en cuanto encuentra un dispositivo lo toman por default, los integrados siempre se detectan primero (video, red, sonido,usb, rs232, paralelo) 

Si quieres que tome por default el agregado, debes deshabilitar por hardware el integrado.

Esto se hace entrando al setup de la máquina, (escape, delete, F11, etc. etc. etc. al inicio), segun la bios de la mother, buscando el dispositivo en cuestión, poniendolo disable y guardando los cambios. 

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de nosreg
+1
0
-1

lo desahabilite por bios y coloque el dispositivo en la ultima linea del blacklist...

...de la siguiente forma con el nombre excacto del dispositivo q muestra en sonidos:

blacklist NVidia nforce2 (Alsa mixer) y funciona perfecto =) gracias  

+1
0
-1
Imagen de Javier M.
+1
0
-1

Por favor, intentad utilizar títulos descriptivos.

Usandolos se le facilita bastante la busqueda a posibles futuros usuarios que tengan el mismo problema.

Un saludo.

P.D. Lo edito para adecuarlo al contenido.


Equipo de moderadores
Normas

Documentación

 

+1
0
-1
Imagen de nosreg
+1
0
-1

jajaja si vas a modificarlo hazlo bien ...=P

Desactivar dispositivo de audio default (solucionado) 

de todas formas perdon por el primer titulo era para captar atencion =)

+1
0
-1