Acer 5210 con Atheros ar5007eg ubuntu 7.10 configurar wifi

Imagen de carlosVg
0 puntos

Hola... como ya es la tercera vez, que vuelvo a instalar el Ubuntu, me he decidido a escribiros, en busca de vuesta ayuda. despues de varios intentos fallidos, dandome grandes errores de carga, que al reiniciar ubuntu no arrancaba de nuevo, Os pido ayuda para configurar mi red inalambrica...(lo habia probado con el 7.04)

 

¿que pasos tengo que realizar?

 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hola otra vez... mmmm, sexta vez, que instalo ubuntu. Ahora he probado con la nueva version 7.10 , se me instala bien, y no tengo ningun problema, el problema me viene cuando intento configurar la tarjeta de wifi de mi portatil, que no me la reconoce, he leido muchos foros, y en todos, me he llevado decepciones, no es por los foros, seguro que es por mi poco conocimiento.

He logrado isntalarme el programa ndiswrapper, para emular los drivers del xp, para que reconociese la tarjeta, y las 6 veces, a la hora de hacerle un reinicio, se me ha quedado colgado en el gestor de arranque.

y ahora sigo trabajando con la conexion de cable,me da miedo volverlo a intentar...

Lo que me gustaria, es que alguien hiciese de tutor, alguien que tenga el mismo problema, y lo halla conseguido solucionar,,, el me iria indicando, y yo iria haciendo los pasos poco a poco, porque he visto que solo no puedo, necesisto la ayuda de alguien.

estaria tremendamente agradecido...

gracias de antemano por ayudar... 

Imagen de dadá
+1
0
-1

Hoka.

Porqué no empiezas con el LiveCD 7.10, yo soy novato y no he tenido ningún problema.

+1
0
-1
Imagen de carlosVg
+1
0
-1

ya he probado con el 7.10, y sigue sin reconocerme la maldita tarjeta de wifi. pero gracias, ha sido lo primero que he hecho, bajarme la nueva version, e instalarla.

+1
0
-1
Imagen de dadá
+1
0
-1

hola de nuevo, que raro? yo tengo instaladas dos tarjetas una Netgear y otra D-Link con chipset Atheros y la verdad es que funcionan perfectamente desde la primera instalación.??????

 

 

Mira en la pag. http://madwifi.org/wiki/Chipsets .Aquí como mínimo encontrarás info de tu tarjeta. Yo uso el chipset AR5212/5213.

Otro enlace:  http://foro.seguridadwireless.net/index.php/topic,2724.msg54922.html#msg...

Suerte.

+1
0
-1
Imagen de carlosVg
+1
0
-1

gracias por echarme una mano, pero...  sigo sin saber como hacer, para que el portatil, me reconozca la tarjeta de wifi, me sigue sin aparecer en, conexiones de red.

 

Me da miedo como hacerlo, ya me he cargado muchas veces el ubuntu, y me ha tocado reinstalarlo todo, ya voy por la sexta vez, y ahora, cada vez, tengo mas configurado el entorno a mi gusto como para volver a empezar,,,

alguien me puede echar una mano??.

Que requisitos minimos tengo que tener?.

abriendo un, terminal, que comandos puedo poner, para que veais las cosas que tengo instaladas, y las que no...

quiero hacerlo bien esta vez...

Atentamente.

un usuario de ubuntu 7.10 

+1
0
-1
Imagen de dadá
+1
0
-1

Buuuf, si supieras la de veces que he llegado a instalar todo el "chiringuito" flipas.

  ...

La tarjeta es USB , instalas desde cero con o sin win....??

Por logica si empiezas como si el ordenata fuese nuevo no tendria que dar problemas...la única vez que he tenido problemas a sido al querer instalar ubuntu 7.10 en un pentium 166 MMX .....del siglo XX.

He instalado Ubuntu en varios Pcs y en un portatil presario y todo OK.

Yo con lo que he sufrido a sido para configurar los madwifi parcheados.

Tela marinera....

saludos dadá

 

+1
0
-1
Imagen de carlosVg
+1
0
-1

Hola a todos, he vuelto a lanzarme en otra prueba, para poder instalar la tarjeta de red del wifi, y me sigue sin aparecer...

Despues de mirar y mirar muchas paginas y comentarios, me he decidido a probar lo que se comenta en esta pagina, y como no me ha dado resultado, ahora que tengo que hacer??, me da miedo hacer malas instalaciones.... 

 esto es lo que he realizado al pie de la letra....

http://www.joelsedano.com/blog/?p=1020#comment-24217

puedo poner en algun terminal algun comando que os pueda ayudar a averiguar que me pasa??

estoy en vuestras manos....

Gracias. 

 

+1
0
-1
Imagen de dadá
+1
0
-1

Pregunta, para esta tarjeta no sirven los drivers de madwifi???

 

Y especifica...

Que es tarjeta externa es la que lleva el portatil.... 

+1
0
-1
Imagen de dadá
+1
0
-1

Si es externa ...el ordenata lleva incorporada otra wifi ???

+1
0
-1
Imagen de dadá
+1
0
-1

Enlace : http://foro.seguridadwireless.net/index.php/topic,8291.0.html

En esta pag. hablan de tú modelo de tu tarjeta. 

+1
0
-1
Imagen de boris rojas
+1
0
-1

hola

amigo yo tuve un monton de problemas con mi chip atheros ar5212 y mad wifi

primero q nada intenta esto

descargate el madwifi desde la pagina http://downloads.sourceforge.net/madwifi/madwifi-0.9.3.3.tar.gz

descargalo en el escritorio

y le das descomprimir

luego ala terminal

$ sudo apt-get install build-essential

una ves instalados te vas desde la terminal y entras a la carpeta madwifi-0.9.3.3

$ make

$ sudo make install

quizas te preguntara si deseas eliminar unos archivos . dale (r) remove

i listo

$ iwconfig

i deberia aparecer tu t. inalambrica

saludos

Aprendiz

+1
0
-1

Aprendiz

Imagen de dadá
+1
0
-1

Por lo que sé madwifi-0.9.3.3 son para instalarlos sobre kernel 2.6.23

 

+1
0
-1
Imagen de carlosVg
+1
0
-1

carlos@carlos-laptop:~/madwifi-0.9.3.3$ make
Checking requirements... ok.
Checking kernel configuration... ok.
make -C /lib/modules/2.6.22-14-generic/build SUBDIRS=/home/carlos/madwifi-0.9.3.3 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-generic'
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath/if_ath.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath/if_ath_pci.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath/ath_pci.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath_hal/ah_os.o
  HOSTCC  /home/carlos/madwifi-0.9.3.3/ath_hal/uudecode
  UUDECODE /home/carlos/madwifi-0.9.3.3/ath_hal/i386-elf.hal.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_hal/ath_hal.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/amrr/amrr.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/amrr/ath_rate_amrr.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/onoe/onoe.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/onoe/ath_rate_onoe.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/sample/sample.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/sample/ath_rate_sample.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/if_media.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_beacon.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_crypto.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_crypto_none.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_input.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_node.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_output.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_power.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_proto.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_scan.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_wireless.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_linux.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_monitor.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_rate.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_acl.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_crypto_ccmp.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_scan_ap.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_scan_sta.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_crypto_tkip.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_crypto_wep.o
  CC [M]  /home/carlos/madwifi-0.9.3.3/net80211/ieee80211_xauth.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_wep.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_tkip.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_ccmp.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_acl.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_xauth.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_sta.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_ap.o
  Building modules, stage 2.
  MODPOST 13 modules
  CC      /home/carlos/madwifi-0.9.3.3/ath/ath_pci.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath/ath_pci.ko
  CC      /home/carlos/madwifi-0.9.3.3/ath_hal/ath_hal.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_hal/ath_hal.ko
  CC      /home/carlos/madwifi-0.9.3.3/ath_rate/amrr/ath_rate_amrr.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/amrr/ath_rate_amrr.ko
  CC      /home/carlos/madwifi-0.9.3.3/ath_rate/onoe/ath_rate_onoe.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/onoe/ath_rate_onoe.ko
  CC      /home/carlos/madwifi-0.9.3.3/ath_rate/sample/ath_rate_sample.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/ath_rate/sample/ath_rate_sample.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_acl.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_acl.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_ccmp.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_ccmp.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_ap.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_ap.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_sta.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_scan_sta.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_tkip.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_tkip.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_wep.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_wep.ko
  CC      /home/carlos/madwifi-0.9.3.3/net80211/wlan_xauth.mod.o
  LD [M]  /home/carlos/madwifi-0.9.3.3/net80211/wlan_xauth.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-generic'
make -C ./tools  all || exit 1
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/tools'
gcc -o athstats -g -O2 -Wall -I. -I../hal -I.. -I../ath  athstats.c
gcc -o 80211stats -g -O2 -Wall -I. -I../hal -I..  80211stats.c
gcc -o athkey -g -O2 -Wall -I. -I../hal -I..  athkey.c
gcc -o athchans -g -O2 -Wall -I. -I../hal -I..  athchans.c
gcc -o athctrl -g -O2 -Wall -I. -I../hal -I..  athctrl.c
gcc -o athdebug -g -O2 -Wall -I. -I../hal -I..  athdebug.c
gcc -o 80211debug -g -O2 -Wall -I. -I../hal -I..  80211debug.c
gcc -o wlanconfig -g -O2 -Wall -I. -I../hal -I..  wlanconfig.c
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/tools'
carlos@carlos-laptop:~/madwifi-0.9.3.3$ sudo make install
sh scripts/find-madwifi-modules.sh 2.6.22-14-generic

WARNING:
It seems that there are modules left from previous MadWifi installations.
If you are unistalling the MadWifi modules please press "r" to remove them.
If you are installing new MadWifi modules, you should consider removing those
already installed, or else you may experience problems during operation.
Remove old modules?

[l]ist, [r]emove, [i]gnore or e[x]it (l,r,i,[x]) ?
r
for i in ./ath ./ath_hal ./ath_rate ./net80211; do \
                make -C $i install || exit 1; \
        done
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
install ath_pci.ko //lib/modules/2.6.22-14-generic/net
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath'
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath_hal'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
install ath_hal.ko //lib/modules/2.6.22-14-generic/net
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath_hal'
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath_rate'
for i in amrr/ onoe/ sample/; do \
                make -C $i install || exit 1; \
        done
make[2]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath_rate/amrr'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
install ath_rate_amrr.ko //lib/modules/2.6.22-14-generic/net
make[2]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath_rate/amrr'
make[2]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath_rate/onoe'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
install ath_rate_onoe.ko //lib/modules/2.6.22-14-generic/net
make[2]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath_rate/onoe'
make[2]: Entering directory `/home/carlos/madwifi-0.9.3.3/ath_rate/sample'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
install ath_rate_sample.ko //lib/modules/2.6.22-14-generic/net
make[2]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath_rate/sample'
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/ath_rate'
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/net80211'
test -d //lib/modules/2.6.22-14-generic/net || mkdir -p //lib/modules/2.6.22-14-generic/net
for i in wlan.o wlan_wep.o wlan_tkip.o wlan_ccmp.o wlan_acl.o wlan_xauth.o wlan_scan_sta.o wlan_scan_ap.o; do \
                f=`basename $i .o`; \
                install $f.ko //lib/modules/2.6.22-14-generic/net; \
        done
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/net80211'
(export KMODPATH=/lib/modules/2.6.22-14-generic/net; /sbin/depmod -ae 2.6.22-14-generic)
make -C ./tools  install || exit 1
make[1]: Entering directory `/home/carlos/madwifi-0.9.3.3/tools'
install -d /usr/local/bin
for i in athstats 80211stats athkey athchans athctrl athdebug 80211debug wlanconfig; do \
                install $i /usr/local/bin/$i; \
                strip /usr/local/bin/$i; \
        done
install -d /usr/local/man/man8
install -m 0644 man/*.8 /usr/local/man/man8
make[1]: Leaving directory `/home/carlos/madwifi-0.9.3.3/tools'
carlos@carlos-laptop:~/madwifi-0.9.3.3$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

 

nada de nada... sigue sin aparecerme.....

 

+1
0
-1
Imagen de carlosVg
+1
0
-1

Hola... sigo haciendo intentos con mi ordenador,  he seguido todo este tutorial al pie de la letra.... 

http://www.joelsedano.com/blog/?p=1020#comment-24217

y sigo sin ver en la barra de herramientas, al lado del reloj, el icono de la red wifi.

 

os dejo un par de comandos para que veais la tarjeta que tengo...

 

carlos@carlos-laptop:~$ lspci -nn | grep 168c:001c
02:00.0 Ethernet controller [0200]: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter [168c:001c] (rev 01)

 

carlos@carlos-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

carlos@carlos-laptop:~$
 

+1
0
-1
Imagen de dadá
+1
0
-1

No te desesperes.....

+1
0
-1
Imagen de dadá
+1
0
-1

No desesperes...

Lo que no termino de entender es: Cuando instalas el Live CD sin haber instalado al disco duro tampoco reconoce la tarjeta ?

 

Mira el comentario de Hwagm sobre el chipset--------

http://foro.seguridadwireless.net/index.php/topic,873.0.html 

+1
0
-1
Imagen de dadá
+1
0
-1

enlace:

http://foro.seguridadwireless.net/index.php/topic,873.0.html

Observa el comentario sobre el chipset.

 

dadá 

+1
0
-1
Imagen de migatxu
+1
0
-1

http://madwifi.org/ticket/1679 - http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz

Quita lo tengas instalado de madwifi, instala wireless-tools, hostapd, build-essential.

Revisa que no tengas cargado ningun modulo de atheros con un lsmod | grep ath, si sale algo, descarga el modulo con sudo rmmod ath_pci hasta que no tengas ningun ath_

 Descomprime el archivo que has bajado, y haces un make y sudo make install, despues sudo modprobe ath_pci y prueba a ver si ya tienes wifi, via network manager o co un ifconfig a ver si ya sale el dispositivo, y ya configuras.

Un saludo

 

"El pollo Popeye es la polla"

+1
0
-1

"El pollo Popeye es la polla"

Imagen de carlosVg
+1
0
-1

hola... pues la verdad, es que segui un tutorial, que instalaba, el programa ndiswrapper, e instalaba los driver, para poder tener wifi... lo segui todo, de esta pagina....

http://www.joelsedano.com/blog/?p=1020#comment-24217

lo digo, por si hago algo, que ya este hecho, o por si una cosa afecta a la otra... no me gustaria tener que reinstalar todo otra vez... seria la Septima.... >S

Te pongo lo que me sale, cuando en un terminal pongo lo que me has dicho....

carlos@carlos-laptop:~$ lsmod | grep ath
ath_pci 98336 0
wlan 206660 1 ath_pci
ath_hal 192720 1 ath_pci

necesitas algun comando mas??? 

+1
0
-1
Imagen de carlosVg
+1
0
-1

carlos@carlos-laptop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:D4:CE:F5:F4
inet addr:192.168.2.100 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::216:d4ff:fece:f5f4/64 Scope:Link
UP DIFUSIÓN CORRIENDO MULTICAST MTU:1500 Metric:1
RX packets:15531 errors:0 dropped:0 overruns:0 frame:0
TX packets:14031 errors:0 dropped:0 overruns:0 carrier:0
colisiones:0 txqueuelen:1000
RX bytes:17378436 (16.5 MB) TX bytes:2098319 (2.0 MB)
Interrupt:20 Base address:0x2000

lo Link encap:Bucle local
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK CORRIENDO MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
colisiones:0 txqueuelen:0
RX bytes:448 (448.0 b) TX bytes:448 (448.0 b)

 

 carlos@carlos-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

 

yo voy pegando cositas, por si os son de utilidad....

espero vuestras respuestas.

Atentamente.

un usuario de Ubuntu 7.10 

+1
0
-1
Imagen de dadá
+1
0
-1

estos son los pasos que yo he seguido despues de haber instalado muchas veces ubuntu, ahora ya me lo se de memoria:

Instalar D-Link DWL-G520 + Netgear WG311T + patch madwifi
Estos son los pasos que yo he seguido para Atheros AR5212/5213:

Se instala en el disco duro Ubuntu 7.10 (instalacion nueva, vengo de win...)

Una vez instalado se actualiza hasta llegar al kernel 2.6.22-14-generic con todas las actualizaciones
que te pida Ubuntu, no olvides instalar aircrack (no hay que preocuparse de la versión), madwifi-tools,
sharutils, subversion, gcc-3.4, macchanger,weplab, build-essential (tranquilo es tedioso pero el resultado
vale la pena, son más o menos 800 Megas, +- 4 horas de descargas y actualizaciones) además tendras que añadir al repositorio esto:
echo deb http://archive.ubuntu.com/ubuntu/ gutsy main restricted | sudo tee -a /etc/apt/sources.list
aptitude update
Instalación:
Para instalar el núcleo 2.6.22-14 invocar el siguiente comando:
apt-get install linux-headers-2.6.22-14 linux-headers-2.6.22-14-generic linux-image-2.6.22-14-generic linux-restricted-modules-2.6.22-14-generic linux-ubuntu-modules-2.6.22-14-generic
Tendras que comentar la linea del repositorio (deb http://archive.ubuntu.com/ubuntu/ gutsy main restricted | sudo tee -a /etc/apt/sources.list).
...
...
...
Seguro que algo se me olvida... HUUUUM... Pero bueno más o menos creo que por aquí van los tiros.

Mira desde Synaptic que aircrack esté actualizado a la version 1:0.9-1
Si todo esta correcto ya no actualizará más y Ubuntu funcionará que te cagas... (no cámbio como se ve la terminal y esos colores !!!)

OK. Sigamos:

Cuando tengas todo actualizado (elimina kernels antiguos, deja el sistema solo con 2.6.22-14-generic) simplemente haz esto:

cd /usr/src
wget http://patches.aircrack-ng.org/madwifi-ng-r2277.patch
svn -r 2834 checkout http://svn.madwifi.org/madwifi/trunk/ madwifi-ng
cd madwifi-ng
ifconfig ath0 down
ifconfig wifi0 down
patch -Np1 -i ../madwifi-ng-r2277.patch
./scripts/madwifi-unload
make
make install
depmod -ae
modprobe -r ath_pci
ifconfig
iwconfig

Reboot (--------Sistema, Salir, Reiniciar).

Para terminar de configurar modificad el archivo /etc/udev/rules.d/z45_persistent-net-generator.rules

http://madwifi.org/wiki/UserDocs/Distro/Debian/TroubleshootingInstallation

Reboot (--------Sistema, Salir, Reiniciar).

Ahora comprobad si funciona:
airmon-ng stop ath0
airmon-ng start wifi0
ifconfig ath0 up
aireplay-ng --test -i wifi0 ath0

El sistema responderá a los 5 ataque con OK:

11:50:04  Trying card-to-card injection...
11:50:04  Attack -0:        OK
11:50:04  Attack -1 (open): OK
11:50:04  Attack -1 (psk):  OK
11:50:04  Attack -2/-3/-4:  OK
11:50:04  Attack -5:        OK
11:50:04  Injection is working!

En estos momentos tengo instaladas dos tarjetas con chipset AR5212/5213 y funciona muy bien,,,,,,, con algunas dudas y cuestiones que ahora
no vienen al caso. Para volver a modo manager es:

wlanconfig ath create wlandev wifi0 wlanmode managed.

Saludos. dadá.
 

+1
0
-1
Imagen de dadá
+1
0
-1

Según he visto por la web de madwifi  -madwifi-0.9.3.3 es para instalar sobre kernel 2.6.23-------

dadá 

+1
0
-1
Imagen de carlosVg
+1
0
-1

Puedo tener instalado ndiswrapper, y tambien instalar madwifi?, no dara algun problema?

+1
0
-1
Imagen de dadá
+1
0
-1

Yo soy partidario de que si tienes un potipoti de cosas instaladas no sabras a ciencia cierta si el probelema viene de aquí o allá

más cuando no se sabe mucho de informática. Para salir de dudas puede probar Wifislax 3.1 que ya lleva incorporados muchos drivers para chipsets

No tendras que instalarlo en el disco duro para comprobar que te reconoce la tarjeta.

 

saludos dadá. 

+1
0
-1
Imagen de dadá
+1
0
-1

Hola.

Cuando instalas por pimera vez al disco duro dices que no te aparece la tarjeta..

1º instala desde synaptic madwifi-tools

reinicia .......si no ?

Desde mí punto  de vista si desde el principio ya no tienes reconocida la tarjeta  ves poco a poco, yo creo que es indispensable instalar madwifi-tools  y yo personalmente instalaria el paquete madwifi que dice Boris Rojas  http://snapshots.madwifi.org/special/madwifi-ng-r2756+ar5007.tar.gz

y a partir de aquí mira como queda el sistema ... Pero por pasos ya que instalando los madwifi-tools evidentemente tendria que verse la tarjeta

saludos dadá. 

+1
0
-1
Imagen de carlosVg
+1
0
-1

carlos@carlos-laptop:~$ sudo echo "ndiswrapper" >>   /etc/modules
bash: /etc/modules: Permiso denegado

 

Porque no tengo permisos al hacer este comando???? 

+1
0
-1
Imagen de dadá
+1
0
-1

 

sudo su

login:

 

+1
0
-1
Imagen de migatxu
+1
0
-1

No quiero que me pegues aqui un lsmod | grep ath o un ifconfig, haz los pasos que te he dicho, al pie de la letra, funciona. Quizas este no sea el mejor medio para ayudarte si estas muy perdido.

irc-hispano #ubuntu

"El pollo Popeye es la polla"

+1
0
-1

"El pollo Popeye es la polla"

Imagen de carlosVg
+1
0
-1

lo que pasa es que lo primero que me dices en el post anterior, es que quite todo lo que tenga instalado del madwifi, y el que instale, no fue ese, fue el ndiswrapper,  y por eso no lo he echo....

+1
0
-1
Imagen de dadá
+1
0
-1

Imagen de carlosVg
+1
0
-1

he seguido el tutorial al pie de la letra, y nada. siguen sin aparecerme las redes inalambricas.... jo....

 

+1
0
-1
Imagen de dadá
+1
0
-1

Mírate Wifislax 3.1 como minimo saldras de dudas

 

Tardarás más en bajarte la iso que en instalar el livecd y comprobar

si aparece la tarjeta .

 

+1
0
-1
Imagen de carlosVg
+1
0
-1

Me puedes esplicar un poquito como hacerlo?, te estaria muy agradecido, creo que ya lo he probado todo... pero no entiendo lo que me quieres decir....

 

Gracias de antemano, por la dedicacion...

 

+1
0
-1
Imagen de dadá
+1
0
-1

1º ves a seguridad wireless (web ---desde negroogle.es)

2º busca Wifislax 3,1, bajate la iso es para cd live

3º Instala el live cd son 15 minutos, te pedirá login y passwd supongo que será......root / toor

se quedará en modo texto, entonces pones startx y se cargará el entono gráfico.

 

+1
0
-1
Imagen de crow1x
+1
0
-1

WENAS TARDES, OS ESCRIBO PORQUE YO PUDE SOLUCIONAR EL FALLO DE LAS ATHEROS, DE QUE NO SON COMPATIBLES CON UBUNTU, O ESO DECIAN.

OS DEJO AKI COMO LO HICE A VER SI OS AYUDA-->

 

Aki os dejo una forma rapida de hacer funcionar la WIFI Atheros ke se que a muchos os esta dando muchas rompeduras de cabeza.
se hace casi todo con una Shell (Consola o Terminal)
--> Tenemos que estar como root:
su
y ponemos la pass

--> 1º actualizamos la sources.list con:

apt-get update

--> 2º despues de actualizarla, instalamos lo siguiente:

apt-get install linux-headers-generic (si usas la versión generica del kernel, en caso contrario sustituimos el "generic" por el tipo de kernel ke tenemos 386 - 686 - ...)
apt-get install build-essential bin86 sharutils
apt-get install ndiswrapper

--> 3º una vez instalados, solo nos falta los drivers que tenemos que instalar, en este caso tendriamos que conseguir los drivers " ar5006eg ".
yo los encontre sin problemas por www.google.es. en el caso de que no los encontreis me avisais y os los envio por mail.

--> 4º Ahora que ya tenemos los drivers, los descompromimos y vamos a la carpeta

cd /home/"USER"/ar5006eg/

y ahora una vez dentro escribimos

ndiswrapper -i net5211.inf
ndiswrapper -l
ndiswrapper -m
--> 5º Ahora probamos el modulo:

modprobe ath_pci
modprobe ndiswrapper

--> 6º Y hacemos que los cambios para sean permanentes:
nano /etc/modules
Agregamos "ath_pci" sin comillas, al final y debajo de ath_pci ponemos "ndiswrapper" tb sin comillas
guardamos los cambios con (control + O, control + X ->este para salir) y reiniciamos el pc.

Y wifi activada en un Linux, rapido y facil :D~~

Probado en una Ubuntu 7.10 y funciona ok

By: Crow1x ----- thecrow2505@gmail.com

+1
0
-1
Imagen de crow1x
+1
0
-1

mira carlosVg yo tambien levo pokito en el mundillo del linux, mira te dejo aki mi mail: thecrow2505@gmail.compor si tienes problemas avisame y te puedo ayudar oki

 

 

Un saludo Manu 

+1
0
-1