realmente necesito alguien que me ayude con esta vpn

Imagen de elfio
0 puntos

No es la primera vez que escribo a cuenta de este tema, pero es que ya estoy hasta las narices de esta red vpn. Las otras veces que he escrito no he recibido ayuda alguna y me gustaría que alguien se prestase a echarme una mano, porque yo solo no lo conseguire nunca...

 

Resulta que estoy en una residencia y hay una red vpn por la que se tiene acceso a internet. Esta vpn va bien para windows pero no para ubuntu. No se cuantas cosas he probado para conectarme y no lo consigo, aunque creo que el fallo esta en la configuración de las conexiones, pero por lo visto los administradores de la red, tienen menos idea de ella que los propios residentes... asi que  cuando les pides la encriptacion que tiene y demás configuraciones no saben decirte más que: eso son las DNS... y no, no lo son.

He probado con el pptpconfig, con el plugin para network manager para conexiones pptp, y ayer mismo con el kvpn sin exito alguno... esto dos último, me brindan más posibilidades para configurar la conexión, pero son tantos parámetros que me resulta imposible probar cada configuración una por una...

Creo que lo ideal sería algún tipo de script o lo que sea que me diga que clase de encriptación tiene o la configuración de la conexión que tengo que hacer...

Supongo que también serviría conocer la equivalencia de una conexión por windows a una por ubuntu, porque la de windows si que la tengo...

 

Si es necesario, pondré aqui las capturas de los programas, de los reportes del debugger... y lo que sea, pero por favor: ¡¡¡¡ayuda!!!! 

Imagen de elfio
+1
0
-1

De verdad necesito ayuda... ubuntu sin internet... es menos ubuntu... ahora mismo no tengo mas remedio que estar con window$...

Hay demasiados parametros que no se configurar, ayudadme por favor, alguien que sepa.... 

+1
0
-1
Imagen de SIMOJFJ
+1
0
-1

Haber no se si te sabre soluccionar algo pero bueno vamos por partes.

Dices que de windows te funciona ok ¿no?

Como te conectas a la red ¿Wiffi o ¿Lan (Cableada) ?

si estas seguro de haberte conectado a la red aunque no puedas ver  nada, prueba lo siguiente trata de entrar dentro de la configuracion del switch o del ruter al que pertenece la red.

Lo puedes ver poniendo la direccion de la puerta de enlace del equipo (router o switch) esto si no lo ves en ubuntu desde windows Inicio->Ejecutar y escribes cmd, con todo esto te saldra el entorno consola de windows.

Una vez dentro escribe ipconfig y te dara los datos de la conexion a la red, anota el de la puerta de enlace y prueba con ese numero en el firefox o el explorador que tengas en linux suele ser por defecto 192.168.1.1

si almenos te sale una ventana de usuario y pasword sera que la conexion la establece.

Apartir de ahi contactas otra vez conmigo y veremos si es un problema del router o switch que hay que configurarlos para que te deje acceder desde linux o si es un problema de configuracion de linux. 

 

+1
0
-1
Imagen de elfio
+1
0
-1

Muy buenas, he tardado mas, porque durante el fin de semana no estoy en la residencia...

 

Sí, en windows me va bien, de hecho ahora mismo estoy desde windows... y sí, estoy desde una lan, por cable, nada de wifi.

En cuanto a lo que me comentas de la puerta de enlace, resulta que he hecho el ipconfig y me salen dos  puertas de enlace predeterminadas. He probado con ambas a entrar por el navegador y me sale la página de firefox de 'Problema al cargar la página'. También he probado con la que me comentas que suele ser la predeterminada, por si las moscas, y tampoco funciona, me sale la misma página de antes... nada de ventanas de usuario y password...

 

Saludos, espero que puedas ayudarme. 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola elf...:

Desde Windows, conectado pulsa:

Inicio > Ejecutar > cmd  en la consola escribe: 

ipconfig /all

Copia y pega la salida en el post.

Desde Ubuntu ejecuta en consola:

sudo lspci

sudo ifconfig

Copia y pega las salidas en el post.

abre los archivos:

gedit /etc/network/interfaces

gedit /etc/resolv.conf 

Copia y pega su contenido en el post. 

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de elfio
+1
0
-1

Ok, ya he hecho todo lo que me pediste, aquí estan los resultados:

 

Aquí tienes el resultado de ipconfig /all

 

Aquí tienes las salidas de las cosas de ubuntu:

 


hago lspci

00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0c.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
01:00.0 VGA compatible controller: S3 Inc. Savage 4 (rev 03)

hago ifconfig

eth0      Link encap:Ethernet  HWaddr 00:C0:26:27:47:8A 
          inet addr:192.168.7.37  Bcast:192.168.7.255  Mask:255.255.252.0
          inet6 addr: fe80::2c0:26ff:fe27:478a/64 Scope:Link
          UP DIFUSIÓN CORRIENDO MULTICAST  MTU:1500  Metric:1
          RX packets:2673 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:1000
          RX bytes:264336 (258.1 KB)  TX bytes:8179 (7.9 KB)
          Interrupt:11 Base address:0x4000

lo        Link encap:Bucle local 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK CORRIENDO  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:0
          RX bytes:84 (84.0 b)  TX bytes:84 (84.0 b)

abro /etc/network/interfaces

auto lo
iface lo inet loopback

----

abro /etc/resolv.conf

# generated by NetworkManager, do not edit!

search bermejales

nameserver 192.168.2.7
nameserver 192.168.2.234
nameserver 195.76.138.3

 

 

 


Eso es todo.

 

 

Respecto a la conexión que me comentas en el otro post, he probado a hacer la pero tengo una duda: al final del todo, cuando pide especificar las ips a las que me voy a conectar que se notan así '172.168.0.1/16' o algo parecido, me encuentro algo perdido... que tengo que poner la ip del servidor vpn y al otro lado de la barra no se que poner...

Espero que me puedas resolver esta duda.

 

Saludos. 

 

 

 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola elf...:

Si lo que tienes es que configurar una vpn propia pueba:

Instalación:
En la barra de tareas, pulsar:
Aplicaciones -> Añadir y Quitar…
Una vez en el cuadro de diálogo correspondiente, en el campo “Buscar” escribir:
pptp
En el campo “Mostrar” seleccionar “Todas las aplicaciones disponibles”.
Aparecerá el Gestor de conexiones VPN (PPP Genérico) que se debe selecionar marcando la casilla que lo identifica.
Pulsar en “Aplicar cambios”
Una vez finalizada la instalación, reiniciar el sistema.

Configuración del acceso VPN PPTP
Pulsar con el botón derecho sobre el icono que identifica al Network Manager en la barra de tareas su icono aparece en la parte superior derecha de la pantalla, y muestra información acerca de la conexión de red.
Se desplegará un menú que deja seleccionar la opción:
Conexiones VPN -> Configurar VPN.
En el cuadro de diálogo que aparece, pulsar el botón “Añadir”
Se iniciará un asistente que nos guiará durante el proceso.
En el primer paso seleccionar “PPTP Tunel”.
En el segundo paso, hay varias pestañas. En la primera poner el nombre de la conexión. Debajo, indicar que es tipo Windows VPN (PPP) y poner la pasarela que es la IP del servidor VPN.
En la pestaña Autenticación marcar “rechazar EAP” y “rechazar CHAP”.
En la pestaña “Compresión y Encriptación” no tocar nada.
En la pestaña “Opciones PPP” tampoco tocaremos nada en principio.
En la última, “Enrutado”, deshabilitar “DNS del compañero a través del tunel” y marcar la opción “Sólamente utilizar VPN para estas conexiones:” Aquí tendremos que especificar la subred a la que queremos acceder por VPN.
En el campo donde se especifican las direcciones a la que accederemos por la VPN, pondremos la dirección IP de la red y su máscara, por ejemplo, 172.26.0.0/16 según esta notación si las direcciones ip son del tipo 172.26.0.1 con máscara 255.255.0.0
Una vez guardada la configuración al pulsar otra vez sobre el icono de la barra de tareas de Network Manager, y seleccionar Conexiones VPN, aparecerá la conexión que acabamos de crear y bastará con pulsar en ella para que nos pida usuario y contraseña. Si la conexión no aparece, pero ya la hemos configurado, (la vemos en la lista del cuadro de dialogo “Configurar VPN”), reinicia el sistema y aparecerá.

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de elfio
+1
0
-1

Uff ya empezaba a pensar que nadie me respondería y voy y me encuentro con esta sorpresa: ¡¡dos personas me han contestando!!

 

Lo primero muchas gracias a ambos por contestar. Voy a probar todo lo que me comentais tan pronto como pueda y ya os comento los resultados.

 

Saludos y muchas gracias de nuevo. 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola elf...:

Edita interfaces:

sudo gedit /etc/network/interfaces

Segun el post tiene solo esto: 

auto lo
iface lo inet loopback

Debe tener todo esto:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.7.137
gateway 192.168.7.254
netmask 255.255.252.0 
network 192.168.7.0 
broadcast 192.168.7.255  

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de elfio
+1
0
-1

Ok, lo edito y ahora te cuento.

 

Por cierto, me podrias aclarar el tema de la ip/16 esa, no se que significa ni como ponerla...

 

Saludos, a ver si conseguimos echar a andar esto... 

+1
0
-1
Imagen de elfio
+1
0
-1

Hola

 

Me temo que no es la solución al problema, o al menos no lo es totalmente. Me explico:

He hecho lo que me has dicho y he sustituido el contenido del archivo en cuestion por lo que me habias escrito. Resulta que cuando guarde el archivo (previo backup) ni si quiera reconocia los paquetes que tenia instalados para conectarme via vpn y tampoco reconocia la red a la que estaba conectado... hay una pagina que te salta en el navegador cuando reconoce la red pero no esta conectado y no salía...

¿Qué será? 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola elf...:

Pulsa con el botón derecho sobre el icono que identifica al Network Manager en la barra de tareas su icono aparece en la parte superior derecha de la pantalla, y muestra información acerca de la conexión de red.
Se desplegará un menú que deja seleccionar la opción:
Conexiones VPN -> Configurar VPN.
En el cuadro de diálogo que aparece, pulsar el botón “Añadir”
Se iniciará un asistente que te guiará durante el proceso.
En el primer paso selecciona “PPTP Tunel”.
En el segundo paso, hay varias pestañas.
En la primera poner el nombre de la conexión, bermejales.
Debajo, indicar que es tipo Windows VPN (PPP)
Poner la pasarela que es la IP del servidor VPN, 192.168.7.254
En la pestaña Autenticación marcar “rechazar EAP” y “rechazar CHAP”.
En la pestaña “Compresión y Encriptación” no tocar nada.
En la pestaña “Opciones PPP” tampoco tocar nada.
En la última, “Enrutado”
Deshabilitar “DNS del compañero a través del tunel”
Marcar la opción “Sólamente utilizar VPN para estas conexiones:”
Aquí tendremos que especificar la subred a la que quieres acceder por VPN.
En el campo donde se especifican las direcciones a la que accederas por la VPN:
Pon la dirección IP de la red y su máscara, 192.168.7.0 con máscara 255.255.252.0
Guarda la configuración.
Pulsa sobre el icono de la barra de tareas de Network Manager
Selecciona Conexiones VPN.
Aparecerá la conexión que acabas de crear.
Pulsa en ella para que te pida usuario y contraseña.
Si la conexión no aparece, pero ya la has configurado, (la ves en la lista del cuadro de dialogo “Configurar VPN”)
Reinicia el sistema y aparecerá.

Saludos. 

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de elfio
+1
0
-1

Hola que tal.

 

He hecho cuanto me has dicho, pero sigo sin poder conectarme...

No me queda claro lo ultimo de la ip y /16 ó /24 ¿eso que significa? lo que he hecho ha sido poner 192.168.7.000/24 espero que no esté mal y podamos descartar esto...

 

Saludos. 

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola elf...:

la /16 o 24 son los bits y va un solo cero final .0/16 ó .0/24

No se lo pongas. pon solo 192.168.7.0

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de elfio
+1
0
-1

Hola:

 

Lo he hecho tal y como me has dicho y no se conecta... es más, después de tratar de conectarme ya no vuelve a hacer el intento de conectarse, porque aunque yo trate de hacerlo es como si me ignorase...

Saludos. 

+1
0
-1
Imagen de BaTToSaY
+1
0
-1

hola, al parecer estamos en la misma residencia..

 

yo tb uso ubuntu

 

 

lograstes conectarte??

 

alguien podria ayudarme?

 

he echo todo como deciais 

 

en dirección IP de la red y  máscara: 192.168.7.0 255.255.252.0

donde pongo /16? y /24?

esque si no lo pongo no me deja aplicar T_T

 

necesito ayuda!

 

es una lástima dejar de usar ubuntu

pero sin internet no puedo hacer nada 

+1
0
-1
Imagen de xapusoft
+1
0
-1

Bueno, lo de /16 /24 es la máscara, para la que nos dan 25.255.252.0 seria /22 si no me equivoco.

Resulta que yo también estoy en la residencia y me acabo de instalar el Ubuntu que ha salido hace poco, pero he seguido los pasos que se indican aqui y no consigo conectarme. Me gustaría saber si hay novedades.

Gracias 

+1
0
-1
Imagen de elfio
+1
0
-1

Bueno, yo estoy un poco al tanto de las cosas nuevas... y la verdad nuevo, poco... se podria decir que lo unico nuevo que hay es la version del network-manager que trae hardy. tiene algunas opciones que antes no tenia, asi que quizas ahora sea mas facil que antes, pero no se nada mas :(

+1
0
-1
Imagen de xapusoft
+1
0
-1

lo máximo que he conseguido es conectarme a la red con el KVpn, o al menos eso me indica. Desactivo todas las opciones de la primera ventana, voy dejando todo igual, relleno nombre de usuario y contraseña, y le digo que se conecte a bras.bermejales (lo que nos indica nuestro administrador para windows), pero simplemente me dice que estoy conectado a ****@bras.bermejales (siendo **** mi usuario) pero en realidad sigue sin tener acceso a internet.

¿Qué hago mal? 

+1
0
-1
Imagen de herensuge
+1
0
-1

Buenas,

 

 No se si os servira de ayuda (espero que sí).

  Si la vpn se establece contra un equipo Cisco, entiendo que deberíais instalaros y usar vpnc (Ese es mi caso y funciona sin problemas).

 Si accedeis a la VPN correctamente (otros equipos dentro de la VPN) pero no accedeis a Internet, posiblemente esto se deba a que no hace el NAT debidamente para vuestros equipos. Algo bastante extraño, ya que os asignan ips del mismo rango y la salida en estos casos suele ser centralizada, realizando el NAT un equipo final (como por ejemplo un FW o router) para todas las conexiones de la VPN.

 En algunos casos, la VPN se utiliza para conectar a un equipo remoto, y se usan dos tipos de rutas, una para la VPN y otra para Inet, en este caso, un ip route por consola seria util.

 Si podeis, ejecutad por consola ip route antes de conectar a la vpn y otro despues de conectar.

 

Un saludo 

+1
0
-1
Imagen de herensuge
+1
0
-1

Buenas,

 

 No se si os servira de ayuda (espero que sí).

  Si la vpn se establece contra un equipo Cisco, entiendo que deberíais instalaros y usar vpnc (Ese es mi caso y funciona sin problemas).

 Si accedeis a la VPN correctamente (otros equipos dentro de la VPN) pero no accedeis a Internet, posiblemente esto se deba a que no hace el NAT debidamente para vuestros equipos. Algo bastante extraño, ya que os asignan ips del mismo rango y la salida en estos casos suele ser centralizada, realizando el NAT un equipo final (como por ejemplo un FW o router) para todas las conexiones de la VPN.

 En algunos casos, la VPN se utiliza para conectar a un equipo remoto, y se usan dos tipos de rutas, una para la VPN y otra para Inet, en este caso, un ip route por consola seria util.

 Si podeis, ejecutad por consola ip route antes de conectar a la vpn y otro despues de conectar.

 

Un saludo 

+1
0
-1
Imagen de sansatan
+1
0
-1

[Editado]

--------------------------------------

Un error muy frecuente: Confundir valor y precio.

+1
0
-1

--------------------------------------

Un error muy frecuente: Confundir valor y precio.