Como ejecutar un archivo .exe ??(Solucionado)

Imagen de sergi.fd
0 puntos

Hola a todos, acabo de instalarme un programa y un de los requisitos es activar la "license server".

Para ello, tengo que ejecutar un archivo llamado "vrlserver.exe" y seguir instrucciones, por lo que voy donde está tal archivo y ya sea haciendo doble click sobre el o con el botón dereccho abrir, no hace absolutamente nada.

Alguien sabe que puedo hacer para ejecutar este archivo ?

 

Gracias,

Sergi

Imagen de furtaxi
+1
0
-1

 Porque si hablas de una licencia, que se activa con un .exe, me da la impresión que es para Windows.

 Se puede ejecutar, pero danos más detalles, porque muy probablemente, no podrás usar la aplicación sin tener, de alguna manera, a Windows "dentro" de Ubuntu 

Saludos,

Roberto. (Alias Trolleador Implacable de Moderadores Tendenciosos)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de jaleos
+1
0
-1

¿Que es, para Ubuntu? Los .exe suelen ser de Windows por lo que en Ubuntu no corren directamente. Y si es un programa de Windows se puede probar a correrlo con Wine. Busca info en el foro, es un tema muy tratado ya.

 Saludos

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

 

+1
0
-1

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

DualCore Intel Core

Imagen de MagoDeOz85
+1
0
-1

Los .exe solamente son ejecutables en Windows, Ubuntu es GNU/LInux.

Un saludo. 

]<----- FacilWare ----->[

-_ y no te compliques _-

-__________________-

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************

Imagen de sergi.fd
+1
0
-1

Pues se trata de Vray un motor de render muy bueno que se instala como pluguin para maya, en este caso.

Siguiendo las instrucciones del fabricante y la ayuda de furtaxi, ya he instalado el programa con un .exe y todo bien, pero ahora debo activar la licencia

 

_________________________________________________________ 

Instrucciones: 

... For example:
 
   cd VRAY_INSTALL_DIR
   su
   ./linuxinstaller.exe
   <follow installer instructions>
   exit
 
III. Setting up the V-Ray license server
========================================
 
(A) On the machine where you will be running the license server:
 
1) If you have not installed a V-Ray license key previously, after installation
   is complete and still with root permissions, run the V-Ray license server,
   located by default in the "/usr/autodesk/maya/vray" folder:
 
   /usr/autodesk/maya/vray/vrlserver.exe

...

 

Sergi 

 

+1
0
-1
Imagen de furtaxi
+1
0
-1

 No me fijé que eras tú. Pues es algo un poco complicado, porque, muy seguramente, éste programa intentará conectarse a internet, así que no sé si con Wine, se podrá. Inténtalo como primera opción, es bastante fácil y rápido.

 

Dame el enlace del programa, y doy una mirada, a ver si dice algo de GNU/Linux. 

Saludos,

Roberto. (Alias Trolleador Implacable de Moderadores Tendenciosos)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de sergi.fd
+1
0
-1

El enlace del programa es este

http://www.chaosgroup.com/

Lo que dices que intentará conectarse a internet, no lo se seguro, pero diría que no.

Tampoco creo que sea solo para Windows, ya que all solicitar el plug-in me facilitaron las instrucciones especificas para linux.

Lo que debo hacer es ejecutar el archivo vrlserver.exe, desde alli generar un "license request" y enviar el resultado al fabricante para que me de un "license key". Siento lo del inglés pero no se como traducirlo.

Gracias,

Sergi 

+1
0
-1
Imagen de furtaxi
+1
0
-1

Podrías copiarlo a un diskette o pendrive, y ejecutarlo en otro ordenador con Windows, pero en las instrucciones te dice que tiene que ser desde el que vas a usar.. o sea, que te pillan datos de la máquina:

(A) On the machine where you will be running the license server:

Así que intenta con Wine, esperemos que el resultado lo puedas luego copiar y pegar, y mandársela por e-mail .

Tienes wine en los repositorios de synaptic. Es bastante rapidillo de instalar. una vez que éste, debería arrancar sólo con un doble click.

Edito: He entrado al enlace, pero sin registrarme, no me deja ver ni el foro. Prueba tu, que tendrás acceso, a ver si alguien puso el mismo problema.

Saludos,

Roberto. (Alias Trolleador Implacable de Moderadores Tendenciosos)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de sergi.fd
+1
0
-1

Ok ! Pues tengo windows tambien instaldo en el disco duro, asi que puede que la cosa aún se pueda salvar, jjj

Miré en los foros del fabricante y nadie comneta nada parecido.

En tal caso, haré lo que comentas de ejecutarlo bajo windows en mi máquina y si no hay problemas les enviaré el request ese explicando lo que he hecho y si no va bien espero que me den una solución

 Muchas gracias por tu ayuda !!

Sergi 

+1
0
-1
Imagen de c0kit0_2oo7
+1
0
-1

Si se intenta conectar a internet.. puede instalar wine-tools de getdeb.net, creo que al instalar winetools te instala internet explorer 6... supongo que asi no tendría problema (ahora leere mas abajo a ver q hay)

EDITO, jejee, no habia tanta cosa debajo de mi post xD 

---------------------------------------------------------

GNU/Linux MyBstFrnd Be4 ask'n look & srch...

+1
0
-1

---------------------------------------------------------------------------
lestat@esdebian.org

Imagen de conradoat
+1
0
-1

¿Has probado a ejecutar el programa desde la consola?

Si entiendo bien, has intentado operar sobre el programa con el raton, pero aparentemente la instalación que has hecho se realiza desde la línea de comandos.

 El que un programa acabe en ".exe" no implica que sea de windows.

un saludo

 

+1
0
-1

-----
ubuntu-user: #15713
linux-user: #259266

Imagen de sergi.fd
+1
0
-1

aún no se bien que hago a través de la consola, yo diría que si lo probé. Lo que hice es :

cd /usr/autodesk/maya/vray para ponerme en el direcctorio

sudo su para obtener permisos y pongo contraseña

./vrlserver.exe para ejecutar el .exe

y me da este error: ./vrlserver.exe: error while loading shared libraries: libtiff.so.3: cannot open shared object file: No such file or directory

 

Creo que es así,no?

 

Gracias,

Sergi

+1
0
-1
Imagen de MagoDeOz85
+1
0
-1

Instala la libreria que te pide, y vuelvelo a ejecutar, si te pide algo mas instalalo tambien, hasta que funcione XD

Un saludo. 

]<----- FacilWare ----->[

-_ y no te compliques _-

-__________________-

+1
0
-1

*****************************************************************

¡Libresfera, la revista libre!

*****************************************************************

Imagen de jaleos
+1
0
-1

http://www.ubuntu-es.org/index.php?q=node/45914

Saludos 

 

 

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

 

+1
0
-1

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

DualCore Intel Core

Imagen de sergi.fd
+1
0
-1

Pues al final lo que pasba era que faltaba instalar lo de libiff.so.3 y gracias al tutorial mandado por jaleo todo fue fino.  Por lo que pude ejecutar ese archivo .exe en Ubuntu

 

Muchas gracias a todos por vuestra ayuda !!

Sergi

+1
0
-1
Imagen de jaleos
+1
0
-1

Enhorabuena, me alegro que te sirviera.

Saludos 

 

 

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

 

+1
0
-1

-----------------------------------------------------------------------------------------------------------------------------------------------------

Un poco de GRUB y Super Grub Disk

http://jaleos.wordpress.com/

DualCore Intel Core

Imagen de conradoat
+1
0
-1

No he podido mirar la respuesta antes. Veo que ya esta solucionado.

Sí, era así, sergi.

Suerte

 

 

+1
0
-1

-----
ubuntu-user: #15713
linux-user: #259266

Imagen de ofuscado
+1
0
-1

Antes de nada comentar un par de cositas muy sencillas pero básicas para no crear más confusión. Lo de el .exe ha sido idea de los graciosillos de ChaosGroup ya que es una extensión inventada por ellos, por q en realidad no es un binario de windows, en realidad es un binario de linux ¿como puede alguien saber que es un archivo tenga la extensión que tenga? pues muy fácil:

Ejemplo:
file linuxinstaller.exe
linuxinstaller.exe: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), not stripped

Como bien dice ahí es un ELF executable (de 64bits en mi caso) que es el tipo de archivo binario común en linux.

Una vez teniendo esto claro... Nada de wine ni historias raras...
Los ejecutables se ejecutan con ./ejecutable o con sh ejecutable.

Yo tengo otro problema y es q en /usr/autodesk/maya/vray/vrlserver.exe no tengo ese archivo, no existe.
Tengo la version de vray: vray_demo_08523_maya2008_linux_x64.zip y claro me falta el binario del vrlserver...
He visto que tengo un /usr/autodesk/maya2008-x64/vray/bin/vrlserver pero es un shell script y dentro contiene:

#!/bin/bash
export LD_LIBRARY_PATH=/usr/ChaosGroup/V-Ray/Standalone_for_linux_x64/lib/linux_x64/gcc-4.1
/usr/autodesk/maya/vray/vrlserver.exe $*

Si lo ejecuto:
./vrlserver
./vrlserver: line 3: /usr/autodesk/maya/vray/vrlserver.exe: No existe el fichero o el directorio

Como es evidente no existe el archivo...
Así que no soy capaz de poder usar el vray por q me falta ese archivo ¿alguien sabe algo?

Gracias.

+1
0
-1
Imagen de ofuscado
+1
0
-1

Vale por lo visto en la versión Demo para linux no existe ese archivo por q no hace falta licencia para usar la Demo.

+1
0
-1