Driver de ati en amd64

Hola a todos.

Tengo instalado el Ubuntu 64 en un compaq 2225AE con la gráfica de ATI Xpress 200M. Al principio tenía puesto en el xorg.conf la opción de noaccel pero viendo que en la página de ATI tienen el driver y leyendo en este portal que había mucha informacion sobre como instalarlos me decidí a ponerlos ya que pasa usar blender que es lo que más amenudo hago me vendría de perlas tener la aceleración 3D en la tarjeta de video.

Al lío, el caso es que instalo todo siguiendo los hilos:
http://www.ubuntu-es.org/node/7161
http://www.ubuntu-es.org/node/5571

En principio va todo bien, no me da errores instalar los headers ni el driver. Pero al hacer glxgears pone:

"error while loading shared libraries: libGL.so.1: Cannont open shared or object file"

Veo que puede ser un problema por tener librerías 64 que por algún motivo no se entere mi PC de donde están las cosas. A este pensamiento no llego solito claro se me ocurre leyendo esto http://libertonia.escomposlinux.org/comments/2004/10/14/111535/64/2?mode... lo malo es que no tengo tanta idea como para poder solucionar esto.

Ya he escrito en el post http://www.ubuntu-es.org/node/5571 pero creo que es más conveniente crear uno dentro de AMD64 ya que parece que es un problema especifico de la distribución para esta arquitectura.

Imagen de verderi
+1
0
-1

Para instalar los drivers de Ati

1. Entras en la web de ati i te descargas los drivers en el escritorio

Controladores y Software > Linux > Linux x86 > FireGL > FireGL V Series ati-driver-installer-8.14.13.run y lo ejecutas con la consola root ./ati-driver-installer-8.14.13.run y lo configuras con este comando en la cosola de root glrxconfig

2. Acceleración de ati en la consola tecleas:

sudo apt-get install xorg-driver-fglrx

echo fglrx | sudo tee -a/etc/modules

depmod -a

tee -a /etc/modules

gedit /etc/X11/xorg.conf and change "ati" to "fglrx", perhaps

y por ultimo Reinicias el PC

En depmod -a se te puede quedar la consola bloqueada da igual esperas un rato y la cierras y sigues con los pasos :P

+1
0
-1
Imagen de albano
+1
0
-1

Tengo una tarjeta Xpress 200 M de ATI para portatil. Mis drivers son los de FireGL V Series.
¿Esas tarjetas no son de la gama profesional de ATI?
Es decir me funcionaría ese driver con mi tarjeta, de momento estaba intentandolo con los de "ATI Proprietary Linux x86_64 Driver 8.16.20 for Radeon Xpress 200 Series" pero claro no me fucnionan.

Por ahora he hecho lo mismo que me has dicho pero con los drivers que ya tengo descargados y el startx me devuelbe: "No devices detected".

Probaré a ver.

+1
0
-1
Imagen de gabiel
+1
0
-1

El controlador para las x200 es el que utilizabas en principio "ATI Proprietary Linux x86_64 Driver 8.16.20 for Radeon Xpress 200 Series"; pero a día de hoy dan muchos problemas, el módulo del kernel da bastantes problemas al compilarlo (sin él olvidate de la aceleración 3D), si consigues compilar el módulo tienes que desactivar la memoria dedicada de la x200 y compartir la ram del sistema (desde la bios del portátil) o en caso contrario el servidor gráfico se colgará al arrancar. En definitiva, habrá que esperar a que Ati publique la próxima versión de los controladores y esperar que resuelva los problemas actuales.

Saludos.

PD: En estos foros puedes encontrar información sobre otro portátil con una x200, lleban bastante tiempo probando, así que igual puedes encontrar algo que te ayude.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de albano
+1
0
-1

Gracias por contestar. En fin esperaré a que salgan los nuevos drivers. De montento estoy tirando sin aceleración 3D.
Ahora me intentaré instalar la wifi que también se las trae.

Un saludo.

¿Cuando venderán portatiles con Linux preinstalado? :P

+1
0
-1