problemas con spamassassin

Imagen de bislandry
0 puntos

Tengo un servidor de correos Ubuntu 6.06 con Postfix y usuarios virtuales en
LDAP. Estoy incluyendole spamassassin y clamav para que funcionen a
traves de amavisd-new. La idea es esta:

                                    [SpamAssassin]
                                            ^
                                            |
Email --> [(25) Postfix] -->[(10024) amavisd-new] -->[(10025) Postfix]
                                            |
                                            v
                                        [ClamAV]

El problema que tengo es que el spamassassin parece que no se entera de
que el amavis lo esta llamando. En los encabezamientos de los emails
estan las marcas del clamav, y si mando un virus este lo detecta. Pero
el spamassassin no deja ninguna marca en los encabezamientos ni en los
logs.

En el fichero /etc/default/spamassassin la variable ENABLE=0 (tambien
probe con ENABLE=1). En local habilite el uso de los clasificadores
bayesianos(aunque este viene por defecto)

El fichero /etc/amavis/conf.d/15-content_filter_mode del amavis tienes
lo sgte:
#########################
use strict;
@bypass_virus_checks_maps = (
\%bypass_virus_checks, \@bypass_virus_checks_acl, \
$bypass_virus_checks_re);
@bypass_spam_checks_maps = (
\%bypass_spam_checks, \@bypass_spam_checks_acl, \
$bypass_spam_checks_re);
1; # insure a defined return
##########################

Alguien me puede dar una ayuda??

Saludos,
Billy Vejo