jdk en sparc

Imagen de trucutrucu
0 puntos

hola que tal, tengo un servidor sun ultrasparc, que tiene instalado ubuntu 7.10, pero al momento de tratar de instlarle el jdk fuese la version que fuese, me saca este error:

despues de que le daba 

chmod -x jdk-6u2-linux.i586.bin

./jdk-6u2-linux.i586.bin 

despues de toda la documentacion me pregunta que si estoy de acuerdo y le digo que si y me aparece:

 

 unpacking...

checksumming

extracting...

./install.sfx.4938: 1 Syntaxis error: "(" unexpected

failed to extract the files. please refer to the Troubleshooting section of the

Instalation Instruction on the download page for more information. 

 

como lo puedo arreglar???

un error parecido me paso en ubuntu 6.06.01, la veradd no recuerdo bien, pero era algo asi como 

./install.sfx.4938: 1 Syntaxis on line 388 (no recuerdo bien, pero era algo parecido)

 

el chiste es que ni en esa version ni esta que tengo ahora puedo instalar el jdk, existe la posibilidad de que

sea por tipo de arquitectura que es sparc???? porque ese mismo jdk lo instale en mi lap y si quedo, no me marco

ningun error.

 

gracias de antemano por su ayuda