Ada en Ecplise

Imagen de Javier M.
+1
0
-1

Siento no tener la respuesta, pero me surge una duda...

Para programar en ADA por qué no usas gnat que tambien viene en los repositorios?

Un saludo.


Equipo de moderadores de Ubuntu-es
Normas

Documentación

 

+1
0
-1
Imagen de Javier M.
+1
0
-1

Parece que no estaba tan lejos.

Lo que buscas es el gnatbench que lo puedes descargar desde aqui.

De todos modos sigo con la misma duda. Por qué no utilizas el gnat-gps?

Un saludo.


Equipo de moderadores de Ubuntu-es
Normas

Documentación

 

+1
0
-1
Imagen de Necrotzar
+1
0
-1

 

recien termino de instalar gnat-gps, si sabes de alguna forma para españolzarlo o de algun manual de usote lo agradeceria.

en cuanto al plugin gnatbench no encuentro el linck de descarga en la pagina que me pasaste.

+1
0
-1
Imagen de Javier M.
+1
0
-1

Vaya, pense que te habia dado el link de la descarga, pero parece que siempre redirecciona a la pagina principal.

Fijate en la parte de la derecha y pica el segundo link ( download GNAT GPL edition ), en la pagina que se abre, en la carpeta GPL esta para descargar el gnatbench.

Para traducir el GPS, la verdad es que no lo se, yo lo uso en ingles pero voy a mirar.

Un saludo.


Equipo de moderadores de Ubuntu-es
Normas

Documentación

 

+1
0
-1
Imagen de Necrotzar
+1
0
-1

gracias javier... logre descargar el plugin... el detalle ahora es como instalarlo.. 

trate de hacerlo por mi cuenta pero termine reinstalando el eclipse. jaj..

+1
0
-1
Imagen de yago83
+1
0
-1

El camino más rápido para usar Ada con Eclipse, para mi ha sido instalar GNAT por mi cuenta, para ello me lo he descargado de aqui (tendreis que registraros) a continuación instalar GNAT con el scrip (hacerlo con sudo). Seguidamente podreis descargaros el plugin de esta página que se llama GNATbench e instalarlo a partir de su script, aunque yo me he declinado más por el uso de Aonix ,el cual es muy sencillo de instalar desde Eclipse, bastan con irnos a Ayuda>Actualizaciones de Software>Buscar e instalar, una vez aqui nos vamos a Buscar caracteristicas nuevas para instalar>Sitio Remoto nuevo, y ponemos Nombre:(lo que queramos) URL:http://www.aonix.com/adt_update  y ya esta. Yo uso Eclipse 3.2( primero por que lo puedo poner en español (lo de Ada no viene)) y segundo por que estoy mas familiarizado con él), nota: no se si valdra para versiones posteriores.

A programar! 

Yago 

+1
0
-1

The past is gone but the future is mine

Imagen de Necrotzar
+1
0
-1

e seguido tus pasos para instala aonix en eclipse...

pero cuando lo quiero instalar me aparece el siguiente error cuando lo selecciono

Eclipse BIRT Doc (2.2.2.r22x_v20071015-110-s332Aw31181_2_) necesita característica "org.eclipse.datatools.doc.user (1.0.0)" o una versión

te comento que mi vercion de eclipse es la 3.2

 y cuando pido detealle de error esto es lo que me devuelve

 La configuración actual contiene errores y esta operación puede tener resultados impredecibles.
Eclipse BIRT Doc (2.2.2.r22x_v20071015-110-s332Aw31181_2_) necesita característica "org.eclipse.datatools.doc.user (1.0.0)" o una versión posterior.
Eclipse BIRT Chart Runtime Feature (2.2.2.r22x_v20071015-7Y8l7DMVg4-_6uC7tmU8Y) necesita característica "org.eclipse.emf.ecore.sdo (2.2.0)" o una versión posterior.
Eclipse BIRT Report Runtime Feature (2.2.2.r22x_v20071015-7U7U7RBs-_N6u3VW7eooU) necesita plug-in "org.eclipse.tomcat (4.1.130)" o compatible.
Eclipse BIRT Example (2.2.2.r22x_v20071015-7C7C7A55QQBJZTFDqGIOV) necesita plug-in "org.eclipse.tomcat (4.1.130)" o compatible.
Data Tools Platform Model Base (0.9.1.200609201) necesita característica "org.eclipse.emf.ecore.sdo (2.1.0)" o una versión posterior.
Eclipse BIRT Report Designer Feature (2.2.2.r22x_v20071015-7U7U7TB8R573QDLV82yqWWX8fppV) necesita plug-in "org.eclipse.tomcat (4.1.130)" o compatible.

y no me doy cuenta de como solucionaro... 

+1
0
-1
Imagen de yago83
+1
0
-1

Haber, el problema que tienes creo que no es problema por instalar 

Aonix, sino por que no tienes instalado BIRT,  Yo uso la version de

eclipse 3.2, y BIRT creo que es para utilizarlo con J2EE, y no tiene( en

principio que influir). Cómo creo que puedes solucionarlo, pues instalando completamente BIRT, o desinstalando los jar's que tengas de BIRT. Ayuda>Actualizaciones de Software>Buscar e instalar>Buscar caracteristicas nuevas para instalar>Siguiente>

 Y en principio te tiene que aparecer una lista de sitios de busqueda, entre ellos Aonix, y donde pone Bussiness Intellegence and Reporting Tool, lo marcas y dejas de que se actualize.

Si ves que tienes problemas, puedes optar por el camino rápido,desmarcar

todas y volver a actualizar todo, yo de todos modos antes de instalar 

Aonix, actualice todo.

Espero que te haya servido de ayuda :-) 

The past is gone but the future is mine

+1
0
-1

The past is gone but the future is mine

Imagen de Lit0s
+1
0
-1

Me acabo de instalar ada en eclipse, tengo la versión 3.2 y acabo de instalar la versión de aonix, el problema es que a la hora de crear un nuevo proyecto no me encuentra ningún compilador y me dice que no se encuentra el toolchain y no me deja avanzar, he probado a descargarme todos los compiladores de gnat que hay en synaptics y nada, no se que hacer, teneis alguna idea?

Muchas gracias :)

+1
0
-1