Joysticks/gamepads en Ubuntu

Imagen de nachokankunen
0 puntos

Hola a todos

Hace poco que he instalado Ubuntu en mi ordenador y la verda q estoy muy completo, la detección de hardware ha sido muy buena y con apitude genial para instalar nuevos programas.
Bueno a lo q iba. Tenog un Gravis Xterminator digital pad y me gustaria usarlo en los emuladores tipo Xmame y asi. He buscado información en interne y en el foro pero no he visto nada claro. ¿Alguien podria orientarme un poco en el tema?
Gracias y un saludo a todos

Imagen de gabiel
+1
0
-1

Por lo que he visto, ese pad se encuentra soportado. Enchufalo y debería reconocerlo, para configurarlo puedes usar un programa llamado jscalibrator (se encuentra en universe).

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola

Gracias por el consejo, lo unico q no debo tener esa aplicación instalada pq no me arranca desde un terminal y tp veo algo similar en las herramientas. Puedo hacer un aptitude install jscalibrator? ¿necesitaré algo más?
Gracias de nuevo por la ayuda

+1
0
-1
Imagen de gabiel
+1
0
-1

Efectivamente tendrás que instalarla; no crea ninguna entrada en los menús, así que tendrás que recurrir a la terminal o crear una entrada para el programa en los menús.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola de nuevo

Ya siento ser tan pesadillo pero todavia no me defiendo mucho con estas cosas.
Arranco la aplicación y me da un error al inicializar el Joystick. El caso es q ya esta conectado al puerto de jeugos de mi SB live. El resto de opciones q he visto son como para abrir algun archivo de configuración, pero q obviamente no tengo. ¿Me puede faltar algun driver o asi?
Un saludote

+1
0
-1
Imagen de gabiel
+1
0
-1

¿Cual es error que devuelve?

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Pues el error q me da nada más arrancar la aplicacion es este:

"Could not access the especified path(s), verify that the path(s) are specified correctly and that you have sufficient permission to access them. Also make sure that the joystick in question is actually connected, turned on (as needed), not in use by another program, and that the joystick driver or module is loaded (type 'modprobe ')."

El joystick está conectado y no tiene boton de encendido. Lo de modprobe no lo he podido hacer porque no se el nombre del driver, siquiera si tengo alguno instalado para el joystick, desde luego yo no lo he instalado, como no viniese con el propio Ubuntu va a ser q no :P

+1
0
-1
Imagen de gabiel
+1
0
-1

En principio sí se incluyen los controladores necesarios, tan solo te faltará cargarlos; si tienes una SB Live que esté soportada por el módulo emu10k1 carga el siguiente módulo para el puerto de juegos emu10k1-gp, y este otro para el joystick grip.

Si funciona añade el nombre de los módulos al archivo /etc/modules para que se carguen automáticamente.

Saludos.

PD: Para cargar los módulos ejecuta sudo modprobe "nombre_modulo"

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola, perdona si tardo en responder, ando liadillo
Muchas gracisa ahora ya no da ninún error y me carga bien el driver y todo para poder calibrar el Joystick.
El caso es q cuando le doy a calibrar los movimientos no se corresponden correctamente con lo q se ve, me explico.
El Joystick tiene 10 botones q funcionan y detecta bien. Luego tiene un mando digital y otro analogico, el analogico funciona perecto, pero el digital no aparece representado, aunq no me preocupa. Luego tengo un boton despazable como si fuese un acelerador q parece pillarlo bien. El problema viene con dos botones q por decirlo de alguna manera son de presion graduable, uno hacia la izq y otro a la derecha. Pos bien segun el grafico uno de esos botones mueve una cosa y el otro otra distinta y lo mismo con el ultimo boton es como un mini joystick de 4 direcciones q lo mismo, los movimeintos no se corresponden con la representación.
Debo de ser el tio más pregunton de por aqui, ya perdonaras :P ¿Sabes si será cosa de tocar más o menos el calibrado o si kizas será cosa del driver del puerto de juegos o asi?
Espero no darte mas la turra y en serio muxisimas gracias or la ayuda

+1
0
-1
Imagen de gabiel
+1
0
-1

La verdad es que la representación de los controles en ese programa es un poco "curiosa", en principio, si es capaz de asociar un valor a cada botón funciona bien; lo único que queda es que lo prubes en alguna aplicación a ver que tal funciona (me viene a la cabeza MAME ;) ).

Saludos.

PD: Yo también he estado un poco liado y por eso he tardado. De todas formas no te preocupes por preguntar todo lo que haga falta, los foros están para eso.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Despues de pelearme un poco para instalar el xmame, he probado con algunas roms y funciona mu bien.
Muchisimas gracias por la ayuda :D

+1
0
-1
Imagen de kanibalv
+1
0
-1

por favor, me tira el error cuando ejecuto:
sudo jscalibrator /dev/js0
El error es:
"Could not access the especified path(s), verify that the path(s) are specified correctly and that you have sufficient permission to access them. Also make sure that the joystick in question is actually connected, turned on (as needed), not in use by another program, and that the joystick driver or module is loaded (type 'modprobe ')."

Por lo que supongo que debo cargar los modulos y/o activar el puerto de juego de mi tarjeta de chip FM801, la Genius Sound Maker 32x2. Ent. cuales modulos me sirven y/o como activo el puerto.

Cualquier ayuda la agradeceria mucho.

Kanibal

+1
0
-1

Kanibal.-

Imagen de kanibalv
+1
0
-1

encontre como abrir el puerto en : http://www.ubuntuforums.org/showthread.php?t=55173&

ahora me lo reconoce en el /dev/js0, pero me indica 4 ejes, 4 botones y al el "eje y" me sale al revés, habria alguna forma de poder arreglar esto?

Kanibal

+1
0
-1

Kanibal.-