¿Compiz es imposible con ATI Radeon 9250?

Imagen de downward
0 puntos

Hola a todos, mi equipo es un AMD 2800+, 512 en RAM, tengo una ATI Radeon 9250, he buscado la solucion a mi problema en decenas de foros, pero ninguno lo ha resuelto, soy casi nuevo en linux, de hecho solo tengo 6 meses con el y por nada regreso a windows, lo que pasa es que actualice el Ubuntu 7.4 Feisty a 7.10 Gutsy y al tratar de habilitar compiz fusion en Sistema›Preferencias›Apariencia›Efectos visuales y cambio el estado a personalizado, la ventana se pone en blanco y negro y automaticamente se cambia a la opcion ninguno y me sale el aviso: Desktop effects could not be enabled.

Luego cuando pongo en terminal compiz --replace (tambien lo he intentado con compiz -replace, emerald theme etc.) me aparece:

Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:5960 (rev 01) (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity/home/downward/.themes/marble-look/gtk-2.0/gtkrc:49: Clearlooks configuration option "sunkenmenu" is not supported and will be ignored.

Cuando pongo en terminal: glxinfo

name of display: :0.0
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 8x x86/MMX+/3DNow!+/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.0.1
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x24 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x25 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x26 24 tc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x27 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x28 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x29 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x2a 24 tc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x2b 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x2c 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x2d 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x2e 24 dc 0 32 0 r y . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x2f 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None

0x30 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 0 0 0 0 0 0 None

0x31 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow

0x32 24 dc 0 32 0 r . . 8 8 8 8 0 24 0 16 16 16 16 0 0 Slow

0x5b 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

Cuando en Terminal pongo glxgears si los puedo visualizar y la lectura es la siguiente:

14811 frames in 5.0 seconds = 2956.680 FPS
29374 frames in 5.0 seconds = 5851.878 FPS
32504 frames in 5.0 seconds = 6489.609 FPS
34315 frames in 5.0 seconds = 6850.626 FPS
34654 frames in 5.0 seconds = 6915.056 FPS
35106 frames in 5.0 seconds = 6988.867 FPS
35106 frames in 5.0 seconds = 7019.572 FPS
34880 frames in 5.0 seconds = 6974.785 FPS
34202 frames in 5.0 seconds = 6825.711 FPS
29569 frames in 5.0 seconds = 5911.038 FPS
34428 frames in 5.0 seconds = 6873.968 FPS

Mi configuracion Xorg es:

# xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ImPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "stylus"

Option "Device" "/dev/input/wacom"

Option "Type" "stylus"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "eraser"

Option "Device" "/dev/input/wacom"

Option "Type" "eraser"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "cursor"

Option "Device" "/dev/input/wacom"

Option "Type" "cursor"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "Device"

Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO]"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "COMPAQ 7550"

Option "DPMS"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies Inc RV280 [Radeon 9200 PRO]"

Monitor "COMPAQ 7550"

DefaultDepth 24

SubSection "Display"

Modes "1600x1200" "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Option "AIGLX" "true"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet

# InputDevice "stylus" "SendCoreEvents"

# InputDevice "cursor" "SendCoreEvents"

# InputDevice "eraser" "SendCoreEvents"

EndSection

Section "DRI"

Mode 0666

EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Espero que me puedan ayudar porque ya estoy perdiendo las esperanzas, porque lo he intentado casi todo el emerald theme, los controladores ATI que descubri que para mi tarjeta son muy malos, instale el xserver-xgl pero tampoco funciona el compiz y solo hace que mi computadora se alente asi que los inabilite haciendo un archivo llamado disable, etc; ahora, pienso que si se ven los engranes del glxgears creo que estoy a un paso de lograr que compiz corra en mi computadora pero no lo encuentro, y lo mas raro es que en Feisty todo estaba de maravilla con el compiz fusion, por logica pienso que esto debe ser un problema menor de configuracion, despues de mucho moverle al sistema y hacer un "batidero" trate de dejar todo en la configuracion original. No creo que sea problema de Ubuntu o si? debo hacer un downgrade a Feisty?

espero que me puedan ayudar, gracias. 

Imagen de mardukk
+1
0
-1

amigo yo estube una semana tratando de hacer funcionar compiz con una ati radeon 9550 y lo probe todo sin resultados, afortunadamente  me encontre con envy el cual me instalo la tarjeta de video y soluciono el problema ahora estoy disfrutando de compiz y todas sus funciones, recomiedo 100 % el uso de envy para las ati.

+1
0
-1
Imagen de Sanguinario_Joe
+1
0
-1

Yo como siempre hago publicidad de mi tutorial, y la hago porque tengo una muy baja siniestralidad

[COMO] Intalar drivers ATI, con AIGLX, aceleracion3D, y compiz-fusion funcionando completamente (v1.4 del tuto)

(Si no te funciona el link usa el buscador con ese mismo nombre)

No recomiendo el envy bajo ningun concepto, y no soy el unico...El envy te instala lo que le parece oportuno, y puede acabes teniendo el cubo, pero sin aceleracion 3D (porque te instale xgl), hay gente que le ha ocurrido que le ha jodido la interfaz grafica y ha tenido que restaurarla quitando el xorg.conf, y luego han tenido que borrar los drivers (no sin complicaciones, porque como no sabes que te ha metido...)

En fin, tambien habra mucha gente a la que le haya ido de hongos (pero yo veo demasiadas quejas por ahi...Por aquello del que el que mas sufre es el que mas grita)

Tu veras...

Saludos!!! 

 

+1
0
-1
Imagen de theboss22
+1
0
-1

Bueno compa;ero sanguinario_joe yo logre hacer funcionar mi ati radeon xpress 1100 en Ubuntu Gutsy Gibbon que viene integrada en la tarjeta y hasta donde he leido es una 300 no se que mas, el caso es que me ha funcionado perfecto salvo por la cuestion de que al momento de irme a Sistema>Preferencias>Apariencia>Efectos Visuales me marcaba "The Composite extension is not available" instalando el paquete xserver-xgl. simplemente instalando comando

¤ sudo aptitude install xserver-xgl

 reiniciar el equipo y listo.

 

bueno por lo demas pues excelente el tuto que pusiste muy agradecido en lo personal pues soy totalmente nuevo en esto y aprendiendo cosas nuevas, claro buscando y buscando encontre solucion a mi problema...

 

saludos.. 

+1
0
-1
Imagen de downward
+1
0
-1

Gracias a los dos, pero el problema consiste en que no hay drivers propietarios para la tarjeta Radeon 9250, AMD les dejo de dar soporte y por ende los drivers nuevos no funcionan, y los viejos que si soportan la tarjeta no funcionan bien con Ubuntu Gutsy asi que recomiendan que se usen los drivers libres de Ubuntu pero con estos no "jala" el Compiz Fusion de hecho cuando me voy a Sistema›Administracion›Gestor de controladores Restringidos me devuelve el siguiente mensaje> Su hardware no necesita controladores privativos.

Gracias, y espero que me puedan ayudar :) 

+1
0
-1
Imagen de Festor
+1
0
-1

 La Radeon 9250 de ATi funciona perfectamente con Compiz Fusion de Ubuntu 7.10

(no sé si funciona bien con las versiones instables de Compiz Fusion que circulan por la red...)

Digo esto porque yo la tengo y lo sé por experiencia :D

Además tambien tiene aceleración gráfica automatica desde la instalación.... SIN HACER NADA :D 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de kifto
+1
0
-1

yo creo qyue la cosa puede ir quizas por lo que dice festor...a ver , yo me lo he bajado todo de los repositorios y tal...¿incluso ahí puede haber versiones inestables de aplicaciones para ubuntu?

 o quizas tambien se deba a que algunos somos un poco tarugos y hemos probado demasiados tutoriales y opciones, y puede ser que por el camino hayamos desconfigurado algo, etc...

yo lo que se es que llevo ya para 2 meses bregando con mi ATI radeon 9550, y sigo sin compiz...y tener ubuntu asi, un poco capado en efectos gráficos, pues que da rabia... 

yo hay 2 cosas que no he probado, lo del envy y lo de instalar lo de Xgl...pero creo que lo demas, casi todo lo que he visto

Eso si, el PC me funciona bastante bien, tengo direct rendering, tengo aceleración 3D (me sale el cubo girando y bastante rápido), tengo el controlador para tarjetas graf ATI  en uso, creo que ya tengo el monitor bien configurado despues de un tiempo viendo si la cosa podía ir por ahí...tambien he mirado y tratado de hacer tropecientos tutoriales...

 A mi hay un par de cosas que siguen sin quedarme muy claras, por ejemplo, al poner fglrxinfo creo que me sale que no tengo los últimos drivers de ATI:

kifto33@kifto33-desktop:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon 9550 / X1050 Series
OpenGL version string: 2.0.6473 (8.37.6)


ahora bien, son esos drivers correctos? . mi tarjeta es una radeon 9550, y pone ahí que de la serie X1050, y segun veo, los drivers 8.42.3 son para la serie 9600...Por lo que yo veo, yo tengo instalados los drivers 8.37.6; y los ultimos que hay son los 8.42.3(los que funcionan en la serie 9600)...lo que quiero saber es si los que tengo son los ultimos que hay para mi tarjeta o si los drivers 8.42.3 tambien me valen para mi radeon 9550, y son los que debería tener para poder usar los efectos de escritorio.

Me valdría de algo el envy para esto? 

Tambien, mirando por otros lados, si ejecuto "compiz" desde la terminal:

kifto33@kifto33-desktop:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:4153 (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity

no se si eso del Xgl tendrá tambien algo que ver, por que por lo que leo, se recomienda no instalarlo...

+1
0
-1
Imagen de Festor
+1
0
-1

ATI Radeon 9550 / X1050 Series

Significa el conjunto de tarjetas desde la 9550 hasta la x1050 que usan el mismo controlador.

A ver... actualmente hay 3 controladores para ATI:

* Uno libre y que soporta un amplio rango de tarjetas (creo que el mayor de todos) pero que sólo proporciona aceleración gráfica a los modelos Radeon 9250 o inferiores.

Para los demás modelos tiene aceleración 2D

Este controlador viene incluido en Ubuntu por defecto y se autoinstala y se autoconfigura si detecta tu gráfica ATI. 

* Uno privativo proporcionado por ATI que a día de hoy sólo ofrece soporte para los modelos 9550 (incluido) y superiores (creo que hasta la serie x1050 o por ahi..)

Este controlador es el de los numeritos chulos 8.37.6, 8.42.3 y demás.

Ubuntu instala de manera automatica (con el gestor de drivers restingidos) la versión que posee en los repositorios que normalmente es más antigua que la actual ya que se busca un consenso entre estabilidad y novedad. 

Para instalar los ultimos controladores propietarios usa Envy, pero usa la ultima versión de este programa de su web oficial no la que cuelgan muchos blogs por ahi.

 Checking for Xgl: not present.

Eso no es un error, simplemente no estas usando el XGL 

Leete esto:

http://www.portalsedg.com/foro/showthread.php?t=37543 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de kifto
+1
0
-1

pues muchas gracias, festor...con el envy he podido subir los drivers de mi radeon 9550 de 8.37 a 8.42, que son los que me permiten habilitar compiz-fusion..

y por fin despues de mas de un mes trasteando puedo disfrutar de todas estas chorraditas...  los prgramas de video y tal parpadean, pero con desactivar los efectos de escritorio, ya vuelven a funcionar correctamente... 

 

entiendo que con las limitaciones de mi equipo no pueda tener ambas cosas a la vez (tv por streaming, un entorno gráfico potente y aplicaciones ofimáticas abiertas)...pero al menos ahora tengo la opcion de cuando verlos yy cuando no.

 

gracias de nuevo

 

1 saludo 

+1
0
-1
Imagen de cantervilotis
+1
0
-1

Yo tenía los mismos problemas, hasta que me di cuenta que en la version 7.10 no hay q hacer NADA para que se configure la tarjeta y te de direct rendering YES,  asi q te recomiendo que inicies una sesion con live CD desde UBuntu 7.10 copias el xorg.conf en una unidad usb y lo reemplazas en tu sesion de siempre.

Saludos des desde Chile

Go Vegan

+1
0
-1

Salve 95 vidas al año, Sea Veg(etari)ano

Imagen de downward
+1
0
-1

de ser asi, debo hacer una instalacion limpia, y para eso tengo que descargar el gutsy, entonces quiza lo mas conveniente seria esperarme y hacer una instalacion limpia de Ubuntu Hardy :P espero que haya otra forma de activar el compiz.

 gracias 

+1
0
-1
Imagen de downward
+1
0
-1

ya intente substituir el xorg.conf y tambien trate de configurarlo manualmente y el problema persiste. 

+1
0
-1