CÓMO configurar Compiz Fusion (efectos de escritorio) en portátil Acer Extensa 7620G con ATI Mobility Radeon HD 2400 [editado]

Imagen de polkillas
0 puntos

No escribo demasiado, pero con lo que me ha costado hacerlo, creo que puede ser bueno colgarlo. Cuando me compré el portátil Acer Extensa 7620G, lo que me convenció fue la pantalla, 17 pulgadas panorámicas. Pero lo que no había tenido en cuenta es la tarjeta gráfica, una ATI Mobility Radeon HD 2400, y los problemas que esta marca da en Linux. Cuando instalé Ubuntu 6.10 en mi viejo ordenador de sobremesa me reconoció inmediatamente la tarjeta gráfica, una nVidia GeForce, y supuse que Ubuntu 7.10 haría lo mismo con la gráfica del portátil, pero no fue así, parece ser que hay bastantes problemas con ello. Además, el driver fglrx que puedes descargarte con Synaptic no sirve de nada, los efectos de escritorio siguen sin activarse. Así que me puse a buscar, y de hecho busqué bastante. Incluso leí alguna página en francés, pero lo que conseguí fue cargarme el sistema gráfico, (quizás porque no he estudiado francés en la vida). Así que tuve que reinstalar, y finalmente, di con la solución. Lo que hice fue lo siguiente:

 

1. Descargar el driver.

Lo primero que hay que hacer es conseguir el archivo del driver. La primera vez que intenté bajármelo, vi que no existe en la página web de ATI ninguna tarjeta Mobility Radeon HD 2400, y me desesperé. Por esa misma desesperación, lo que intenté fue bajarme el driver para una tarjeta Radeon HD 2400, sin el adjetivo Mobility. ¡Y funciona! El driver se puede encontrar en

http://ati.amd.com/support/driver.html

La versión para Linux 64 bits, que es la que uso yo, se puede encontrar directamente en

http://ati.amd.com/support/drivers/linux/linux-radeon.htm

0Allí te descargas un archivo de nombre ati-driver-installer-8-3-x86.x86_64.run, que podemos guardar en nuestra carpeta personal o donde se prefiera. Una vez guardado, tenemos que darle permiso de ejecución escribiendo en un terminal

sudo chmod +x ati-driver-installer-8-3-x86.x86_64.run

Esto se puede hacer también en Nautilus, pulsando con el botón derecho sobre el archivo, seleccionando Propiedades, pestaña Permisos y seleccionar la opción Permitir ejecutar el archivo como un programa.

 

2. Prepara las dependencias.

Después podemos preparar nuestro ordenador. Cuando hemos acabado el paso 1, podemos intentar ejecutar el instalador, pero siguen los problemas. Se necesitan una serie de paquetes adicionales para funcionar. Aquí escribo de memoria, no tuve la precaución de tomar nota de los paquetes necesarios. Afortunadamente, es el mismo archivo quien nos avisa. Cuando lo ejecutamos desde un terminal con

sudo ./ati-driver-installer-8-3-x86.x86_64.run

nos saldrá un mensaje de error, diciendo que hay que instalar una serie de paquetes. Entre ellos está uno llamado build-essentials,pero no es el único. Así que tenemos que instalarlos con

sudo apt-get install build-essentials nombre_de_otro_paquete nombre_de_otro_paquete

poniendo todos los nombres de paquetes que pida el ejecutable. Este proceso hay que hacerlo dos veces. La primera vez que instalamos estos paquetes y ejecutamos el instalador, nos volverá a dar un mensaje de error diciendo que siguen faltando paquetes. Se vuelven a instalar de la misma manera, cambiando en la instrucción anterior sólo los nombres de los paquetes. Ah, hay que recordar que quizás cambie el nombre del archivo si la arquitectura es diferente.

 

3. Creando los paquetes para Ubuntu.

Ejecutamos el archivo y nos aparece por fin un instalador gráfico. Y siguen los problemas. Dicho instalador no permite crear los paquetes para ninguna distribución de Ubuntu, así que hay que hacerlo en terminal. Abrimos uno y escribimos 

sudo ./ati-driver-installer-8-3-x86.x86_64.run --buildpkg Ubuntu/7.10

o bien

ati-driver-installer-8-3-x86.x86_64.run --buildpkg Ubuntu/6.06

para la versión LTS.

 

4. Instalar los paquetes

Si no hay problemas, deben generarse al final cuatro paquetes .deb que debemos instalar. Lo más sencillo es hacerlo gráficamente, que es como lo he hecho yo. Confieso con cierta vergüenza que no sé instalar paquetes en terminal, pero Gdebi lo hace a la perfección con sólo hacer doble clic sobre los 4 paquetes. El orden en que se instale creo que no es importante, si bien uno de los paquetes no se puede instalar hasta que se han instalado los otros tres. Gdebi te dice que no puede instalarlo si no has instalado los otros, pero no da ningún problema.

 

5. Configurar el driver

Una vez hemos instalado los paquetes, debemos configurarlos. Para ello, escribimos en terminal

sudo aticonfig --initial --input=/etc/X11/xorg.conf

si no tenemos configuraciones extrañas (dos monitores o cosas así) y ya está. En el caso de configuraciones extrañas, lo que se puede hacer es escribir

aticonfig

a secas, para que aparezcan las opciones, aunque a mí no me ha hecho falta.

 

6. Comprobar que el driver se usa.

Vamos a Sistema>Administración>Pantallas y gráficos y comprobamos que el controlador usado es fglrx.

 

7. Reiniciamos el sistema

Al reiniciar, ya en la pantalla de inicio de gdm debería notarse la diferencia.

 

8. A disfrutar

Bueno, espero que haya sido de ayuda.

Imagen de Festor
+1
0
-1

 Bery no es recomendable de usar ya que está obsoleto.

Su continuación es Compiz Fusión, integrado en Ubuntu 7.10 

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de polkillas
+1
0
-1

Es lo que tiene escribir sin pensar. Si has leído el tutorial, verás que lo que en realidad se configura es Compiz Fusion. Gracias  por la observación, ya lo he editado.

+1
0
-1
Imagen de kelp
+1
0
-1

Movido a tutoriales y trucos


Equipo de Ubuntu-es
+1
0
-1

Las tres cosas más peligrosas del mundo son: un programador con un soldador, un ingeniero de hardware con un parche de software y un usuario con una idea

Imagen de polkillas
+1
0
-1

No tenía ni idea de que se pudiera hacer. Gracias, kelp.

+1
0
-1
Imagen de Festor
+1
0
-1

No tenía ni idea de que se pudiera hacer. Gracias, kelp.

7. Las bitácoras no son el lugar adecuado para la publicación de Howto’s o Comos.

http://www.ubuntu-es.org/index.php?q=blog/normas

****-------------------****

The Life of Nadock Blog

****-------------------****

+1
0
-1
Imagen de julioracing
+1
0
-1

viva el software libre

Buenas gente, tengo un acer extensa 5620 con una ati mobility Hd 2400 le instado instalando los driver de la forma en la que me comentais pero no soy capaz, lo que quiero es que me pille la maxima resolucion que es 1280 x 800, para despues poner le el compiz fusion. tengo el ubunto 7.10 puesto, cuando lo instala en la consola sale un asigtente de ati para poder instalar el paquete y no me da error, cuando voy a la configuracion que me decis, no me deja poner la resolucion esa, reinicio y esto sigue igual, muchas gracias, y si me hacer el favor de decirme como es os lo agradeceria, un saldo.

+1
0
-1

viva el software libre

Imagen de julioracing
+1
0
-1

viva el software libre

mira pongo los comando estos para ver si esta funcionando la aceleracion 3D.
y me dice que yes.

glxinfo | grep direct

me dice yes.

fgl_glxgears

me sale el cubo con los piñones, y a buen paso.

esto quiere decir que tengo los driver instalados, pero no puedo poner la resolucion 1280 x 800,
gracias por todo.

+1
0
-1

viva el software libre

Imagen de julioracing
+1
0
-1

viva el software libre

lo he cambiado a mano y listo

aqui os dejo el enlace

http://www.ubuntu-es.org/index.php?q=node/69155

yo que puese en el archivo fuen "1280x800@60"

cambie de sesion y listo parece que va al pelo, ahora voy poner el compiz fusion haber que os cuento, gracias gente un saludo.

+1
0
-1

viva el software libre