Reproducción de DVD muy lenta

Imagen de osobuko
0 puntos

Hola a todos,

Tengo un problemilla a la hora de reproducir DVDs. Lo que pasa es que la imagen se ve a saltos, vamos, como si no le diera al PC para leer el DVD y mostrarlo a la vez.

He probado el MPlayer y el VLC. Me pasa lo mismo con los 2. Con el Totem ni me va. Incluso con el MPlayer me ocurre que, cuando le doy a ver a pantalla completa, no se expande la imagen y se sigue viendo pequeño. Además, con el Totem también me pega saltos cuando reproduzco películas en Divx, por ejemplo.

Me parece raro porque con la versión anterior de Ubuntu esto no me pasaba, y el VLC me estuvo funcionando de lujo.

¿Sabéis qué tengo que hacer? Gracias de antemano.

Un saludo.

Imagen de gabiel
+1
0
-1

Comprueba que tienes activado el DMA en el lector de DVD:

sudo hdparm /dev/dispositivo_del_lector

si no lo tienes activado activalo mediante:

sudo hdparm -d1 /dev/dispositivo_del_lector

Y para que esto se realice automáticamente al iniciar el sistema, edita de forma apropiada el archivo /etc/hdparm.conf

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de osobuko
+1
0
-1

Muchas gracias por tu ayuda!!!!!

Lo he comprobado, y tenías razón. El DMA de la grabadora de CD y de la lectora de DVD estaban desactivados. Ya he añadido un par de líneas en el archivo que comentas y va bien.

En cierta forma, me parece raro. Pensaba que activaba en todos los IDEs el DMA (parece que en Warty lo hacía), pero bueno, tampoco sabía mirarlo :P

Un saludo y gracias otra vez.

+1
0
-1
Imagen de papageno
+1
0
-1

Si lo hago desde la cónsola, si activo DMA en las lectoras de DVD, pero si incluyo las líneas

/sbin/hdparm -d1 /dev/hdc
/sbin/hdparm -d1 /dev/hdd

que corresponden en mi caso a una lectora y una lectora/grabadora DVD, en el fichero /etc/hdparm.conf, después de reselar sigue todo igual, sin activar DMA, y tengo que hacerlo otra vez desde la cónsola para que se active.

+1
0
-1
Imagen de gabiel
+1
0
-1

Para editar el archivo tienes que seguir el formato que se especifica en el mismo, también hay varios ejemplos en el archivo que te pueden servir de referencia.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de papageno
+1
0
-1

La verdad es no se que es lo que estaba haciendo, en cuanto he puesto

/dev/hdc {
dma = on
}

todo ha ido bien, ya me estaba precupando pensando que no conecté bien algo la última vez que metí mano a las tripas de la máquina. Siento haber sido tan torpe, gracias por tu paciencia.
Ahora estoy de lleno metido en grabar DVD de doble capa (en concreto el DVD de SuSE 10.0) pero no me da más que problemas, tanto obtener la imagen ISO, como grabarla. En fin, con un poco de paciencia lo conseguiré.
Por si alguén se anima, para obtener la imagen ISO, en la cónsola:

# dd if=/dev/hdc of=/home/yo/imagenesISO/suse10

y para grabarla en el DVD

# growisofs -dvd-compat -Z /dev/dvdrw=/home/yo/imagenesISO/suse10

El caso es que todo parecía ir bien, pero la imagen que creó que debería de ser de unos 8,5 GB, se ha quedado en más o menos 300 Kb, o una cosa así, y eso que la salida del comando indicó todo correcto, claro, ahora growisofs me dice que mejor ponga un disco de simple cara porque si no se desperdiciará más de un 50%. Todo un detalle con lo caros que están.

+1
0
-1