Inicio de Sesion Automática en LTSP 5

Imagen de danielsc
0 puntos

Levante una red con 19 equipos en un laboratorio con Edulinux, los equipos funcionan bien; hice lo mismo en otro laboratorio pero con Ubuntu 7.10 corriendo LTSP 5, el único problema, los terminales livianos no se auto logean o no inician sesión automaticamente, lo intente todo:

gdm.conf, Autologin.sh , Sistema -> Administracion -> Ventana de Entrada, Ventana de Entrada = Entrada Local, Probe con entrada Automatica, Temporizada. En Sistema Preferencias -> Sesiones Active mi Autologinsh. Cree archivos para cada terminal para que el demonio gdm lo cargara en la partida

gdm.conf

[daemon]
# Automatic login, if true the first local screen will automatically
logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=true
AutomaticLogin=/usr/local/bin/autologin.sh|

# Timed login, useful for kiosks. Log in a certain user after a certain
# amount of time
TimedLoginEnable=true
TimedLogin=/usr/local/bin/autologin.sh|
TimedLoginDelay=5

autologin

#!/bin/bash
case "${DISPLAY}" in
"Comp1.ltsp:0") LOGNAME=pc1;;
"Comp1.ltsp:0.0") LOGNAME=pc1;;
"Comp2.ltsp:0") LOGNAME=pc2;;
"Comp2.ltsp:0.0") LOGNAME=pc2;;
*) LOGNAME=alumnos ##Debiera ser la contrseña

echo $LOGNAME
exit 0
;;
esac
echo $LOGNAME

Todo y aún asi no inician sesion Automaticamente; solucionado parcialmente ingresando cuentas de usuario EJ: pc1,pc2,pc3, etc

Pero los alumnos las deben ingresar por si mismos.

El dominio en el Dhcp es "Ltsp" y Lo intente ingresando las ip a cada computador y en forma automatica; Tampoco Funciono el Autologin.

Alguna Orientacion al Respecto

de antemano Muchas gracias.

POST DATA: EL SCRIPT DEL AUTOLOGIN SE CARGA PERO NO INICIAN AUTOMATICAMENTE LO SE PORQUE SE CARGA POCO ANTES DE APARECER LA PANTALLA DE INICIO DE SESION, EL SERVIDOR SE AUTOLOGEA SIN PROBLEMAS. SOLO OCURRE EN LOS TERMINALES.