Problemas con juegos que exigen 3D

Imagen de AngelBotto
0 puntos

Veran compañeros cuento con una targeta ati radeon x1300 de 512 mb, eh instalador hardy heron perfectamente uno que otro problema pero solucionados menos uno veran tengo instalador compiz fusion y me funciona perfectamente tengo aceleracion 3D pero cuento con un pequeño problema cuando abro juegos que exigen aceleracion 3D la pantalla sale normal pero se ve algo destilanente no sabria como describirlos por eso les dejare dos videitos que eh grabado para que ustedes mismos vean y aver si me puedne ayudar =/

 http://www.youtube.com/watch?v=QwSgrhAkqbQ

 http://www.youtube.com/watch?v=0qwBlkpLdBI

 

y mi xorg.conf por si hay algo mal =(

 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "screen1" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
    Load  "dri"
    Load  "v4l"
    Load  "glx"
EndSection

Section "ServerFlags"
    Option        "AIGLX" "on"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "vmmouse"
EndSection

Section "Monitor"
    Identifier   "Configured Monitor"
    VendorName   "Plug 'n' Play"
    ModelName    "Plug 'n' Play"
    Gamma        1
    ModeLine     "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Monitor"
 # 
    Identifier   "monitor1"
    VendorName   "LG"
    ModelName    "LG L192WS"
    HorizSync    30.0 - 83.0
    VertRefresh  56.0 - 75.0
    Gamma        1
    ModeLine     "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    ModeLine     "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
    ModeLine     "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
    ModeLine     "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    ModeLine     "1280x768@60" 80.1 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
    ModeLine     "1280x720@60" 74.5 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
    ModeLine     "1280x800@75" 107.2 1280 1360 1496 1712 800 801 804 835 -hsync +vsync
    ModeLine     "1280x768@75" 103.0 1280 1360 1496 1712 768 769 772 802 -hsync +vsync
    ModeLine     "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    ModeLine     "1440x900@75" 136.5 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
    ModeLine     "1440x900@60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    ModeLine     "1600x1024@60" 136.4 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
    ModeLine     "1680x1050@60" 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    ModeLine     "1680x1050@75" 188.1 1680 1800 1984 2288 1050 1051 1054 1096 -hsync +vsync
    ModeLine     "1920x1200@60" 193.2 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
EndSection

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fglrx"
    VendorName  "ATI"
    BoardName   "ATI Radeon (fglrx)"
    Option        "MergedFB" "off"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"
    BusID       "PCI:1:0:1"
EndSection

Section "Device"
 # 
    Identifier  "device1"
    Driver      "fglrx"
    VendorName  "ATI"
    BoardName   "ATI Radeon (fbdev)"
    BusID       "PCI:1:0:0"
    Option        "VideoOverlay" "on"
    Option        "OpenGLOverlay" "off"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "Configured Video Device"
    Monitor    "Configured Monitor"
    DefaultDepth     24
    SubSection "Display"
        Virtual   640 480
        Depth     24
        Modes    "640x480@60"
    EndSubSection
EndSection

Section "Screen"
 # 
    Identifier "screen1"
    Device     "device1"
    Monitor    "monitor1"
    DefaultDepth     24
    SubSection "Display"
        Depth     24
        Modes    "1440x900@75" "1440x900@60" "1280x800@60" "1600x1024@60" "1280x768@75" "1680x1050@60" "1280x800@75" "1680x1050@75" "1280x720@60" "1920x1200@60" "1280x768@60" "800x600@60" "800x600@75" "800x600@72" "800x600@56"
    EndSubSection
EndSection

Section "Extensions"
    Option        "Composite" "on"
EndSection

 


De ante mano agradezco enormemente por tomarse su tiempo y tratar de colaborarme

 

 

Imagen de AngelBotto
+1
0
-1

  Nadie save nada acerca de eso no creo que sea la unika persona que le suceda =( realmente estoy desesperao que alguien me ayude plis                                     

 

   Mi Mundo es Libre tu Mundo es Libre
                                                                Ubuntu 8.04

+1
0
-1
Imagen de omnicron-d
+1
0
-1

pues yo tambn tengo problemas a la hora de ejecutar juegos 3d,especificamnte OpenArena.. tampoco se como explicarlo solo se desliza la imagen se corre, no c.. uso una intel x3100... gracias

+1
0
-1

<a href="http://ubuntucounter.geekosophical.net" title="The Ubuntu Counter Project - user number # 21088"><img src="http://ubuntucounter.geekosophical.net/img/ubuntu-user2.php?user=21088" alt="The Ubuntu Counter

Imagen de submk1
+1
0
-1

Les cuento que tengo Gusty 7.10 64 bits con nvidia serie 6000 onboard. La problemática se refiere a que he descargado tanto de repositorios como de getdeb alrededor de 8 juegos entre los que estan assaultcube, warsau, openarena, tux racer, etc y ninguno funciona. lo unico que tira es una pantalla en negro donde se logra vislumbrar el fondo de pantalla de mi pc. No se que pasa, ya que tengo aceleracion, me doy cuenta xq compiz funciona muy bien, entonces pregunto, por donde empiezo?, que debo revee? o instalar o desistalar de nuevi? alguien me puede orientar?  garcias amiguis!!

+1
0
-1
Imagen de danielGT
+1
0
-1

No soy el más indicado para configuraciones ya más avanzadas con la tarjeta grafica y aceleracion 3D, sin embargo, has probado desactivando compiz-fusion antes de jugar? 

Prueba desactivando temporalmente compiz-fusion, para ello haz click en el icono de compiz (o lo que antiguamente era el beryl-manager) y selecciona Metacity.

Como muchos, y yo en particular, solo usamos compiz-fusion para alardear frente a los amigos, o bien lo tuvimos activado al principio puesto que era la novedad, eramos como niños con juguete nuevo xD, pero ahora la mayor parte del tiempo lo tenemos desactivado.

Luego cuando dejes de jugar vuelve a activarlo. Yo en lo personal creo que es mejor desactivar compiz mientras juegas, ya que es lógico que haya una baja en el rendimiento de la tarjeta y el juego te irá mas lento o a tirones.

Al menos asi sabras que tu tarjeta no tiene nada malo.

EDITADO: Tambien puedes desactivar compiz haciendo click derecho sobre el escritorio y luego en Efectos, seleccionas la opcion correspondiente.

+1
0
-1
Imagen de atan
+1
0
-1

NO soy un experto pero vi algo interezante,

cuando usaste el comando glxgears

Lo mas q te dio fue 65.366 FPS

A mi en una ati 9200se de 64mb me da hast a 870.555 FPS 

 

Y TU TIENES un  un animal de 512Mb

Prueba instalando los driver un vez mas, creo q por ahy podrias empezar, o consulta sobre tu tarjeta grafica.

 

 

 

Viva mi patria, Viva el open source

+1
0
-1
Imagen de submk1
+1
0
-1

Ahora como pregunta, esto debería ser asi? digo es lógico tener q desactivar comopiz, creo q es una manera elegante de salir del problemita, pero supongo que debe haber una solucion algo mas definitiva, un saludo y probare... 

+1
0
-1
Imagen de cousteau
+1
0
-1

El envy te instala los últimos drivers para Nvidias y Atis de forma fácil.

http://www.albertomilone.com/nvidia_scripts1.html

Instala el EnvyNG-Core y el EnvyNG-GTK (o EnvyNG-Qt si usas KDE.


«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
+1
0
-1

«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
Imagen de submk1
+1
0
-1

Probe deshabilitar conpiz y nada ninguno funciona salvo tuxcar, por lo que los he desistalado. Me resta dos preguntas:

 

1- Como desistalo assaultcube.

 

2 - Alguien sabe xq no me funcionan ninguno de los juegos 3d fps?

 

Tengo acelerecaión, comprobado con glxinfo.

 

Gracias!!  

+1
0
-1
Imagen de c385
+1
0
-1

Hola submk1, decirte que personalmente he tenido la lts de Ubuntu en 64 bits, y no note diferencia solo que algunos juegos para linux solo estan en 32 bits y el crossover por ejemplo solo esta para 32 bits, asi que instale Ubuntu 8.10 pero de 32 bits.

Desde la 7.04, que lo hice manual la instalacion grafica, me ha ido muy bien mi grafica Nvidia Geforce Go 7300 con los driver Privativos, los oficiales de Nvidia, ya que con los de Ubuntu algunos juegos no se veian bien.

Como ya has dicho que tienes aceleracion y una Nvidia, la cual no deberia dar problemas, instala los driver privativos, en la version 7.10 que tienes te recomiendo que lo hagas con la ayuda de Envy, en synaptic esta, y atraves de el instalas estos driver.

Yo venia usando Envy hasta la 8.10 que ya desde los restrigidos te instala los oficiales de Nvidia, segun la tarjeta que tengas te recomienda unos o otros.

+1
0
-1

Pensar que la vida sera buena contigo por ser buena persona es como creer que un león no te comerá por ser vegetariano.