Formas actualizar a Kernel 2.6.11

Imagen de Shagohod
0 puntos

¡Muy buenas! He instalado linux Ubuntu 5.04 en mi ordenador. El problema viene cuando quiero instalar mi wireless Zyair B-220, tras mucho buscar, he encontrado varios manuales pero en todos ellos el primer paso es instalar el kernel 2.6.11.
También recomiendan que se haga por medio de la instruccion apt-get install linux-source-2.6.11 pero es aquí donde vienen mis problemas; supongo que con esta accion, linux descargara el paquete requerido por medio de internet (o buscando por Ubuntu, que tampoco lo encuentra) pero precisamente yo los necesito para ponerme internet, por lo que logicamente, no me deja.
¿Hay algun otro modo de bajarlo? Se que en kernel.org tambien se puede pero preferiría seguir los manuales al pie de la letra...
Un saludo, gracias de antemano.

Imagen de gabiel
+1
0
-1

Puedes buscar los paquetes que desees bajar en packages.ubuntu.com, en este caso linux-image-2.6.11

Pero también podrías aprobechar y bajar directamente Breezy que está a punto de salir y trae un kernel 2.6.12 de serie.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Shagohod
+1
0
-1

Gracias por responder, y tan pronto! Ya me he bajado
el archivo "linux-image-2.6.11-1-686_2.6.11-0.2_i386.deb"
y ya he vuelto a tener problemas...(lo siento pero soy
nuevo en linux y me queda muuuuucho que recorrer).
A lo que iba, fui a descomprimir el archivo, y tuve
problemas con una carpeta llamada "initrd" y aparte,
lo descomprimi de forma manual, es decir, carpeta a
carpeta y despues copiando y pegando..(me imagino que habrá
algun codigo que lo haga todo de una vez no?)
A ver si con vuestra ayuda consigo poner internet en linux
y con ello ir mirando paginas como éstas para aprender poco
a poco a utilizar este operador.
Un saludo!

+1
0
-1
Imagen de gabiel
+1
0
-1

No tenías que descomprimir ese archivo, para instalarlo tan solo tienes que ejecutar este comando sudo dpkg -i linux-image-2.6.11-1-686_2.6.11-0.2_i386.deb. Además para compilar el módulo para la tarjeta wifi necesitarás las cabeceras del kernel, puedes encontrarlas aquí pero aseguarte de bajar la versión que corresponda al kernel que has bajado previamente (en este caso 2.6.11-1-686_2.6.11-0.2_i386). Para instalarlas utiliza de nuevo dpkg -i

De todas formas recuerda que tan solo queda un día para Breezy, igual te compensa esperar a mañana y bajar la iso (recuerda que ya trae la versión 2.6.12 de serie).

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Shagohod
+1
0
-1

Al final te hice caso y hoy ya estoy bajando el breezy
del mirror:
http://us.releases.ubuntu.com/releases/5.10/
Ahora sólo queda esperar e instalar el driver usb para
al fin navegar con linux...que ganas tengo!
Gracias de nuevo (no me cansare de decirlo).

P.S: ¿Hago bien en descargarme este o debería esperar a
que salga alguna version europea o algo por el estilo?

+1
0
-1
Imagen de gabiel
+1
0
-1

No hay versiones diferentes, todos los mirrors tienen la misma imágen.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Siento ser un pesado pero son tantas mis ganas de poder conectarme
a internet con linux que no puedo esperar mas!
Ya he instalado breezy y ahora el problema es otro. Te explico:
descomprimi ambos archivos y a la hora de ir a instalarlos me da
error, es decir, dentro de la carpeta del driver escribo 'make' y
me salia el error 'make-->command not found', buscando por aqui
encontre que para instalar dicho paquete bastaba con
'apt-get install build-essential' lo hice y previsiblemente se instalo.
Lo que pasa es que al ejecutar de nuevo make,obtengo lo siguiente:
'lib/modules/2.6.12-9-386/build: No existe el fichero o el directorio.
Alto'
Ahora si que ya no tengo ni idea de que me pasa...
Un saludo!

+1
0
-1
Imagen de gabiel
+1
0
-1

Te faltan las cabeceras del kernel, creo que venían en el cd así que podrás instalarlas mediante apt, el apquete se llama linux-headers (por si acaso me equivoco, recuerda que puedes acudir a la página que te mencioné en mensajes anteriores para descargarlo, recuerda que tiene que coincidir la versión con la del kernel que tienes instalado).

Por cierto, también necesitarás gcc3.4 para poder compilar el módulo.

A parte de esto no creo que neceites nada más para compilar el módulo, excepto evidentemente lo que te pida el propio módulo como dependencias.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1