Tarjetas de sonido en puerto ISA

Imagen de Dominus
0 puntos

Buenas familia... acabo de instalarle a mi ordenador antiguo ubuntu (he de mudarme y no puedo llevarme mi "grandullón)

Todo ha ido muy bien pero tengo un problema con el audio... no consigo q funcione en una Sound Blaster 16 en un puerto ISA..... alguien puede decirme si este tipo de dispositivos está soportado por Ubuntu??''

Muchísimas gracias por vuestra ayuda, estoy abierto a todas vuestras sugeremcias.

Atentamente.

Imagen de Anónimo
+1
0
-1

Por experiencia en debian, las SB ISA van bien y ALSA las configura sin problemas. En Ubuntu no he probado pero siendo labor de ALSA supongo que no hay diferencia.

Usa el comando 'alsaconf' para configurar la tarjeta.

Tambien he probado una cuantas tarjetas ISA que no son Sound Blater y esas no las ha detectado.

+1
0
-1
Imagen de Dominus
+1
0
-1

Pues que va... no la ha detectado y encima el comando alsaconf no existe.... en fin, muy raro. Tendrá algo que ver el que sea Plug'n'play???

P.D.: Siento haber metido la pata pero la tarjeta es la Sound Blaster Awe 64 (perdón por la confusión :-S)
==================================================================
Necesito el CD key de mi ubuntu!!!!!

+1
0
-1

==================================================================
Necesito el CD key de mi ubuntu!!!!!

Imagen de Anónimo
+1
0
-1

justito ahora me iba a contestar a mi mismo porque acabo de pinchar una tarjeta de sonido ISA

Como dices 'alsaconf' no existe en ubuntu, asique voy a buscar a ver como se hace.

Creo que esta es la tarjeta que tenia funcionando en otra maquina con debian. Digo creo porque tenía dos SB casi iguales y no se exactamente cual he cogido. Cuando traiga la otra miraré si la reconoce de alguna forma o dónde hay que tocar.

Ya te digo que mi duda ahora es ver como se configura alsa sin alsaconf, porque soporte se que tiene porque la he usado anteriormente

postearé si hago algun progreso
saludos

+1
0
-1
Imagen de Anónimo
+1
0
-1

Solucionado. al final era sencillo

Una vez puesta la tarjeta hay que cargar manualmente el modulo correspondiente. En mi caso es una SB16 ISA. El módulo lo cargas con 'modprobe xxxx', y para saber el nombre del modulo buscalo en '/lib/modules/{version_del_kernel}/kernel/sound'
Busca dentro del directorio 'isa' y si dices que es una soundblaster mira en el directorio 'sb'.

Al hacer el 'modprobe snd-xxxx' se cargan el resto de mmodulos de sonido y esta listo para usar

Para cargar el modulo automaticamente al inicio creo que está el fichero '/etc/modules'

saludos

+1
0
-1
Imagen de Anónimo
+1
0
-1

Buenas,
Pues mi problema es con una sb16 isa, acabo de instalar ubuntu 5.10 pero no me funciona (el icono de control de volumen en la barra dice que no detecta ningun dispositivo), he heho lo de cargar el modulo on modprobe pero nada.
con otras distribuciones si me funciona, pero queria dejar esta instalada.

+1
0
-1