Agregar frecuencia de refresco en ati

Imagen de guisheca
0 puntos

Que tal comunidad, resulta que me compré una nueva pc, la cual tiene una placa ati radeon x1250, onboard la cual setee a 256mb. Instalé los drivers propietarios con exito, obtuve aceleración gráfica y puedo correr compiz-fusion con normalidad, incluso tengo la resolución optima de mi monitor (1440x900). El problema es que sólo tengo una frecuencia de refresco de 60mhz, y quisiera que sea mayor, de 75hz. Dicha configuración (1440x900@75) es soportada por mi monitor y placa de video.

A continuación dejo el contenido de mi xorg.conf:

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Radeon X1200 Series"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Extensions"
Option "Composite" "enable"
EndSection

Section "Monitor"
Identifier "Monitor genérico"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Radeon X1200 Series"
Monitor "Monitor genérico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900@75" "800x600" "640x480"
EndSubSection

EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Section "ServerFlags"

Option "AIGLX" "on"

EndSection

Esta parte le añadí yo porque no estaba

SubSection "Display"
Depth 1
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900@75" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900@75" "800x600" "640x480"
EndSubSection

Y sirvió porque después de eso la ventana del GDM se muestra a 1440x900, cuando antes lo hacía a no se que resolución que quedaba re feo.

Edita varias cosas en el xorg.conf, pero no tuve exitos en nada. Y no puedo usar el fglrx-control, no se porqué, lo instalé manualmente, porque no lo tenía, pero no aparece en ningún lado en los menús (ni siquiera yendo a editar menús) y no se cual sería el comando para llamarlo por consola.

Espero haber sido lo mas explicito posible.

Un saludo.