Instalacion de programas

Imagen de LiQueX
0 puntos

agradezco por su comprension y cualquier ayuda, tengo instalado Ubuntu 7.10 Gutsy-Gibbon en una pc con placa d945gcnl con 1Gb de memoria y un micro Dual Core, hasta alli todo bien, el problema es cuando intento instalar aplicaciones como qt3, Gambas2, EID Anjuta o Monodevelop me sale un mensaje indicandome que estas aplicaciones no son soportadas por equipos como el mio (amd64) claro todo esto desde el menu Añadir y quitar, he hecho todo lo que me indican los foros que he consultado y hasta ahora no consigo instalar dichas aplicaciones, he intentado instalar de las siguientes maneras:

DESDE EL MENU AÑADIR Y QUITAR

AL INTENTAR INSTALAR GAMBAS Y GAMBAS2

Esta aplicación la proporciona la comunidad de Ubuntu.
Gambas2 no puede instalarse en un equipo como el suyo (amd64). O bien la aplicación requiere funciones hardware especiales, o bien el vendedor ha decidido no soportar equipos del mismo tipo que el suyo.

 

AL INTENTAR INSTALAR ANJUTA

No se pudo instalar «anjuta»
Esta aplicación está en conflicto con otro software que ya esta instalado. Para instalar 'anjuta', el software conflictivo debe ser desinstalado primero.

Cambie al gestor de paquetes 'synaptic' para resolver este conficto.

 

AL INTENTAR INSTALAR MYSQL

No se pudo instalar «mysql-admin»
Esta aplicación está en conflicto con otro software que ya esta instalado. Para instalar 'mysql-admin', el software conflictivo debe ser desinstalado primero.

Cambie al gestor de paquetes 'synaptic' para resolver este conficto.

 

Y LO MISMO PARA OTRAS APLICACIONES COMO QT4, MONODEVELOP, ANJUTA

"no conozco muy bien el uso de Synaptic"

 

USANDO FIREFOX Y APT

- Abrir FireFox

- Colocar apt://Gambas2

- y luego doy Si en la opcion indicada, aqui es el problema cuando acepto me presenta un mensaje indicandome que no se puede instalar "Can not install 'gambas2' (E:No se pudieron corregir los problemas, usted ha retenido paquetes rotos.) "

bueno espero no haberlos incomodado con mi pregunta y gracias nuevamente por las posibles soluciones que me puedan dar, o es que tal vez ya estan instaladas y no encuentro sus lanzadores.

Imagen de Goyo
+1
0
-1

Cambie al gestor de paquetes 'synaptic' para resolver este conficto.

 


Equipo de moderadores
Normas

Documentación

 

+1
0
-1
Imagen de LiQueX
+1
0
-1

gracias por su respuesta, pero es que no le entiendo, deberia hacer eso en el caso que muestre dicho mensaje, pero en el caso de la instalación de Gambas2 y/o Monodevelop en las cuales me dice que las aplicaciones no estan disponbles para mi amd64, ¿Cuál seria la solución?

Gracias nuevamente por su atención.

+1
0
-1
Imagen de Goyo
+1
0
-1

En los otros casos es de esperar que Synaptic nos de información más detallada si ocurre algún problema, los mensajes de error de Añadir y quitar no son muy útiles y a veces están equivocados.


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de LiQueX
+1
0
-1

No se puedieron marcar todos los paquetes para instalacion o actualizacion.

 Los siguientes paquetes tienen dependencias no resolubles. Asegurese que todos los repositorios requeridos esten añadidos y activados en las preferencias.

gambas2:

Depende: gambas2-gb-compress.....

y todo eso.

 

¿Que debo hacer? , ya estoy pensando seriamente en instalarme el ubuntu 6.06 pues me fue mejor, espero una ayuda antes de limpiar nuevamente mi ordenador.

+1
0
-1
Imagen de Goyo
+1
0
-1

Imagen de patagonian18
+1
0
-1

Lo que pasa es que tienes instalada la versión de 64 bits de Ubuntu y esos programas sólo corren en 32 bits. Tienes dos opciones: Instalar Ubuntu de 32 bits o crear una jaula de 32 bits dentro de tu sistema de 64.

Yo tengo Ubuntu AMD 64 bits y pude instalar Anjuta, así que te debería funcionar :) 

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de LiQueX
+1
0
-1

El mensaje de error que me da es este, debo aclkarar que en la web de gambas indican que este sistema ya corre bajo 64bits: 

gambas2:
 Depende: gambas2-gb-compress-bzlib2 (>=1.9.49-1) but it is not installable
Depende: gambas2-gb-compress-zlib (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-crypt (>=1.9.49-1) but it is not installable
Depende: gambas2-gb-db-firebird  but it is not installable
 Depende: gambas2-gb-db-mysql (>=1.9.49-1) but it is not installable
Depende: gambas2-gb-db-postgresql (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-odbc (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-db-sqlite (>=1.9.49-1) but it is not installable o
     gambas2-gb-db-sqlite2 (>=1.9.49-1) pero no es instalable
 Depende: gambas2-gb-form (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-form-mdi (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-gtk (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-gtk-svg  but it is not installable
 Depende: gambas2-gb-image (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-info (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-ldap (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-net-curl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-net-smtp (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-opengl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-pcre (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-pdf (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-ext (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-kde-html (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-qt-opengl  but it is not installable
 Depende: gambas2-gb-sdl (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-settings (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-vb  but it is not installable
 Depende: gambas2-gb-v4l (>=1.9.49-1) but it is not installable
 Depende: gambas2-gb-web  but it is not installable
 Depende: gambas2-gb-xml (>=1.9.49-1) but it is not installable
 Depende: gambas2-ide (>=1.9.49-1) but it is not installable

 

Bueno, amigo patagonianuser soy algo nuevo en esto de linux, y mas aun e ubuntu asi qeu no se como haria eso de jaula de 32 bits, ahora este ubuntu 7.10 es unicamente de 64bits o existe la version de 32bits?. 

+1
0
-1
Imagen de patagonian18
+1
0
-1

Bueno, digamos que tengo ya cierta comodidad en el manejo de Ubuntu, pero me falta bastante para ser experto. Ubuntu está en ambas versiones: 32 bits, para cualquier pc (core duo, pentium, athlon, sempron, turion, etc) y 64 bits (AMD de 64 bits).

Lo de la jaula de 32 bits consiste en un directorio (carpeta) que se comporta como el directorio raíz (/) para todos los programas que están en su interior. He visto una guía hace poco aquí en el foro. De hecho, aquí hay una. Puedes encontrar más información si buscas en google por chroot.

Por último, te recomiendo instalar mediante Synaptic, en vez de Añadir y quitar pues tiene más opciones y te entrega más información.   

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de Goyo
+1
0
-1

No sé qué lío hay en los repositorios, pero parece que muchos de los paquetes de los que depende gambas2 no están disponibles para 64 bits aunque el propio gambas2 sí está.

http://packages.ubuntu.com/gutsy/gambas2-gb-compress-bzlib2 

Pero en la página de descargas de Gambas aparece un enlace a versiones para Ubuntu más recientes que las de los repositorios oficiales, a lo mejor allí hay más suerte.


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de LiQueX
+1
0
-1

Agradezco la ayuda de los usuarios de este foro, ps de todas aprendi algo mas sobre el manejo de instaladores en linux, como no encontre respuesta valida para lo que deseaba hacer tome la desicion de:

PRIMERO: Instalar nuevamente mi ubuntu 7.10 e intentar nuevamente crear mi carpeta de 32bits, tal vez funcione desde una instalacion nueva.

SEGUNDO: Si lo anterior no me funciona migrare a  mi ubuntu 6.06 que es lo mas facil que encontre hasta ahora, y si logre instalar en ello mi gambas, asi que de todas formas si aun hay alguien que me de ua solución estare completamente agradecido.

+1
0
-1
Imagen de Goyo
+1
0
-1

No estoy seguro, pero me parece que no has seguido mi consejo de mirar en la página de descargas de Gambas.


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de LiQueX
+1
0
-1

Intentado crear mi carpeta de 32bits tengo algunos problemas en mi ubuntu, miren indico la instruccion para actualizar, hasta alli todo bien:

ubtex@ubtex-desktop:~$ sudo apt-get update
[sudo] password for ubtex: ************
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016) gutsy/main Translation-es
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release amd64 (20071016) gutsy/restricted Translation-es
Des:1 http://archive.ubuntu.com gutsy Release.gpg [191B]
Des:2 http://archive.ubuntu.com gutsy/universe Translation-es [139kB]
Obj http://archive.ubuntu.com gutsy Release
Obj http://archive.ubuntu.com gutsy/universe Packages
Descargados 139kB en 33s (4199B/s)
Leyendo lista de paquetes... Hecho

ahora cuando indico la instalacion del paquete me da esto:

ubtex@ubtex-desktop:~$ sudo apt-get install dchrot debootstrap
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se pudo encontrar el paquete dchrot
ubtex@ubtex-desktop:~$

y luego ya no me permite instalar nada, lo he intentado reinicando varias veces y nada, he buscado y todos me indican lo mismo, lamentablemente no encuentro otra forma, lo he intentado con synaptic y me da ese otro error:

No se puedieron marcar los paquetes para instalacion o actualizacion

Los siguientes paquetes tienen dependencias no resolubles. asegurese de que todos los repositorios requeridos esten añadidos y activados en las preferencias

schroot:
 Depende: liblockdev1  but it is not installable

 Ese es el error, bueno creo que el ser novato trae sus consecuencias, pero aun asi si alguien tiene una solucion mela comenta, gracias por todo.

+1
0
-1
Imagen de LiQueX
+1
0
-1

Gracias Goyo acabo de terminar la instalacion de mi Ubuntu 7.10 nuevamente y aun asi persiste el problema, mi intencion es trabajar no solo con Gambas pues tambien deseo trabajar con Monodevelop y con Mysql Server y Client y no los puedo instalar por el mismo error, aun lo seguire intentando, tambien intentare instalar Anjuta en el caso de que ninguno agarre, sobre lo de la pagina de Gambas2 estoy bajando los repositorios el problema es que como soy aun novato no tengo idea de que hacer con los archivos .tar.bz2 ni como hacer para instalarlos pero de todas formas buscare informacion al respecto pero si tienes algun atajo me serviria de mucho que lo puedas compartir, gracias.

+1
0
-1
Imagen de Goyo
+1
0
-1

Si es que os vais a lo más difícil por no leer...

No descargues lo primero que encuentres y menos si no sabes qué vas a hacer con ello, busca la sección sobre Ubuntu. 

Equipo de moderadores
Normas

Documentación

+1
0
-1
Imagen de LiQueX
+1
0
-1

Agradezco por su ayuda, y tenias razon Goyo, logre instalar Gambas2 al fin, eso lo logre hace 8 dias apros, tuve que que hacer un esfuerzo para poder entender las instrucciones que indicaban en ingles y hoy los vi y ya estan en español, bueno poco a poco las experiencias que he pasado en esos dias de verdadero martirio me han enseñdo mucho, gracias.

+1
0
-1