Necesito asistencia para montar sda1

Imagen de Nita
0 puntos

Hola, soy casi nueva en linux, he estado mirando guías y demás, pero no consigo montar sda1, he probado escribir de distintas formas sudo mount...pero nada.

He seguido la guía de aquí "montar particiones" pero estoy verde en algunos pasos. 

Lo más correcto que creo que debo poner en el comando es:

sudo mount -t vfat /dev/sda1 /mnt/windows , tengo creada en media una carpeta que la llame "montar", pero luego me di cuenta que tenia tambien fuera de media la carpeta "mnt" .

Tengo windows con dos particiones sda2 y sda3 , mas la partición que no me reconoce sda1. Y de Ubuntu tengo otras 3 particiones:  sda5, sda6, sda7 (/home, swap y /).

Muchas gracias .

Imagen de furtaxi
+1
0
-1

 Desde Windows, comprueba con el scandisk todas las particiones.

Si tienen errores, GNU/Linux no las monta. 

Roberto. (Alias TIMT)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

Colabora con Preguntas Frecuentes, para mejorar el foro.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Nita
+1
0
-1

Hola furtaxi, acabo de hacer lo que me has dicho, pase scandisk a las dos particiones de windows,sí que tenía errores pero ya les ha corregido. He intentado montar la partición y no lo consigo:

sudo mount -t vfat /dev/sda1 /mnt/windows

me dice que wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or herlper program or other error.......(ahora no me deja copiar-pegar el firefox grrrr)

¿qué puedo hacer?

 

+1
0
-1
Imagen de Goyo
+1
0
-1

La partición debe tener formato FAT. Si tiene formato NTFS (habitual con Windows NT, 2000 y XP) deberías poner ntfs-3g en vez de vfat (lo digo de memoria pero creo que es así).

El directorio /mnt/windows debe existir previamente. Cuando Ubuntu monta automáticamente las particiones lo hace en directorios que crea dentro de /media (/media/sda1 y cosas así) pero realmente se pueden montar en cualquier directorio que exista. Lo que no puede hacer mount es crear él mismo el directorio para montar la partición, has de hacerlo tú primero.

Para poder leer y escribir en la partición montada con tu cuenta de usuario probablemente es necesario que el directorio de montaje tenga los permisos adecuados (no estoy muy seguro de eso) y también añadir algunas opciones al comando mount. No me lo sé de memoria, pero los manuales de mount y fstab ($ man mount, $ man fstab), la documentación de ubuntu-es, la guía ubuntu, etc. pueden ayudar.

Aunque te recomiendo que investigues sobre mount y fstab, porque en caso de problemas pueden ser la única forma de salir del apuro, hay una interfaz gráfica para montar particiones (una especie de editor de fstab) que a mí siempre me ha ido muy bien. El paquete se llama pysdm y una vez instalado aparece en Sistemas->Administración->Dispositivos de almacenamiento.

 


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de Nita
+1
0
-1

Hola Goyo, gracias por responder:

Puse formato FAT, que es el que tiene la partición que quiero montar, en el comando pongo "sudo mount -t vfat...."

Ya había creado  la carpeta en mnt que se llama "windows".

 He leído y revisado $ man mount, $ man fstab), la documentación de ubuntu-es, la guía ubuntu, etc. como dices, pero en algunos puntos estoy verde, de ahí que digo que necesito una ayuda un poco más personalizada, además man mount y man fstab están en inglés y mi inglés es regular.

He estado mirando sobre mount y fstab, instalé pysdm y probé desde ahí a montarla, pero no actúa, o eso me parece. No monta la partición, algo tendré mal.

He mirado el archivo sudo gedit /etc/fstab y he intentado editarlo, pero creo que lo estropeado porque me han salido todas esas líneas de abajo que antes no estaban:

 # /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc          proc         defaults                    0  0 
# /dev/sda5
UUID=9fbb4c6d-b7c4-4396-898e-bb188f1aaaf5  /              ext3         defaults,errors=remount-ro  0  1 
# /dev/sda7
UUID=a1c3783e-5bd4-4b0b-986c-3a4240deda38  /home          ext3         defaults                    0  2 
# /dev/sda2
UUID=0C6C11916C117724                      /media/sda2    ntfs         defaults,umask=007,gid=46   0  1 
# /dev/sda3
UUID=00567E9A567E9060                      /media/sda3    ntfs         defaults,umask=007,gid=46   0  1 
# /dev/sda6
UUID=49660434-29fd-49dc-9cb7-569e724110f6  none           swap         sw                          0  0 
/dev/scd0                                  /media/cdrom0  udf,iso9660  user,noauto,exec            0  0 
/dev/sda1                                  /mnt/windows   vfat           0  0 
/dev/sda2                                  /media/sda2    ntfs         defaults                    0  0 
/dev/sda3                                  /media/sda3    ntfs         defaults                    0  0 
/dev/sda5                                  /media/sda5    ext3         defaults                    0  0 
/dev/sda6                                  /media/sda6    swap         defaults                    0  0 
/dev/sda7                                  /media/sda7    ext3         defaults                    0  0 
/dev/sda1                                  /media/sda1    vfat         defaults                    0  0 

 Dadme más pistas, por favor, que aunque leo información no me entero mucho, gracias.

+1
0
-1
Imagen de Goyo
+1
0
-1

Haz una copia de /etc/fstab por precaución. Edita /etc/fstab y borra las últimas 7 líneas:

/dev/sda1                                  /mnt/windows   vfat           0  0  
/dev/sda2 /media/sda2 ntfs defaults 0 0
/dev/sda3 /media/sda3 ntfs defaults 0 0
/dev/sda5 /media/sda5 ext3 defaults 0 0
/dev/sda6 /media/sda6 swap defaults 0 0
/dev/sda7 /media/sda7 ext3 defaults 0 0
/dev/sda1 /media/sda1 vfat defaults 0 0

y sustitúyelas por esto:

/dev/sda1                                  /mnt/windows    vfat         defaults                    0  0 

Después escribe en un terminal:

$ sudo umount -a
$ sudo mount -a
$ mount

Y pega aquí la salida.


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de Nita
+1
0
-1

fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc          proc         defaults                    0  0  
# /dev/sda5
UUID=9fbb4c6d-b7c4-4396-898e-bb188f1aaaf5  /              ext3         defaults,errors=remount-ro  0  1  
# /dev/sda7
UUID=a1c3783e-5bd4-4b0b-986c-3a4240deda38  /home          ext3         defaults                    0  2  
# /dev/sda2
UUID=0C6C11916C117724                      /media/sda2    ntfs         defaults,umask=007,gid=46   0  1  
# /dev/sda3
UUID=00567E9A567E9060                      /media/sda3    ntfs         defaults,umask=007,gid=46   0  1  
# /dev/sda6
UUID=49660434-29fd-49dc-9cb7-569e724110f6  none           swap         sw                          0  0  
/dev/scd0                                  /media/cdrom0  udf,iso9660  user,noauto,exec            0  0  
/dev/sda1                                  /mnt/windows    vfat        defaults                    0  0

 

Escribí mount en el terminal:

ana@ana:~$ sudo umount -a
umount: /home: dispositivo ocupado
umount: /dev/shm: dispositivo ocupado
umount: /dev: dispositivo ocupado
umount: /var/run: dispositivo ocupado
umount: /: dispositivo ocupado
ana@ana:~$ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error
       En algunos casos se encuentra información en syslog, pruebe
   dmesg | tail   o algo parecido

ana@ana:~$ sudo mount
/dev/sda5 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda7 on /home type ext3 (rw)
/dev/sda2 on /media/sda2 type fuseblk (rw,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
/dev/sda3 on /media/sda3 type fuseblk (rw,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
ana@ana:~$
 

 

+1
0
-1
Imagen de Goyo
+1
0
-1

Si realmente la partición tiene formato FAT, lo único que se me ocurre es que esté en mal estado. Intenta desfragmentarla desde Windows y asegúrate de que Windows se cierra normalmente, luego vuelve a intentarlo.

¿Qué hay en esa partición? ¿Por qué tiene formato FAT?


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de Nita
+1
0
-1

Pufff, pues desde windows imposible desfragmentarla porque no la reconoce, como que no existe.  En esa partición creo que windows me guardaba por defecto las cosas internas del pc ( no entiendo mucho) por ejemplo, la cámara en windows ha dejado de funcionar, aún reinstalando el driver.

Si tiene formato fat o ntfs no lo sé, me guié en decir que tiene formato fat porque es lo que me pareció ver en el programa gparted o en el otro que me han recomendado aquí para montar particiones, allí pone vfat.

Si crees que pudiera tener formato ntfs, ¿qué comando tendría que probar?

+1
0
-1
Imagen de Goyo
+1
0
-1

La partición parece estar en mal estado y así no creo que en Linux se pueda montar. Por otro lado si ni siquiera sabes lo que hay ahí no tiene sentido que gastes mucha energía en intentar montarla. De todas formas escribe esto:

$ sudo fdisk -l

Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de Nita
+1
0
-1

ana@ana:~$ sudo fdisk -l

[sudo] password for ana:

Disco /dev/sda: 120.0 GB, 120034123776 bytes
255 cabezas, 63 sectores/pista, 14593 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x89255405

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1               1         557     4474071   27  Desconocido
/dev/sda2   *         558        4205    29302560    7  HPFS/NTFS
/dev/sda3            9254       12901    29302560    7  HPFS/NTFS
/dev/sda4            4206        9253    40548060    5  Extendida
/dev/sda5            4206        7853    29302528+  83  Linux
/dev/sda6            7854        8339     3903763+  82  Linux swap / Solaris
/dev/sda7            8340        9253     7341673+  83  Linux

Las entradas de la tabla de particiones no están en el orden del disco
ana@ana:~$

¿por qué dices qué parece estar en mal estado? es por saberlo.

Bueno , y sobre que no sé lo que había en esa partición, bueno, puede que no sepa exáctamente lo que era, porque son archivos de windows que no entiendo (soy humana)pero pienso que eran archivos internos importantes;  y sí, quiero gastar energía en aprender a montar la partición, si es posible. Por cierto, a lo mejor si te digo que esa partición en windows la llaman WinRe lo mismo ya sabes de qué va.

Si quiero mantener xp es porque mi portátil no es muy común y es difícil configurar todo, y lo mismo con ubuntu no consigo todas las características: pantalla táctil, cámara...botones de rotación de pantalla...si no, instalaba Ubuntu en todo el pc.

Mi blog : www.kohjinshash6.blogspot.com

Gracias por molestarte.

+1
0
-1
Imagen de Goyo
+1
0
-1

Uno esperaría que Windows sería capaz de desfragmentar una partición de Windows sana.

Sin embargo una consulta rápida en Google muestra que winre significa Windows Recovery Environment. No sé exactamente lo que es pero supongo que, como su propio nombre indica, sirve para recuperar el sistema en caso de desastre y no se utiliza para el funcionamiento normal del sistema .

Probablemente está en algún ingenioso formato inventado por Microsoft que sólo ellos saben cómo funciona y ese sea todo el problema.


Equipo de moderadores
Normas

Documentación
+1
0
-1
Imagen de furtaxi
+1
0
-1

 Casi seguro, que es la partición de recuperación del sistema, esa que ponen para ahorrarse unos céntimos del CD original de Windows.

Quizás una tecla de función active el sistema de recuperación, se cepilla todo, y te deja un Windows nuevo. Si tienes cds de instalación de windows, yo la borraría tranquilamente, en caso contrario, arrancar en Windows, y buscar el programa para crear dichos cds. Por si acaso, haz dos copias, que no me fio mucho de los medios ópticos. 

Roberto. (Alias TIMT)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

Colabora con Preguntas Frecuentes, para mejorar el foro.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Nita
+1
0
-1

Bueno, gracias por aclararme todo esto un poco...he encontrado "restaurar sistema" en windows, intentaré hacer algo.

Lo mismo en 3 días instalo la nueva versión Hardy Heron en todo el pc, no sé no sé, me da pena porque es un xp original, (me vino sin cd).

Bueno gracias por todo. ;D

 

+1
0
-1
Imagen de furtaxi
+1
0
-1

Restaurar sistema, es para dejarlo como estaba antes de instalar algo, o tonterías así.

Lo que debes buscar, que tendrá un nombre acorde con el modelo de ordenador, es un programa para generar cds o dvds de instalación.

Como ya te dije, algunas máquinas tienen una tecla de función, que hay que apretar durante el arranque del ordenador, para entrar al programita, así que enciende el ordenador, y mira todos los mensajes de la BIOS, suele salir una línea del tipo "Press F11 for recovery", o algo así.

Si eso, consulta la web del fabricante, vete directo a las FAQs.

Roberto. (Alias TIMT)

Mi página: www.vigonews.es

Lee y cumple las Normas. Busca antes de preguntar.
En cada hilo, márcalo adecuadamente.

Colabora con Preguntas Frecuentes, para mejorar el foro.

+1
0
-1

Mi web : www.vigovideo.es
Buscar es más rápido que esperar una respuesta.

Imagen de Nita
+1
0
-1

ah! ok ok!

Voy a mirar la página del fabricante, supongo que será ésta: http://www.kohjinsha.com.sg/faq.htm

Voy a mirar un poquito la BIOS, a ver si veo algo.

+1
0
-1