Como arrancar en modo texto?

Imagen de Emenalo
0 puntos

Hola necesito arrancar en modo texto para instalar mi tarjeta NVIDIA. He probado con poner al final de la linea del grub en el arranque pulsando la "e" un 3 al final y no me funciona y el archivo etc/inittab tampoco aparece, alguien pude decirme como puedo arrancar en modo texto?

Imagen de starter
+1
0
-1

en el grub pulsas "e" y al final de la linia que define el kernel pones init=/bin/bash

creo que era asi.

+1
0
-1
Imagen de milord
+1
0
-1

Si lo que quieres es instalar los drivers propietarios de la tarjeta grafica, debes hacerlo de otra forma.

Arrancas en modo gráfico, Administración/gestor de controladores restringidos, habilitas el controlador y ubuntu te lo instal.

Para instalar el controlador de tu tarjeta de video hay una herramienta muy completa que lo hace por tí, se trata de envy.

http://www.albertomilone.com/nvidia_scripts1.html

Un saludo. 

 

 

 

+1
0
-1
Imagen de Incanush
+1
0
-1

¿que sucede si estoy instalando ubuntu y mi PC no tiene taqrjeta grafica?, si existe algun error, ¿como lo corrijo, sin tener que comprar la tarjeta?

+1
0
-1
Imagen de Emenalo
+1
0
-1

He intentado instalar la t. gráfica NVIDIA GeForce Go 7400 utilizando los drivers restringidos, el programa envyNG y desde en modo texto con los drivers descargados de la página de nvidia sin ningun resultado positivo.

 

Si instalo desde envyNG o desde los drivers restringidos me dice que todo ok que reinicie y cuando reinicia me dice que tengo que entrar en modo baja resolución (vamos que tira de drivers VESA) y si lo hago por el modo texto con los drivers despues de intentar descargar el kernel me da este error:

NVIDIA: left KBUILD.
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
       frequently when this kernel module was built against the wrong or
       improperly configured kernel sources, with a version of gcc that differs
       from the one used to build the target kernel, or if a driver such as
       rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
       obtaining ownership of the NVIDIA graphics device(s).
      
       Please see the log entries 'Kernel module load error' and 'Kernel
       messages' at the end of the file '/var/log/nvidia-installer.log' for
       more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
   -1 No such device
-> Kernel messages:
   [  902.512206] warning: process `nvidia-installe' used the deprecated sysctl
   system call with 1.23.
   [  902.512217] warning: process `nvidia-installe' used the deprecated sysctl
   system call with 1.23.
   [  903.103425] NVRM: This PCI I/O region assigned to your NVIDIA device is
   invalid:
   [  903.103427] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0001:00.0)
   [  903.103432] NVRM: The system BIOS may have misconfigured your graphics
   card.
   [  903.104687] nvidia: probe of 0000:01:00.0 failed with error -1
   [  903.104711] NVRM: The NVIDIA probe routine failed for 1 device(s).
   [  903.104713] NVRM: None of the NVIDIA graphics adapters were initialized!
   [  908.449874] warning: process `nvidia-installe' used the deprecated sysctl
   system call with 1.23.
   [  991.977057] CPU0 attaching NULL sched-domain.
   [  991.977064] CPU1 attaching NULL sched-domain.
   [  992.003827] CPU0 attaching sched-domain:
   [  992.003833]  domain 0: span 03
   [  992.003835]   groups: 01 02
   [  992.003839] CPU1 attaching sched-domain:
   [  992.003840]  domain 0: span 03
   [  992.003842]   groups: 02 01
   [ 1155.482946] warning: process `nvidia-installe' used the deprecated sysctl
   system call with 1.23.
   [ 1155.482957] warning: process `nvidia-installe' used the deprecated sysctl
   system call with 1.23.
   [ 1155.802094] NVRM: This PCI I/O region assigned to your NVIDIA device is
   invalid:
   [ 1155.802097] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0001:00.0)
   [ 1155.802105] NVRM: The system BIOS may have misconfigured your graphics
   card.
   [ 1155.802116] nvidia: probe of 0000:01:00.0 failed with error -1
   [ 1155.802140] NVRM: The NVIDIA probe routine failed for 1 device(s).
   [ 1155.802145] NVRM: None of the NVIDIA graphics adapters were initialized!
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

 

 

Si alguien  puede darme unas indicaciones de cual puede ser el problema...

+1
0
-1