Problema con Wireless ipw2200bg

Imagen de oidacra
0 puntos

Bueno e sla primera vez que escribo en este foro, y la verdad he aprendido mucho de el, yo trato de resolver siempre los problemas leyendo, buscado, probando pero esta vez creo que ya me ha ganado.

Tengo una intel ipw2200 e instale el hardy y me reconoce la tarjeta, probe desisntalando todo, hablo de drivers, ieee, firmware, bueno todo, lo volvi a compilar todo y nada.

cuando arranco y tengo el switch de la antena encendido me manda un error algo TX_powe etc. De esta manera no me encuentra la eth1

cuando la arranco sin el switch apagado entra normal. sin ningun error de nada. Luego de encender de esta manera, enciendo el switch ya edspues de logueado, y ok encuentra el eth1, hago todo lo de ponerle que es dhcp, que tiene clave, bueno todo esto. 

El probleeema de todo es que no me encuentra ninguna red inalambrica, y juesto frente esta el router inalambrico, el cual cuando entro en windows si funciona correctamente.  

La verdad espero que alguien me ayude porque de verdad ya no se que hacer, no soy super experto en linux, y quisiera saber si alguien ha hecho una instalacion limpia de los drivers y ver si me comi algo en el camino que no hice. Ah y tampoco me funciona por cable,  tambien me pasa lo mismo, reconoce todo pero le pongo IP o DHCP y no conecta nada. no c si sea algo en mi ubuntu 8.04

Muchas gracias..... 

Imagen de akenaton
+1
0
-1

Mira las DNS si las has puesto que es algo que se olvida facilmente. Akelinux.

+1
0
-1
Imagen de oidacra
+1
0
-1

si le puse los dns, realmente que no he intentado, antes con el 7.10 tambien me daba lio, pero la reiniciaba un par de veces,, y se arreglava... COMO no se pero eso sucedia asi., el wireless para que me funcionara, tenia que apagar el sw y cuando entraba en login era que lo encendia, si n olo hacia asi no funcionaba, y bueno....

Es extrano que una tarjeta tan vieja tenga tanto lio con un ubuntu tan nuevo.

He usado backtrack y alli perfectamente me sirve. es mas en live cd sirve... porque no cuando se instala en que difiere eso.  

+1
0
-1
Imagen de oidacra
+1
0
-1

Una toshiba tecra A4-s211

tiene 1.5GB de ram

1.6 Ghz centrino

60 gb disco

y le instale el 8.04 ubuntu. espero su ayuda. 

+1
0
-1
Imagen de oidacra
+1
0
-1

muchas gracias revisare los links.

te agradesco mucho, la verdad tengo unos meses usando ubuntu, y creo que es una excelente distro, y bueno no quiero tener que desfallecer por no poder configrar mi wireless gracias.. posteare si me resulto... 

+1
0
-1
Imagen de oidacra
+1
0
-1

Me he percatado que todo anda bien, drivers, firmwares... entre muchas cosas mas.... les dejo el dmesg y el lspci para que lo vean.... si ven algo raro porfavor me dicen...

La manera de que el dmesg del ipw2200 y del ieee80211 me salgan asi... tengo ke apagarla y encenderla con el swich apagado, cuando hago login es que entocnes puedo encender el sw de la wireless

arcadio@arcadio-laptop:~$ dmesg | grep ipw
[ 19.523108] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2dmprq
[ 19.523112] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 19.596283] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 23.194938] ipw2200: Radio Frequency Kill Switch is On:
[ 23.196426] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)

arcadio@arcadio-laptop:~$ dmesg | grep iee
[ 14.328504] [<f88e5270>] hpsb_bus_reset+0x0/0x100 [ieee1394]
[ 19.276650] ieee80211_crypt: registered algorithm 'NULL'
[ 19.348393] ieee80211: 802.11 data/management/control stack, 1.2.18
[ 19.348396] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>

arcadio@arcadio-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 04)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8036 PCI-E Fast Ethernet Controller (rev 10)
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:06.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:06.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:06.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
06:06.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller

 

en una arrancada normal el ifconfig me sale esto

eth0 Link encap:Ethernet direcciónHW 00:a0:d1:bc:9d:23
ARRIBA DIFUSIÓN MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
colisiones:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupción:11

eth1 Link encap:Ethernet direcciónHW 00:0e:35:e1:e7:f5
dirección inet6: fe80::20e:35ff:fee1:e7f5/64 Alcance:Vínculo
ARRIBA DIFUSIÓN MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:161 overruns:0 carrier:0
colisiones:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupción:11 Dirección base: 0x8000 Memoria:b000b000-b000bfff

eth1:avahi Link encap:Ethernet direcciónHW 00:0e:35:e1:e7:f5
inet dirección:169.254.11.129 Difusión:169.254.255.255 Máscara:255.255.0.0
ARRIBA DIFUSIÓN MULTICAST MTU:1500 Metric:1
Interrupción:11 Dirección base: 0x8000 Memoria:b000b000-b000bfff

y en mi /etc/network/interfaces
auto lo
iface lo inet loopback

iface eth0 inet static
address 168.77.202.4
netmask 255.255.255.192
gateway 168.77.202.1

iface eth1 inet dhcp
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid PANNet

auto eth1

 

*******************

para mi todo anda bien.... hasta me sale el eth1 en la configuracion de la red /sistema/administracion/red

instale el wifi-radar, y todo andando como lo anterior descrito, no me sale ninguna red, nadda vacio, y el router lo tengo alado de la laptop. Reinicio y entro en windows, y entra a internet asi ke no es nada con el router.

Anteriormente tenia ubunto 7.10 tenia lago asi estos mismos problemas... pero reiniciaba un parde veces.. y magicamente si funcionaba... pero ahora con el 8.04 no. la verdad no c cual sea la diferencia...

Hice una instalacion limpia.... Please alguien que me de la mano.

ahh otra cosa.... me pasa lo mismo con la de red. Conecto directo al router, pongo IPS y no anda, pongo dhcp menos, reinicio con ip a ver si agarra los ips , nada, ya coloque DNS coloque todo. Pienso que pueda ser algo en la misma laptop pero la verdad no c.

Tengo una Tecra A4-s211

gracias.

+1
0
-1
Imagen de eivar
+1
0
-1

Hola, este problema está reportado como un error, pero dan unas recomendaciones que parcen ayudar: https://launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/55532

Básicamente como dicen al final de este post  debes adicionar las opciones de arranque siguientes al kernel :

lapic irqpoll

 

¡El mundo es mejor cuando eres LIBRE de elegir!
LoCo-Panama

+1
0
-1