Hardy no monta ni desmonta automaticamente mi /home

Desde que instale hardy (instalacion limpia) tengo el problema de que cada vez que enciendo el ordenador me hace un chequeo de discos aunque haya apagado bien la ultima vez y deja la particion sin montar, tengo que hacer manualmente un "mount /dev/sda2". Poco despues me di cuenta de que la particion de windows tampoco estaba montada, por lo que llego a la conclusion de que no me monta los discos al iniciar ni los desmonta al apagar. La unica particion con la que lo hace es con /

 

Tengo un disco duro con 4 particiones:

dev/sda1   ----> particion de windows (ntfs)

dev/sda2 ------> /home (ext2)

dev/sda3 ------->/ (ext3)

dev/sda4-------->swap

Creo que el problema está en   /etc/fstab      donde deberia añadir la opcion para que se monten automaticamente dev/sda1 y dev/sda2 pero no quiero tocar nada sin estar seguro, asi que copio aqui mi /etc/fstab para que meindiqueis cuales son los cambios que debo hacer

 

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=a8d87990-83b9-4378-bd90-d0bff20f0d7a /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda2
UUID=33e302b4-cb4b-4c90-ad6d-2422222070e3 /home           ext2    relatime        0       2
# /dev/sda1
UUID=BC2052132051D4CC /windows        ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda4
UUID=f2912619-78f9-4a4f-9583-61bea756c9af none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

Imagen de gotxa
+1
0
-1

Hola kartoffentortilla,
verifica que las particiones tienen físicamente el UUID que /etc/fstab supone... y modifica /etc/fstab en concordancia.
$ ls -l /dev/disk/by-uuid

Salud,
P.D. jo qué hambre da tu nick
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de tortilladepatatas
+1
0
-1

comprobado, los UUID son correctos.

 

Por cierto a mi me da mas habre el kebab de mi imagen

+1
0
-1
Imagen de geracbrspd
+1
0
-1

bajate el programa disk manager y con este ya me monta las unidades al arranque, saludos!!

+1
0
-1

Nadie sabe lo que tiene, hasta que conoce LINUX!!!

Imagen de tortilladepatatas
+1
0
-1

Gracias, pero el problema es que no puedo iniciar sesion sin mi /home montado, y tengo que hacerlo a mano, asi que no tiene sentido que me la monte este programa al iniciar sesion. A demas prefiero no meter programas que no vienen en ubutu para algo que puede hacer la instalación por defecto.

+1
0
-1
Imagen de gotxa
+1
0
-1

hola patatasomelett

$ blkid 

te dará info de los dispositivos de bloques (las particiones). Comprueba que efectivamente es del tipo que quiere /etc/fstab

En mi caso, que tengo todas las particiones de tipo ext3 me sale:

$ blkid | grep home 
/dev/sda4: LABEL="/home" UUID="29822b6c-5342-40a1-8bc8-cc0e388612dd" SEC_TYPE="ext2" TYPE="ext3"

Por otra parte, no hay problema en modificar /etc/fstab. Simplemente recuerda/anota/haz copia de seguridad, para restaurarlo todo como estaba si no te pita... así de fácil. Si quieres pasar tu partición /home de ext2 a ext3 lo puedes hacer sin perder datos con tune2fs (http://www.ubuntu-es.org/index.php?q=node/86358)

EDITADO: creo que la madre del cordero está en la opción 'relatime' de tu /etc/fstab (yo tengo simplemente 'defaults' ahí por eso he leído de qué va pero ojo que aun no me actualicé a Hardy, incluso yo no tengo esa opción en mount).

Según
http://ubuntuforums.org/showthread.php?t=692318
https://launchpad.net/ubuntu/+source/partman-basicfilesystems
https://bugs.launchpad.net/ubuntu/+source/partman-partitioning/+bug/160450
es una nueva característica de Hardy y se supone ya resuelta.

Yo por si acaso, le pasaría un chequeo con

$ fsck.ext2 -pf /dev/tuparticionhome

(ojo, debe estar desmontada, -p para reparar sin preguntar y -f para forzar el chequeo) y/o probaría otras opciones de montaje (todos los ejemplos que ví utilizan relatime junto a otras).

Ya que le estuve echando un vistazo, más info sobre relatime en:
http://linux.slashdot.org/article.pl?sid=07/08/08/1810243
http://lkml.org/lkml/2006/8/25/380

GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de tortilladepatatas
+1
0
-1

Muchas gracias por la ayuda, pero ayer decidi reisntalar, como la instalacion era de hace 3 dias no era demasiado trabajo y pensé que tardaria menos asi que esperando respuesta. Vi tu ultimo comentario justo cuando reinicie tras la instalacion, si no lo hubiera probado.

Como informacion tengo que decir que el /etc/fstab que tenia estaba bien, ya que el que tengo ahora es exactamente igual y funciona bien, asi que el problema estaba en otro sitio.

Gracias de todas formas por tomarte la molestia.

+1
0
-1
Imagen de gotxa
+1
0
-1

pues yo llevo un par de días aprendiendo y combinando bocatas de tortillapapas... A tu salud
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto