problemas driver de nvidia 8600 en hardy (solucionado)

Imagen de leopoldof3
0 puntos

 Primero decir que uso ubuntu desde edgy y nunca habia tenido problemas con las gráficas en gutsy funcionaban muy bien todo los efectos del compiz; Pero formatie todo para empezar desde cero con la instalación de Hardy y hasta ahora todo bien excepto por el driver de la tarjeta gráfica, al iniciar automaticamente me dijo que existían controladores restringidos para la tarjeta y los instalo como lo había hecho en gutsy, pero al reiniciar llego a una pantalla blanca con una lineas negras verticales y de hay no pasa, me meto en modo recovery y recupero las x pero no tengo aceleración y de hecho me marca este error al usar el comando glxinfo  Error: couldn't find RGB GLX visual, y con el de glxgears  me da                                       

Xlib:  extension "GLX" missing on display ":0.0".  

Error: couldn't get an RGB, Double-buffered visual

y al checar en controladores me dice que no se esta usando el driver restringido, lo vuelco a intentar instalando desde synaptic nvidia-glx-new y al reiniciar me topo de nuevo con la pantalla blanca, y esas rallas negras, lo intente tambien por medio de envyng y me da el problema de resolucion reducida y no logro configurarla ni en el xor ni con nvidia settings, por último lo intenta con el driver de la página de nvidia siguiendo las instruciones adecuadas y con todo llego siempre a la misma pantalla blanca con rallas negras.

Quisiera saber si a alguien le sucede lo mismo, o alguna idea de como poder tener la aceleración ?

de antemano gracias por sus respuestas

ay ay ayde

 

Imagen de HaMmeTT
+1
0
-1

A ver si algún administrador crea un post permanente porque creo ya hay 10 o 15 diferentes de lo mismo y ya no los encuentro.

+1
0
-1
Imagen de leopoldof3
+1
0
-1

Bueno por fin despues de unos dias  queriendo solucionarlo aquí el como :

Bien lo primero desintalar desde synaptic todo lo que tiene que ver con el driver de nvidia, osea el envyng, el nvidia-glx-new, etc.

A mi la primera vez que lo intente me salio un error de que ya había algo de nvidia instalado en el kernel así que formatie todo y al reinstalar lo primero que hice fue seguir los siguientes pasos, solo así me funciono aunque no creo que sea necesario formatear nada;

Bien lo primero bajarse los driver más nuevo de envidia lo puedes hacer aquí

http://www.nvidia.com/object/linux_display_ia32_173.08.html

guardas el archivo el tu carpeta personal para no andar poniendo la dirección del archivo, presionas ctrl+alt+F1 para irte a esa consola por que necesitaras parar el entorno gráfico, esto lo haces con este comando 

sudo /etc/ init.d/gdm stop

despues corres el archivo .run de envidia 

sudo sh ./NVIDIA-Linux-x86-173.08-pkg1.run

contestas que si a todo

Cuando haya terminado te dira que todo bien, despues modificamos cierto archivo

sudo nano /etc/default/linux-restricted-modules-common

y buscas la linea que dice disabled_modules=""

dentro pones nv de tal forma que queda así:

Disabled_modules="nv"

guardas con control+0

y sales con control+x

despues reinicias con 

sudo reboot now

al iniciar ya debes de tener la aceleración gráfica.

Ahora solo queda el problema de que el tecaldo se desconfigura, y sale una fea pantalla al inicio que dice nvidia linux beta, esto lo arregle modificando el xorg, por si alguien necesita algo de ayuda lo haces así

sudo gedit /etc/X11/xorg.conf

 ahí solo modifican lo que vean

les pego el mio para que se den una idea, ya tiene configurado el touchpad, el teclado en distribución latinoamerica y el parametro para que no salga el logo feo de nvidia jejeje

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
        Identifier     "Layout0"
            Screen      0  "Screen0"
        InputDevice    "Synaptics Touchpad"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "latam"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "NoLogo"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 

Bueno creo que me alargue más de la cuenta, espero que alguien le sirva por lo menos

ay ay ayde

+1
0
-1

ay ay ayde

Imagen de Nemut
+1
0
-1

estaba teniendo muchos problemas con el driver de nvidia, con el teclado, con el scrol del touchpad, etc... y tu solución me ha venido genial.
Muchas gracias por el aporte.

+1
0
-1
Imagen de arielvissig
+1
0
-1

Buenas, yo lo instale y todo bien, salvo que no puedo poner la resolucion bien, tengo hasta 800 x 600 y tengo un lcd de 22, lo cual necesitaria 1600 x 1050 (si no me equivoco)
Peor la cuestion es esa, como podria hacer para que me tome las otras resoluciones?'

Gracias de antemano.

Quiero el mundo linux!!!

+1
0
-1

Quiero el mundo linux!!!