qgl.h???incompatibilidad?? porq?

Imagen de zprian
0 puntos

hola a tod@s
estoy haciendo unas practicas con el qt-designer y me he encontrado que no me encuentra la libreria qgl.h, resulta que me he intentado bajar algunas librerias donde creo que esta... pero ninguna de ellas me la deja instalar por "incompatibilidades", he probado con la freeglut3, xlib, libmesa, y no se cual mas..alguien me podria decir porq es eso de las incompatibilidades... y cual me podria bajar??

asias

Imagen de gabiel
+1
0
-1

Esa librería se encuentra en libqt3-mt-dev; recuerda que si vas a desarrollar aplicaciones usando una librería que instalaste desde un paquete deb, necesitas instalar la parte necesaria para desarrollar aplicaciones con ella (tiene el mismo nombre que el paquete de la librería pero acabado en dev).

Saludos.

PD: Para localizar los paquetes que contienen un determinado archivo puedes utilizar esta página http://packages.ubuntu.com.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

buenas, he seguido tu consejo de bajarme libqt3-mt-dev, aunque me sonaba a que ya lo habia probado tambien.. y en efecto me da un error de compatibilidad con una libqt3-obdc-dev creo que era, ademas de muchas dependencias que no me resuelve.. pero bueno, al menos ya se con que me tengo que pelar para instalarla, muchas gracias!

+1
0
-1
Imagen de gabiel
+1
0
-1

Creo que tienes algún problema con los repositorios, no deberían faltar dependencias; y el problema de incompatibilidad es algo que se "marca" en los propios paquetes; tal vez tiengas un repositorio de terceros que contiene paquetes que interfieren con los de Ubuntu.

He probado en mi equipo y no hay problemas con las dependencias de libqt3-mt-dev, además me permite seleccionar libqt3c102-odbc sin que indique que existe incompatibilidad.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1