problemas con firestarter (SOLUCIONADO)

Imagen de guicho
0 puntos

Instale ubuntu 8.04 y al activar el firestarter me da el siguiente mensaje !no se pudo activar el cortafuegos" el dispositivo eth0 no esta preparado.

compruebe la configuración de su dispositivo de red y asegurese de que su conexión a internet este disponible.

 

Nota. cuando utilizaba ubuntu 7.10 no tenía ningun problema. 

 

Este problema se presenta aunque este recien instalado ubuntu "limpio"

Imagen de Lexitius
+1
0
-1

 

Hola a todos los Ubunteros pues mi problemas es el mismo que a ti te pasa 

 "el dispositivo eth0 no esta preparado".

compruebe la configuración de su dispositivo de red y asegurese de que su conexión a internet este disponible.

 y pues ahora el problemas aumento ahora firestarter no me inicia se cuelga 

 

+1
0
-1

****“Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas”.****

Imagen de spamoutkk
+1
0
-1

Hola probar lo siguiente, esto me pasó a mí con la versión en español:

Cuando inicializa los valores de las interfaces , busca la máscara, pero busca por el valor Mas. El problema es que el ifconfig devuelve Más , con lo cual devuelve un valor en blanco.

Script de inicialización.

/ etc / init.d / firestarter

Valor original que busca:

INMASK = `/ sbin / ifconfig $ IF | grep Mas | cut-d: 4-f`

Solución :

INMASK = `/ sbin / ifconfig $ IF | grep Más | cut-d: 4-f`

 

 

+1
0
-1
Imagen de catmi777
+1
0
-1

Hola amigos; me eh actualizado a Ubuntu 8.04 y tengo el mismo problema con firestater y deseo aplicar la solución que comentas pero después de abrir el terminal y darle, me respode que la: orden no encontrada,o es que debbo hacerlo en otr lado. ¿Qué hago? Gracias.

+1
0
-1

Un saludo libre

Imagen de rperezbl
+1
0
-1

Gracias spamoutkk, por la pista.

A mi me ha pasado exactamente lo mismo, y he hecho los siguientes cambios en el fichero /etc/firestarter/firestarter.sh y me ha funcionado:

# He cambiado la clave
# MASK=`/sbin/ifconfig $IF | grep Mas | cut -d : -f 4`
# por la clave
MASK=`/sbin/ifconfig $IF | grep Más | cut -d : -f 4`

# También he cambiado la clave
# INMASK=`/sbin/ifconfig $INIF | grep Mas | cut -d : -f 4`
# por la clave
INMASK=`/sbin/ifconfig $INIF | grep Más | cut -d : -f 4`

Saludos.

+1
0
-1
Imagen de katodo
+1
0
-1

Gracias spamoutkk, gracias rperezbl he hecho lo que tu en las dos claves y ahora va perfecto.
Salud ** Katodo

Bueno, esto no lo entiendo. Edité el archivo con sudo gedit y lo guardé y funcionó. Despues de algun encender y apagar, horas más tarde, veo que el firestarter presenta el mismo problema y que el archivo no tiene el acento corregido. Compruebo de nuevo editando con sudo gedit y veo que el cambio no es permanente. ¿Alguien sabe la solución?
Gracias

+1
0
-1

Salud **Katodo

Imagen de JOERED
+1
0
-1

Yo tengo el mismo problema , lo edito y se vuelve a ir , a ver si alguien sabe la solución.

Gracias

 

 

:) Saludos a todos :)

Usuario Registrado Gnu/Linux # 404240

Usuario Registrado Ubuntu     #   17449

 

+1
0
-1

 

 

:) Saludos a todos :)

Usuario Registrado Gnu/Linux # 404240

Usuario Registrado Ubuntu     #   17449

 

Imagen de guicho
+1
0
-1

Por que mi caso es sorprendente le di en consola / etc / init.d / firestarter y me manda a lo siguiente (nada parecido a lo que recomiendan hacer):

#!/bin/sh
#
# Init file for the Firestarter firewall
#
# chkconfig: 2345 11 92
#
# description: Starts, stops, and lock the firewall
#
# Script Authors:
# Tomas Junnonen
# Paul Drain
#
# config: /etc/firestarter/configuration
#
### BEGIN INIT INFO
# Provides: firestarter
# Required-Start: $syslog
# Required-Stop: $syslog
# Should-Start: $local_fs $network
# Should-Stop: $local_fs $network
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start firewall
# Description: Run firestarter-configured firewall script.
### END INIT INFO

. /lib/lsb/init-functions

FS_CONTROL="/etc/firestarter/firestarter.sh"

[ -x /usr/sbin/firestarter ] || exit 0
[ -x $FS_CONTROL ] || exit 0
[ -s /etc/firestarter/configuration ] || exit 0

RETVAL=0

start() {
log_begin_msg "Starting the Firestarter firewall..."
$FS_CONTROL start > /dev/null
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
log_end_msg 0
else
log_end_msg 1
fi
return $RETVAL
}

stop() {
log_begin_msg "Stopping the Firestarter firewall..."
$FS_CONTROL stop > /dev/null
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
log_end_msg 0
else
log_end_msg 1
fi
return $RETVAL
}

lock() {
log_begin_msg "Locking the Firestarter firewall..."
$FS_CONTROL lock > /dev/null
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
log_end_msg 0
else
log_end_msg 1
fi
return $RETVAL
}

# See how we were called.
case "$1" in
start)
start
RETVAL=$?
;;
stop)
stop
RETVAL=$?
;;
restart)
stop
start
RETVAL=$?
;;
force-reload)
stop
start
RETVAL=$?
;;
lock)
lock
RETVAL=$?
;;
status)
if [ -e /var/lock/subsys/firestarter -o -e /var/lock/firestarter ]; then
log_warning_msg "Firestarter is running..."
else
log_warning_msg "Firestarter is stopped"
fi
RETVAL=$?
;;
*)
log_success_msg "Usage: firestarter {start|stop|restart|force-reload|lock|status}"
exit 1
esac
exit $RETVAL

................................................
Si alguien me pudiera decir que parte omite en este proceso se los agradecere (ya que no encontre en ningun lugar INMASK = `/ sbin / ifconfig $ IF | grep Mas | cut-d: 4-f`

).

+1
0
-1
Imagen de katodo
+1
0
-1

Mira a ver con
sudo gedit /etc/firestarter/firestarter.sh
Aunque a mi los cambios que realizo no quedan permanentes.
Ya contaras

Salud **Katodo

+1
0
-1

Salud **Katodo

Imagen de guicho
+1
0
-1

Solo con tu recomendacion rperezbl pude encontrar donde realizar la correccion y te comento que ya lo logre, firestarter ya esta activado, muchas gracias

+1
0
-1
Imagen de neno
+1
0
-1

sigue el problema.
Al principio el error era "el dispositivo eth0 no esta preparado". Que después de editar el script, ya no da ese error, ahora es:
"el dispositivo eth1 no esta preparado". El dispositivo eth1 es la tarjeta inalámbrica, que es con la que quiero hacer una conexion ad-hoc a otro portátil. Any idea?

+1
0
-1
Imagen de polonanni
+1
0
-1

Q TAL UBUNTU"S MIREN CUANDO FIRESTARTER LE ARROJE EL MENSAJE DE ETH0 NO ESTA PREPARADO, LO UNICO QUE TIENEN QUE HACER ES ABRIR LA INTERFACE DEL PROGRAMA (FIRESTARTER) Y DONDE DICE RED CHECAR EN QUE DISPOSITIVO HAY ACTIVIDAD UNA VEZ IDENTIFICADO VAMOS A IR A LAS PREFERENCIAS DEL PROGRAMA, LES ABRIRA UNA VENTANA Y DAN CLIN EN CONFIGURACIONES DE RED AHORA SOLO TIENEN QUE ELEGIR EL DISPOSITIVO DE RED EN LAS DOS OPCIONES QUE APARENCEN Y LISTO... COMENTEN SI LE SIRVIO HASTA PRONTO

+1
0
-1

ATT. POLOX