Como asociar tarjeta USB a wlan0?

Antes de nada pido disculpas por si no me explico bien o uso una nomenclatura incorrecta; soy newbie nivel 0 ;)

Estoy intentando montar mi conexion wireless Telefónica (la que viene con el pack Imagenio) en Ubuntu.
Hasta el momento he leído bastante sobre configurar y levantar la red, me conozco al dedillo el /etc/network/interfaces y todo lo relativo, asi que por eso no creo que haya problema.

El problema reside en lo fundamental, Ubuntu reconoce el dispositivo USB (WL-682 802.11g, de SparkLAN)pero no lo hace como un dispositivo de red y, por tanto, no lo asocia a un wlan (o lo que sea) como si hace con mi tarjeta ethernet, que asocia automaticamente a eth0.

Pensé que el problema radicaba en que necesitaba algun tipo de "drivers" y, como no existen drivers linux para esta maldita tarjeta, utilizé ndiswrapper para intentar cargar los de Windows (prismaxp.inf, prismaxp.sys, prismgxp.sys). Resultado: invalid drivers segun el ndiswrapper; no such device segun el ifup.

Si he comprendido bien la filosofia de este SO, el problema es que, a pesar de que Ubuntu sabe que hay ahí un dispositivo USB con el que se puede comunicar, no sabe que eso es una tarjeta de red y, por tanto no lo asocia a wlan0. Como se asocia un dispositivo a wlan0? Creo que esa es la pregunta que debo formular.

He buscado durante dias en decenas de foros y en los pocos casos en que se habla de esta tarjeta u otra similar el hilo concluye sin que nadie encuentre solución.

Agradezco cualquier pista!

Imagen de Anónimo
+1
0
-1

yo tengo el mismo problema y ya estoy cansado de buscar una solucion, si alguein la sabe... pues estoy dispuesto a escuchar las sugerencias
Gracias

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo tambien tengo el mismo problema con este adaptador wireless.
¿Alguien ha encontrado alguna solución?

+1
0
-1
Imagen de mala
+1
0
-1

Hay un scrip llamado AUTOMATIX que te instala un montón de utilidades, desde codecs de video al skype, pasando por un programa que se llama Windows Wireless drivers, con este programa puedes cargar los drivers de windows para tu usb y a su vez configurar tu red. Yo antes tenía el suse 10 y no era capaz de hacer andar el usb wireless, sin embargo con el ubuntu y esa aplicación mi usb ha funcionado desde el primer día

+1
0
-1
Imagen de gabiel
+1
0
-1

EL "programa" para usar controladores de Windows para los adaptadores wifi es ndiswrapper, que se incluye de serie con Ubuntu. Tal vez lo que instale Automatix sea un frontend gráfico (¿ndisgtk?), pero si no le funciona ndiswrapper "a pelo" tampoco lo hará mediante un frontend.

Saludos.

--------
Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Para ver algo más interesante, haz clic aquí.
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Con la tarjeta WL-682 que an mencionado mas arriba, tengo el mismo problema, uso el diswrapper para instar los drivers, me dice k muy bien pero de wlan0 nada de nada; alguien a conseguido ponerlo?

+1
0
-1
Imagen de gabiel
+1
0
-1

Asegurate de usar uno de los controladores ya probados. También asegurate de cargar el módulo ndiswrapper.

Saludos.

--------
Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Para ver algo más interesante, haz clic aquí.
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

linux:/home/pablo # dmesg | grep ndis
ndiswrapper: module not supported by Novell, setting U taint flag.
ndiswrapper version 1.2 loaded (preempt=no,smp=no)
ndiswrapper: driver prisma02 (SparkLAN,11/15/2004, 1.00.8.0) loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: d9324fcb
ndiswrapper (ndiswrapper_add_usb_device:363): Windows driver couldn't initialize the device (C0010006)
ndiswrapper: probe of 1-2:1.0 failed with error -22
usbcore: registered new driver ndiswrapper

+1
0
-1
Imagen de Anónimo
+1
0
-1

linux:/home/pablo # dmesg | grep ndis
ndiswrapper: module not supported by Novell, setting U taint flag.
ndiswrapper version 1.2 loaded (preempt=no,smp=no)
ndiswrapper: driver prisma02 (SparkLAN,11/15/2004, 1.00.8.0) loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: d9324fcb
ndiswrapper (ndiswrapper_add_usb_device:363): Windows driver couldn't initialize the device (C0010006)
ndiswrapper: probe of 1-2:1.0 failed with error -22
usbcore: registered new driver ndiswrapper

+1
0
-1
Imagen de gabiel
+1
0
-1

Como bien comentas, el problema viene porque no tienes el driver correspondiente instalado, una vez que lo instales aparecerá el dispositivo automáticamente (wlan0 o el que corresponda).

El controlador de Windows que intentas usar supongo que será el correspondiente a Windows XP o al 2000 (no funcionan los de 9x o Me). Si es así, tendrás que buscar otro controlador de Windows para la misma tarjeta (a veces no funcionan los que vienen con la tarjeta en concreto, pero sí lo hacen otros para tarjetas que usan el mismo chip), en esta página (perteneciente al proyecto ndiswrapper) puedes buscar enlaces a controladores ya probados.

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

He probado casi todos los de esa página y no me va ninguno. Ademas con cualquiera de ellos no detecta el hardware!!! Con el prisma02.inf que se instala en windows para la usb de telefonica, si detecta el hardware pero nanai de la china de detectarlo como dispositivo de red. Por tanto haciendo iwconfig no aparece wlan0 (para todos pone no wireless extensions)
Saludos

+1
0
-1
Imagen de gabiel
+1
0
-1

Hombre, la intención no era que probases todos los de la página, tan solo con el que correspondiese a tu modelo (evidentemente el con el resto te va a decir que no se encuentra la tarjeta correspondiente).

¿Cargas el módulo de ndiswrapper después de instalar el controlador de Windows? Si es así mira justo después de cargarlo los mensajes que aparezcan mediante dmesg, también dale un vistazo al registro del sistema en /var/log/messages

Saludos.

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

Buenas!! no siempre cuando instalas el driver te levanta wlan0 como dicen por auquí lo se xq con el usb wifi q tengo yo de jazztel me pasa
para levantarlo simplemente escribe en consola

sudo ifconfig wlan0 up

y ya puedes configurarla normalmente
UN SALUDO-->chaco

+1
0
-1
Imagen de gabiel
+1
0
-1

Pero el problema que tiene no es que no se levante la interfaz, sino que no aparece el dispositivo correspondiente; con lo cual no es posible levantar la interfaz.

Saludos.

PD: De hecho, nunca se levanta el interfaz al cargar el módulo; se levanta cuando lo configuras, por ejemplo mediante ifconfig wlan0 "ip". Para que se levante automáticamente al iniciar el sistema tienes que crear la configuración correspondiente en /etc/network/interfaces, tras eso no solo se levantará automáticamente (si lo especifícas), sino que con un siple sudo ifup "interfaz" se levantará en cualquier momento con la configuración asociada y con ifdown la desactivarás en cualquier momento (por supuesto también podrás hacerlo desde el asistente correspondiente).

--------

Para ver mi firma rasca aquí ===> ||||||||||||||||||||||||||||||||
Jabber ID: gabiel@jabber.org

+1
0
-1
Imagen de Anónimo
+1
0
-1

finalmente al leer tu articulo entendi porque no se conecta la cosa del wlan0, mi tarjeta es una trendnet TEW-444ub/a 802.11g, tengo una computadora Bion Duo y tengo instalado kubuntu, lo peor de todo es que no trae puerto para instalar la tarjeta PCMCI, entonces opte por la version USB del wireless... pero nada, yo se que lo que voy a escribir no es correcto desde el punto de vista de alguien que use linux... pero lo unico que se me ocurrio fue instalar Windows Xp en una particion y kubuntu en otra particion. porfavor... si alquien sabe como instalar esa tarjeta haganoslo saber, gracias!!!!

+1
0
-1
Imagen de Anónimo
+1
0
-1

encontre el problema, tengo una tarjeta trendnet tbw-103ub utilice los drivers que venian con la misma, y el ndiswrapper
primero ndiswrapper -i zd1211u.inf
luego ndiswrapper -l

roberto@kubuntu:/etc/network$ ndiswrapper -l
Installed ndis drivers:
zd1211u driver present, hardware present

luego ifconfig... ninguna wlan0, ok
ifconfig -a
si aparece la wlan0 entonces
ifconfig wlan0 up
y listo, luego
iwconfig wlan0 essid "nombre de la red".

espero que les sirva de algo.
saludos!!!

+1
0
-1
Imagen de mnuls
+1
0
-1

En mi caso, los drivers de Windows para el adaptador inalámbrico USB WL-682 802.11g de SparkLAN se cargan correctamente usando el prisma02.inf que viene en el Monitor de Red Inalámbrica que instala Telefónica.

Cuando hago un "ndiswrapper -l" me muestra que están correctamente instalados y que el hardware está presente.

El problema llega cuando intento ejecutar "modprobe ndiswrapper" para cargar el modulo en el kernel. El ordenador se queda colgado y no reacciona el ratón ni nada, sólo puedo resetear.

¿Alguien sabe a qué se debe o cómo se soluciona?

Gracias.

+1
0
-1
Imagen de mnuls
+1
0
-1

En mi caso, los drivers de Windows para el adaptador inalámbrico USB WL-682 802.11g de SparkLAN se cargan correctamente usando el prisma02.inf que viene en el Monitor de Red Inalámbrica que instala Telefónica.

Cuando hago un "ndiswrapper -l" me muestra que están correctamente instalados y que el hardware está presente.

El problema llega cuando intento ejecutar "modprobe ndiswrapper" para cargar el modulo en el kernel. El ordenador se queda colgado y no reacciona el ratón ni nada, sólo puedo resetear.

¿Alguien sabe a qué se debe o cómo se soluciona?

Gracias.

+1
0
-1
Imagen de gabiel
+1
0
-1

Prueba con otros controladores. En la página de ndiswrapper puedes encontrar una lista con controladores probados.

Saludos.

PD: ¿Esa tarjeta no tiene controlador nativo?

♠ ♣ ♥ ♦
Este comentario puede contener trazas de cacahuetes, almendras y germen de trigo.
[Documentación oficial][Normas del foro]

+1
0
-1
Imagen de mnuls
+1
0
-1

Hola.

Por desgracia no existen controladores nativos, al menos que yo sepa. En la página oficial de SparkLAN se pueden descargar los drivers para el adaptador, pero sólo hay para windows.

En cuanto a la lista de controladores de la página de ndiswrapper, no parece que haya ninguno que me sirva. He probado los que se supone que usan el mismo chipset y ni si quiera llegan a detectar la presencia del hardware (con ndiswrapper -l).

En fin, quizas pruebe a llamar a los de Imagenio para que me cambien el adaptador, a ver si distribuyen otro modelo con drivers nativos para linux o que funcionen con ndiswrapper.

De todas formas gracias por contestar.

Un saludo.

+1
0
-1