Problema con Gnome-Art en Hardy

Imagen de edugl
0 puntos

Hola, he instalado una hardy limpia y me va de maravilla, pero he instalado el programa gnome-art para decorarlo y no se abre, copio y pego el mensaje de consola:

 edugl@edugl-desktop:~$ gnome-art
/usr/lib/ruby/1.8/net/protocol.rb:133:in `sysread': Conexión reiniciada por el par (Errno::ECONNRESET)
    from /usr/lib/ruby/1.8/net/protocol.rb:133:in `rbuf_fill'
    from /usr/lib/ruby/1.8/timeout.rb:56:in `timeout'
    from /usr/lib/ruby/1.8/timeout.rb:76:in `timeout'
    from /usr/lib/ruby/1.8/net/protocol.rb:132:in `rbuf_fill'
    from /usr/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
    from /usr/lib/ruby/1.8/net/protocol.rb:126:in `readline'
    from /usr/lib/ruby/1.8/net/http.rb:2020:in `read_status_line'
    from /usr/lib/ruby/1.8/net/http.rb:2009:in `read_new'
     ... 10 levels...
    from /usr/lib/ruby/1.8/open-uri.rb:30:in `open'
    from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:156:in `isConnected'
    from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:132:in `main'
    from /usr/bin/gnome-art:25
edugl@edugl-desktop:~$

no se llega a abrir nunca. Un saludo y gracias!

 

Imagen de dajuliani
+1
0
-1

Tengo exactamente el mismo problema que vos.

Aparentemente, intenta conectarse con algo, y como no lo logra, se cierra. Pero, no estoy seguro que sea eso.

+1
0
-1
Imagen de edugl
+1
0
-1

y quizas no es problema del server de gnome-art????

+1
0
-1
Imagen de methodmann
+1
0
-1

/usr/lib/ruby/1.8/net/protocol.rb:133:in `sysread': Conexión reiniciada por el par (Errno::ECONNRESET)
    from /usr/lib/ruby/1.8/net/protocol.rb:133:in `rbuf_fill'
    from /usr/lib/ruby/1.8/timeout.rb:56:in `timeout'
    from /usr/lib/ruby/1.8/timeout.rb:76:in `timeout'
    from /usr/lib/ruby/1.8/net/protocol.rb:132:in `rbuf_fill'
    from /usr/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
    from /usr/lib/ruby/1.8/net/protocol.rb:126:in `readline'
    from /usr/lib/ruby/1.8/net/http.rb:2020:in `read_status_line'
    from /usr/lib/ruby/1.8/net/http.rb:2009:in `read_new'
     ... 21 levels...
    from /usr/local/lib/site_ruby/1.8/gnome-art/gnome_art.rb:132:in `call'
    from /usr/local/lib/site_ruby/1.8/gnome-art/gnome_art.rb:132:in `main'
    from /usr/local/lib/site_ruby/1.8/gnome-art/gnome_art.rb:132:in `main'
    from /usr/bin/gnome-art:25

 

Por favor a ver si alguien sabe como solucionar esto que estoy bastante interesado en el gnome-art

 

Saludos

+1
0
-1
Imagen de kainxp
+1
0
-1

A mi me pasa lo mismo, me lanza ese error desde el terminal

 

 

La cosa es que hace 4 dias los instale y funcionó, pero a los 2 dias dejo de funcionar, hoy lo he vuelto a instalar y me sigue pasando lo mismo, cuando intenta arrancar crashea , y si lo lanzas desde terminal sale ese error de ruby

 

 

Sinceramente soy muy novato en linux y esto no se por donde cojerlo.

 

Algun iluminado?

+1
0
-1
Imagen de amporio
+1
0
-1

buenasss

para hardy es

Gnome-Art NextGen

La instalación consiste en descargar el paquete comprimido GnomeArtNG-version.tar.gz, descomprimirlo en el disco duro, acceder al directorio y ejecutar el archivo runGnomeArtNG.sh

pagina

http://developer.berlios.de/projects/gnomeartng/

o

paquete deb

http://prdownload.berlios.de/gnomeartng/gnomeartng-0.5.0-all.deb

saludos!

+1
0
-1

obiguan kenovi

Imagen de kainxp
+1
0
-1

despues de leer tu respuesta, me puse a desinstalar el gnome-art que tenia por el que has puesto en los links

 

para facilitar la instalacion , etc, lo he hecho con el paquete .deb

 

la instalacion fue satisfactoria, pero al arrancar el programa, sale un cuadro de dialogo donde aparecen unas barras abajo como descargandose algo, derrepente se cierra, aparece una ventana de error y se cierra completamente el programa

 

me gustaria poder leer ese cuadro donde aparece el error , pero el crasheo es tan rapido q no te deja hacer nada

 

que debo estar haciendo mal?

 

 

gracias

+1
0
-1
Imagen de kainxp
+1
0
-1

tomaya, consegui hacerle un pantallazo pero no se como subirlo aqui.

 pero si puedo escribiros que pone en el cuadro de dialogo del error

 

 Warning: Could not download xml file!

 download of file http://art.gnome.org/xml.php?art=10 failed:

 Error getting response stream (ReadDone1): ReceiveFailure

 

ab quien puede exa una manita xD

gracias de antemano!!!!

+1
0
-1
Imagen de amporio
+1
0
-1

Imagen de edugl
+1
0
-1

He desinstalado el gnome-art y luego instalar el paquete deb del NG y me da error...

 

edugl@edugl-desktop:~$ gnomeartng
dtUbuntu

(GnomeArtNg:8502): Gtk-CRITICAL **: gtk_window_resize: assertion `width > 0' failed

** (GnomeArtNg:8502): WARNING **: Invalid borders specified for theme pixmap:
        /home/edugl/.themes/leopard/gtk-2.0/Frame-Gap/frame1.png,
borders don't fit within the image

Unhandled Exception: System.IO.FileNotFoundException: Could not find file "/home/edugl/.gnome2/gnome-art-ng/gnomeArt10.xml".
File name: '/home/edugl/.gnome2/gnome-art-ng/gnomeArt10.xml'
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000]
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000]
  at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
  at System.Xml.XmlUrlResolver.GetEntity (System.Uri absoluteUri, System.String role, System.Type ofObjectToReturn) [0x00000]
  at Mono.Xml2.XmlTextReader.GetStreamFromUrl (System.String url, System.String& absoluteUriString) [0x00000]
  at Mono.Xml2.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
  at System.Xml.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
  at System.Xml.XmlDocument.Load (System.String filename) [0x00000]
  at GnomeArtNG.CArtManager.parseXMLFile () [0x00000]
  at GnomeArtNG.CArtManager.getParseAndCreate (Boolean ForceReload) [0x00000]
  at GnomeArtNG.CArtManager.set_ArtType (ArtType value) [0x00000]
  at GnomeArtNgApp.OnSwitchPage (System.Object sender, Gtk.SwitchPageArgs s) [0x00000]
  at GnomeArtNgApp..ctor (System.String[] args) [0x00000]
  at GnomeArtNgApp.Main (System.String[] args) [0x00000]
edugl@edugl-desktop:~$
 

Un saludo y gracias!

Edugl

+1
0
-1
Imagen de rdbollani
+1
0
-1

comparto el mismo problema con el gnome-art, lo que me resulta curioso es que hace algunos dias atras funcionaba, pero luego reinstale el hardy heron y ahora no corre mas el gnome art.

Alguien que aporte una solucion!!!

Gracias

+1
0
-1
Imagen de skorpionn
+1
0
-1

Hola el problema lo solucione de la siguiete forma fui a http://art.gnome.org/xml.php?art=10 y descarge la pagina con el nombre gnomeArt10.xml y la guarde en /home/tu usuario/.gnome2/gnome-art-ng, luego arranque gnomeartng y funciono perfectamente.

Y listo Saludos

+1
0
-1
Imagen de geekko
+1
0
-1

Es problema del server de gnome-art segun he leido en los foros de gnome-art-nextgen. Es cuestion de esperar a que lo solucionen. Hasta que no lo solucionen en gnome-art, gnome-art-nextgen esta en las mismas ya que tira de ese server (o algo asi crei entender). Ademas, el responsable de gnome-art-nextgen se iba de vacaciones dos semanas y como no lo solucionaran a tiempo iba a tener dificil estar disponible el arreglo en este tiempo para gnome-art-nextgen.

Todo esto es lo que entendi de lo que lei por aquellos foros. Espero haberos aclarado las dudas.

+1
0
-1
Imagen de pasheco
+1
0
-1

Bueno pues eso yo tambien tengo problemas. He instalado el paquete .deb aparentemente sin problemas pero se abre y casi al instante se cierra. No me da tiempo a ver nada. Tengo Hardy para amd64.

Esto es lo que me sale al ejecutar en consola:

pasheco@pasheco-desktop:~$ gnomeartng
dtUbuntu

(GnomeArtNg:7547): Gtk-CRITICAL **: gtk_window_resize: assertion `width > 0' failed

Unhandled Exception: System.IO.FileNotFoundException: Could not find file "/home/pasheco/.gnome2/gnome-art-ng/gnomeArt10.xml".
File name: '/home/pasheco/.gnome2/gnome-art-ng/gnomeArt10.xml'
at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000]
at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000]
at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
at System.Xml.XmlUrlResolver.GetEntity (System.Uri absoluteUri, System.String role, System.Type ofObjectToReturn) [0x00000]
at Mono.Xml2.XmlTextReader.GetStreamFromUrl (System.String url, System.String& absoluteUriString) [0x00000]
at Mono.Xml2.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
at System.Xml.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
at System.Xml.XmlDocument.Load (System.String filename) [0x00000]
at GnomeArtNG.CArtManager.parseXMLFile () [0x00000]
at GnomeArtNG.CArtManager.getParseAndCreate (Boolean ForceReload) [0x00000]
at GnomeArtNG.CArtManager.set_ArtType (ArtType value) [0x00000]
at GnomeArtNgApp.OnSwitchPage (System.Object sender, Gtk.SwitchPageArgs s) [0x00000]
at GnomeArtNgApp..ctor (System.String[] args) [0x00000]
at GnomeArtNgApp.Main (System.String[] args) [0x00000]

Y esto si ejecuto gnome-art:

pasheco@pasheco-desktop:~$ gnome-art
Create program-folder
Create thumbnail-folder
Create temp-folder
Create download-folder
Create backgrounds-folder
Create splashscreens-folder
Create themes-folder
/usr/lib/ruby/1.8/net/protocol.rb:133:in `sysread': Conexión reiniciada por el par (Errno::ECONNRESET)
from /usr/lib/ruby/1.8/net/protocol.rb:133:in `rbuf_fill'
from /usr/lib/ruby/1.8/timeout.rb:56:in `timeout'
from /usr/lib/ruby/1.8/timeout.rb:76:in `timeout'
from /usr/lib/ruby/1.8/net/protocol.rb:132:in `rbuf_fill'
from /usr/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
from /usr/lib/ruby/1.8/net/protocol.rb:126:in `readline'
from /usr/lib/ruby/1.8/net/http.rb:2020:in `read_status_line'
from /usr/lib/ruby/1.8/net/http.rb:2009:in `read_new'
... 10 levels...
from /usr/lib/ruby/1.8/open-uri.rb:30:in `open'
from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:156:in `isConnected'
from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:132:in `main'
from /usr/bin/gnome-art:25
pasheco@pasheco-desktop:~$

+1
0
-1
Imagen de gotxa
+1
0
-1

Hola a todos,
un cambio en el servidor web de http://art.gnome.org hace que no se pueda descargar nada si no se especifica un User Agent, una identificación del navegador de quien "ve" el recurso (foto, página, fichero a descargar...). En este caso, gnomeartng no es un navegador pero le "pide" cosas al website igualmente.

Un usuario avanzado encontró y solucionó el problema en las fuentes mientras el que hizo el programa estaba de viaje, así que en breve seguramente habrá una versión nueva ya funcional. Todo el rollo aquí:
http://developer.berlios.de/bugs/?func=detailbug&bug_id=13780&group_id=9184
(no es prensa libre-amarillista, sólo recalcar lo interesante del software libre para con el usuario final)

Como lo hemos instalado a golpe de .deb y no repositorios, habrá que instalar la nueva versión que no vendrá automáticamente.
http://gnomeartng.berlios.de/

Por un pingüino paciente
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de zenitraM
+1
0
-1

La versión del CVS tira bien, solo hay que hacer:

sudo aptitude install mono-gmcs subversion
svn checkout svn://svn.berlios.de/gnomeartng/trunk
cd trunk
./compile

y para ejecutarla
mono GnomeArtNg.exe

+1
0
-1
Imagen de albokillers
+1
0
-1

hola acabo de instalar la vercion 0.5.1 de gnome-art next gen y no me ha dado ningun problema lo mas probable es que tengas la vercion 0.5.0 y no la ultima

saludos

+1
0
-1
Imagen de gotxa
+1
0
-1

la nueva versión 0.5.1 va bien
GoTXa
linux counter #116453

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de dajuliani
+1
0
-1

Tal como dices, con la versión que salió hace unos días se solucionan todos los problemas.

+1
0
-1