MI Modem PCtel HSP no lo puedo instalar

Imagen de duvotov
0 puntos

Ps soy nuevo en esto y ps tengo el Ubuntu 8.04(hardy)
con nucleo Linux 2.6.24-16-generic

pero el problema es que no tengo el driver adecuado para mi modem PCtel HSP y si lo encuentro no me sirve para el núcleo de linux, y ps no se que hacer por que la verdad me parece que este ubuntu esta muy bueno, en fin me gustaría que me ayudaran ya que necesito para conectarme cuando no estoy en casa.

y fuera de eso no se como conectarme cuando ya este instalado

por favor mi modem es PCtel HSP no lo olviden y mi nucleo Linux 2.6.24-16-generic y gracias por la ayuda y la atención prestada

Imagen de soygecko
+1
0
-1

Solo vas a encontrar un driver que es para redhat...pero funciona y una vez instalado el drive lo único que tendrías que hacer es ir en la interface gráfica a red y habilitar una nueva interface...creo que te va a aparecer para habilitar el modem. suerte con eso y seguí intentando que no es nada del otro mundo

Soy de Salta y hago Falta, soy 6e(k0

+1
0
-1

Soy de Salta y hago Falta, soy 6e(k0

Imagen de lauchacba
+1
0
-1

hola, instala desde el cd el paquete
sl-modem-daemon

o buscas por nombre: sl modem daemon en synaptic.

una ves instalado, abris una terminal y ejecutas:

sudo wvdialconf

tenes que ver algo así al final del listado (similar):

ttySL0<*1>: Speed 460800: AT -- OK
ttySL0<*1>: Max speed is 460800; that should be safe.
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySL0.
Modem configuration written to /etc/wvdial.conf.
ttySL0: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

el modem fue detectado..... en /dev/ttySL0

ahora editas un archivo como usuario root:

Sudo gedit /etc/wvdial.conf

el contenido dejalo similar a esto:

[Dialer Defaults]
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Phone = numero-de-telefono
Modem = /dev/ttySL0
Username = nombre-de-usuario
Carrier Check = off
Password = clave-de-usuario
Baud = 460800

comentario:
cuando provee el pctel, me dio error la segunda ves, dado que no encuentra el modem despues...

en una terminal ejecutas:

sudo pppconfig

y seguis los pasos, esto seria como indicarle al sistema de forma precisa donde buscar la proxima ves o algo así.:

DNS o servidores dejalo en dinamicas ... lo demás es intuitivo.

saludos.

editado:
a pesar de usar el pppconfig la idea es conectarse y desconectarse usando los comandos

sudo wvdial y sudo killall wvdial

______________________________________________________________

ubuntu sin internet? secc=act.sources.list.sin.int.en.mi.web

http://ar.geocities.com/novatocba

por que en algunos lugares el modem es un lujo.

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de duvotov
+1
0
-1

pues no me detecta ningún modem y el problema es que esta conectado, intente desconectarlo y volver a conectarlo pero nada y ps me gustaría conectarme a Internet desde allí, por favor ayúdenme

+1
0
-1
Imagen de lauchacba
+1
0
-1

pero tenes modem interno pci o externo? conta algo más.

editad: en una terminal haces
lspci
copia y pega lo que te salga.

______________________________________________________________

ubuntu sin internet? secc=act.sources.list.sin.int.en.mi.web

http://ar.geocities.com/novatocba

por que en algunos lugares el modem es un lujo.

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de duvotov
+1
0
-1

00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge

00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge

00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 80)

00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)

00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)

00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)

01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01)

y cuando le doy wvdialer me abre un archivo y me sale esto pero igual no se conecta, y si me voy a la ventana RED y selecciono el modem se queda procesando y me lo deselecciona que hago?

[Dialer Defaults]
Phone =
Username =
Password =
New PPPD = y

y cuando voy a instalar algún programa o abro un instalador me sale el sigiente error pero le cambia de los dos puntos hacia la derecha es decir siempre me sale.

Error: Dependency is not satiafiable:

esto es lo unico que varia

libc6 |libc-dev

+1
0
-1
Imagen de lauchacba
+1
0
-1

el modem que tenes es el mismo ue tengo yo...

desde synaptic instalas primero:

build-essential

ese paquete entre tantos para compilar te instala eso que te dice que falta.

una ves instalado build-ssential, buscas en la lista el paquete sl-modem-daemon

cuando lo encuentre hacele clic derecho> eliminar completamente

una ves eliminado, lo volves a buscar y marcas para instalar de nuevo.

una ves instalado cerras Synaptic.. vas a aplicaciones>accesorios>terminal...

ejecutas:

sudo wvdialconf

si te dice que no encontro modem alguno.. reinicias la computadora.. y una ves reiniciada volves a ejecutar. (lo que ves mas o menos ya te lo comente arriba)

si da que encontro el modem editas el archivo que te dice ahi:

Sudo gedit /etc/wvdial.conf

por ejemplo: si el proveedor fuera (es para no hacer propaganda) gnome y la propaganda fuera:

conectate al 456789123 usuario ubuntu contraseña ubuntu el archivo quedaria algo así:

[Dialer Defaults]
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Phone = 456789123
Modem = /dev/ttySL0
Username = ubuntu
Carrier Check = off
Password = ubuntu
Baud = 460800

al archivo que te da originalmente le quitas los comentarios ; y agregas las lineas faltantes (por ejemplo auto dns = on )

ahora, como da la casualidad que tenes el mismo modem que yo, segun tu lspci, en la primera ves te podes conectar o no, y al intentarlo te va a dar error.

por que?

aparte del asunto de que VIA tiene cerrado los codigos fuentes y que el pctel goza de una fama que lo califica de una reverenda m***.... es por que como quien dice, el sistema pierde la ubicación del modem.

para evitar esto ejecutas en una terminal...

sudo pppconfig

lo que te pregunta en cierto orden es lo siguiente:

1- elejimos crear nueva conexión.
2- el nombre lo dejamos por default en provider, pasamos a lo siguiente.
3- elejimos Dynapic : usar DNS dinamicos
4- dejamo el asunto en PAP
5- escribimos nuestro nombre de usuario a utilizar
6- escribimos el password
7- dejamos el valor en 460800, que es el que nos dio el reconocimiento.
8- elejimos tono
9- escribimos el numero de telefono
10- intentamos ubicar el winmodem de forma automatica (pregunta..responder si o no..)

11- si no pasa nada nos manda a manual
12- indicamos el /dev que nos dio wvdialconf, en mi caso es /dev/ttyS0
13- control de datos y elejimos "guarda los ficheros y vuelve al menu principal"
14- aceptamos y salimos.

El punto 12 es el que basicamente nos interesa... ya que en el le indicamos al sistema (o lo que sea) que el modem esta en tal lugar...

una ves terminado todo, en adelante solo usas sudo wvdial y sudo killall wvdial

Creditos a Gabrielmuñoz, ya que en uno de los tantos post, fue su respuesta la que ayudo..

acordate de que al ser acceso dial up, puede ser que tengas que intentar 2 o 3 veces la conexion.

saludos..

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de duvotov
+1
0
-1

se me olvidaba mencionar que no tengo ningún otro medio para conectarme a Internet, y cuando le doy para buscar build-essential no me sale nada pero cuando le doy agregar CD-ROm y meto el CD con el que instale ubuntu ahí si me sale y a la hora de seleccionarlo para instalar me sale:

Algunos de los paquetes no se han podido obtener del servidor/es.
¿Seguro que quiere continuar, ignorando esos paquetes?

y si le doy click en si o en no me sale el siguiente error

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/l/linux/linux-libc-dev_2.6.24-16.30_i386.deb
La suma MD5 difiere

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/g/glibc/libc6-dev_2.7-10ubuntu3_i386.deb
La suma MD5 difiere

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/g/gcc-4.2/libstdc++6-4.2-dev_4.2.3-2ubuntu7_i386.deb
La suma MD5 difiere

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/g/gcc-4.2/g++-4.2_4.2.3-2ubuntu7_i386.deb
La suma MD5 difiere

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/t/timedate/libtimedate-perl_1.1600-9_all.deb
La suma MD5 difiere

W: Falló al obtener cdrom:[Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423)]/pool/main/p/patch/patch_2.5.9-4_i386.deb
La suma MD5 difiere

y a la hora de ir directamente a CD e intentar instalar directamente haciendo doble clik me sale el error anterior, por favor ayúdenme no se que hacer

+1
0
-1
Imagen de lauchacba
+1
0
-1

arranca la pc desde el cd, y fijate en la tercera opcion: busqueda o chequeo del cd, en busca de errores, fijate que es lo que sale.

si te da error, date una vuelta por mi pagina sección: instalar desde internet off-line o espera que baje otra ves el cd, también tengo el cd mal grabado... si no te dejaba la lista de enlaces a los paquetes directamente.
hasta luego.

pd: no.. todavia no probe el 8.04 jeje.

editado:
estos son los paquetes de build-essential más el sl-modem-daemon

http://archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-libc-dev_2.6.24...
http://archive.ubuntu.com/ubuntu/pool/main/g/glibc/libc6-dev_2.7-10ubunt...
http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.2/libstdc++6-4.2-dev_...
http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.2/g++-4.2_4.2.3-2ubun...
http://archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/g++_4.2.3-1ubu...
http://archive.ubuntu.com/ubuntu/pool/main/t/timedate/libtimedate-perl_1...
http://archive.ubuntu.com/ubuntu/pool/main/p/patch/patch_2.5.9-4_i386.deb
http://archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.14.16.6ubun...
http://archive.ubuntu.com/ubuntu/pool/main/b/build-essential/build-essen...
http://archive.ubuntu.com/ubuntu/pool/restricted/s/sl-modem/sl-modem-dae...

total son 10 archivos...
el sl-modem-daemones por las dudas que tengas que desistelar y reinstalar de cero el sl-modem-daemon

hasta luego.

______________________________________________________________

ubuntu sin internet? secc=act.sources.list.sin.int.en.mi.web

http://ar.geocities.com/novatocba

por que en algunos lugares el modem es un lujo.

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de duvotov
+1
0
-1

gracias !Mi negro!

No sabes lo agradecido que estoy actualmente estoy navegando con mi modem, es mas este comentario es con ese modem, y ps de nuevo gracias y nos vemos.

+1
0
-1
Imagen de lauchacba
+1
0
-1

me alegro de que te sirviera, en mi página ya actualice la sección del módem pctel, le puse imágenes paso por paso, espero que les sirva... si es la misma explicación pero con imagenes..

saludos!!!
pd: enlace directo, lo que si no le baje tanto la calidad a las imagenes, tal ves lo haga en unos días.total:26 peso: 1.3 mb.

http://ar.geocities.com/novatocba/doc/frame/modem-pctel.htm

+1
0
-1

ubuntu sin internet-offline

http://novatocba.netii.net/

http://www.ubuntu-es.org/index.php?q=Preguntas_Frecuentes

de nuevo en linea... y con ubuntu..

Imagen de duvotov
+1
0
-1

Cuando inicio ubuntu el me carga normal pero cuando va a iniciar normalmente no inicia si no que me sale el siguiente mensaje en una pantalla negra como en DOS:

BusyBox v1.1.3(Debian 1:1.1.3-5ubuntu12) Built-in shell (ash)

enter 'help' for a list of built-in command

(initramf)_

Por favor ayúdenme ningún comando le sirve, que debo hacer, agradecería una pronta respuesta ya que en ninguna de las opciones que le doy al iniciar me sirve y por mas que le de y le de me sale esto y no me deja entrar normalmente

+1
0
-1