imposible hacer funcionar la ati mobility 2300? ayuda por favor (no solucionado)

Imagen de museoinformatico
0 puntos

tengo un portatil lg r200 con una tarjeta grafica ati mobility x2300. lo unico que quiero es que el 3d y compiz funcionen y ver los videos a tamaño completo sin saltos. ¿es esto posible? ¿que deberia de hacer? (paso a paso por favor pues repito que soy muy novato).

antes de nada quiero comentar que he seguido varios tutoriales en la web y aun no lo he conseguido. hubo un momento en que me funcionaba el 3d y el compiz pero al ver videos se veian como a saltos por lo que empece de nuevo a trastear y probar tutoriales y ahora ya no se que esta bien o que esta mal pues soy novato en linux.

lo ultimo que he pensado es que tras tantas pruebas quizas lo mejor seria reinstalar el driver de ati desde el principio. he seguido este tutorial: http://www.ubuntu-es.org/index.php?q=node/61826&page=1 para intentar instalar a mano el ultimo driver bajado de la web de ati, pero el problema sigue igual y no funciona, sigo sin 3d y por supuesto sin compiz y sin reproducir video. si en la consola ejecuto fglrxinfo me da un error de que no tengo la libreria libGL.so.1 . si hago un locate libGL.so.1 efectivamente no la tengo. ya no se que mas puedo hacer y probar. estoy desesperado.

por favor ayuda

Imagen de guman
+1
0
-1

si estas usando ubuntu v8, tendras demasiado trabajo,te recomiendo k uses alguna version anterior.....el dapper seria genial,pero yo te recmiendo festy o hasta gutsy!
suerte!

+1
0
-1

Como son las cosas, me encantaba Gnome....ahora lo odio!!!
Y como antes no me gustaba Xfce , no entiendo por que ahora lo adoro!!!

Imagen de Ardanbis
+1
0
-1

si en la consola ejecuto fglrxinfo me da un error de que no tengo la libreria libGL.so.1 

Sistema->Administración->Gestor de paquete Synaptic->buscar ati libgl y a lo mejor encuentras la solución.



Linux user #466973
Ubuntu user #20815
+1
0
-1
Imagen de museoinformatico
+1
0
-1

guman, creo que la version que uso es la ubuntu 8.04 (la ultima?).

Ardanbis, he buscado lo que me dices pero teoricamente ya esta todo instalado ok. pero el caso es que no va.

quizas este equivocado pero una posible solucion seria reinstalar todo el driver de ati compatible con mi x2300. ¿como puedo hacer esto? ¿es posible?

gracias. los problemas continuan

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Buenas, como buena usuaria de ubuntu y ati, he tenido que instalar/borrar/reinstalar/probar/estropear... (mejor paro que si no no acabo nunca :P).

La manera que mejor resultados me ha dado para desinstalar los drivers fglrx ha sido usando su propio desinstalador :D.

sudo bash /usr/share/ati/fglrx-uninstall.sh

Y luego, para volver a instalarlo, en hardy, me funcionó perfectamente con su propio instalador.
Descargas la última versión (cataclyst 8-4 creo) de su web. Le das permisos para ejecutar. Doble-click. Siguiente, siguiente.
Reinicias, y debería ir sin problema.

Prueba y nos cuentas a ver que tal te fue.

Saludos.

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

gracias wilmaforez, pero no puedo hacer lo que me dices por varios problemas:

no puedo desinstalar el driver porque cuando ejectudo lo que me dices me da un error, este:

pc@pclinux ~ $ sudo bash /usr/share/ati/fglrx-uninstall.sh
[sudo] password for paco:
bash: /usr/share/ati/fglrx-uninstall.sh: No existe el fichero ó directorio

no se porque ocurre esto. ¿alguna sugerencia? en caso de que me digas como hacerlo ¿debo de reiniciar despues del todo la maquina ¿puedo hacer todo esto desde el entorno grafico o hay que salir de el?.

ademas, he probado a bajar el driver que me comentas de la web de ati pero el fichero bajado es un .run al que si le doy doble click encima me abre el gedit con un error, es como si no lo reconociera como un ejecutable. alguna ayuda con respecto a esto.
recordar por favor que soy muy novato asi que no deis por sentado que se ejecutar algo si hay que dar alguna vuelta mas.

gracias de antemano por vuestro tiempo y ayuda.

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Si no lo puedes desinstalar es porque no lo instalaste como yo hice anteriormente. No hay problema.

Sigamos, antes de hacer doble click en el .run, debes darle permisos de ejecución. Para ello, click derecho, vas a la pestaña permisos y pon el tick donde pone: permitir ejecutar como si fuera un programa (o algo similar).
Ahora si ya puedes hacer doble click para instalarlo.

Prueba y contesta a ver que tal.

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

tras lo que me comentaste pude instalarlo. me dio la opcion de generar instalador para distro especifica a lo cual no hice caso. lo instale tal cual en modo automatico. la version del driver es el 8.476 recien bajado de la web.

tras la instalacion he reiniciado la maquina. ya tengo 3d, bueno, mas bien a medias. me explico.

el compiz funciona. si pongo un salvapantallas que use 3d como por ejemplo el de las hormiguitas en unas burbujas (antinspect) y le doy a preview funciona pero parecen caracoles que van a saltos es como una pelicula que se salta fotogramas.
del video, mejor no hablamos. pongo una pelicula a pantalla completa y funciona bien el sonido pero se ve a saltos.

no se si tiene que ver pero posteo lo que pone en device el fichero xorg.conf

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Boardname "vesa"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Busid "PCI:1:0:0"
EndSection

Section "Device"

#
Identifier "device1"
Driver "vesa"
Boardname "vesa"
Busid "PCI:1:0:0"
Screen 1
EndSection

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Postea el xorg.conf completo (pégalo aqui paste.ubuntu.com y copia el link).
Aparte de eso escribe en consola:
glxinfo |grep direct
(debería decir direct rendering: yes, puesto que has conseguido iniciar compiz)
Por ahora no se me ocurre más, aunque el xorg.conf solo debería tener una section "device". Quizá vayan por ahí los tiros.

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

lo que me mandas teclear y su salida:

pc@pclinux ~ $ glxinfo |grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

y el archivo xorg.conf completo que tengo es:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection

Section "Monitor"

#
Identifier "monitor1"
Gamma 1
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
BoardName "vesa"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Device"

#
Identifier "device1"
Driver "vesa"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x800@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection

+1
0
-1

Saludos a todos

Imagen de museoinformatico
+1
0
-1

lo que me mandas teclear y su salida:

pc@pclinux ~ $ glxinfo |grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

y el archivo xorg.conf completo que tengo es:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection

Section "Monitor"

#
Identifier "monitor1"
Gamma 1
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
BoardName "vesa"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Device"

#
Identifier "device1"
Driver "vesa"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x800@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

No tienes aceleración. Ese es el problema (no me explico como has conseguido iniciar compiz).
Eso significa que los drivers se instalaron mal.

Escribe en consola:
less /var/log/Xorg.0.log |grep EE
a ver que dice.

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

es curioso si, pero te aseguro que el compiz funciona y aparentemente bien con todos los efectos. todo lo demas (los salvapantallas 3d y la reproduccion de video) no funciona o funciona muy mal.

pc@pclinux ~ $ less /var/log/Xorg.0.log |grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 2
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 2
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 2
(EE) fglrx(0): === [swlDalHelperAddCustomizeMode] === CWDDEDI_DisplayGetSetModeTimingOverride failed: 2

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

De todas las veces que he tenído problemas con la aceleración, nunca me había salido ese error :O.

Así que bueno.. hagamoslo a la vieja usanza. Volver a desinstalar e instalarlo de nuevo, pero de otro modo :D. (sé por experiencia, que incluso haciendo lo mismo, hay veces que funciona y otras que no. es cuestión de insistir hasta que se canse :P).

Primero desinstalar:

sudo bash /usr/share/ati/fglrx-uninstall.sh

Y para instalar, si sabes algo de inglés, intenta seguir esta guía (así me evitas algo de trabajo :P): http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide#Method_...

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

he hecho lo que me comentaste. dio que desinstalo bien.
segui el tutorial paso a paso sin problema.

pero en la comprobacion final me da que tengo instalado el MESA no el ati.

ahora estoy peor que nunca:
1-el sistema me arranca en baja resolucion (ya no tengo 1280x800)
2-tengo 3d pero lentisimo (probado con salvapantallas)
3-no puedo activar el compiz
4-la reproduccion de video ni lo he probado

el contenido completo ahora del xorg.conf es:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "aticonfig-Screen[0]" 0 0
Inputdevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
Defaultdepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "0"
Option "Composite" "0"
EndSection

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Perdón por tardar en contestar.
Se me ocurre una cosa. Entra a sistema>administracion>gestor de controladores restringidos. y asegurate de que esté el tick en la linea de la grafica. Que yo me volví loca y resulta que no se me cargaba el modulo por eso.

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

esta marcado y en uso.

por cierto, ¿ne te parece que ahora el archivo xorg.conf esta mas raro que nunca? lo digo porque no figura por ningun lado la resolucion de pantalla y esas cosas. ¿sera por eso que estoy trabajando en baja resolucion?

gracias

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Si, pero por lo que tengo entendido, hardy hace un tratamiento diferente, y lo que no sale ahí, lo supone.
De todos modos, puedes poner el anterior (creo que automáticamente se guarda) o puedes copiar el mio si quieres :).
Una cosa, me he fijado en que tienes el teclado configurado en ing?es. En el mio sale en español pero solo tendrías que cambiar esta linea:
Option "XkbLayout" "es"
por esta:
Option "XkbLayout" "en"

http://paste.ubuntu.com/13264/

Por otro lado, se volvieron a instalar mal los drivers. :S. Vuelve a escribir esto:
less /var/log/Xorg.0.log |grep EE

y postea la salida.
Pd. Cuando el texto que vayas a pegar sea largo (el xorg.conf por ejemplo) usa la pagina paste.ubuntu.com, así no hay que rebuscar tanto

______________________________________________________

No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

no se porque me dices lo del teclado porque lo he probado y me escribe las ñ, acentos y todo lo demas. parece que funciona en español correctamente.

con respecto a lo que mandas hacer este es el resultado:
pc@pclinux ~ $ less /var/log/Xorg.0.log |grep EE
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Qué raro lo del teclado... bueno, da igual, mejor :P.
Respecto al comando no sale ningun error. Eso es bueno.. y malo, porque al no dar error no hay informacion :S.

A ver.. Escribe:
lsmod |grep fglrx
y:
dmesg |grep fglrx

El primero sirve para saber si está cargado el modulo del driver. El segundo son los mensajes del sistema.

Pero vamos... que no se me ocurre ninguna solucion mas que reinstalar :S (ya sé que es chapucero, pero a mi me suele dar resultado )

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

pc@pclinux ~ $ lsmod |grep fglrx
fglrx 1548940 0
agpgart 34760 2 fglrx,intel_agp

pc@pclinux ~ $ dmesg |grep fglrx
[ 32.293397] [fglrx] Maximum main memory to use for locked dma buffers: 1898 MBytes.
[ 32.293495] [fglrx] ASYNCIO init succeed!
[ 32.294617] [fglrx] PAT is enabled successfully!
[ 32.295766] [fglrx] module loaded - fglrx 8.47.3 [Mar 29 2008] on minor 0

con respecto a lo de reinstalar. tengo miedo de que el tutorial de instalacion manual que me pasaste no se aplique bien en mi caso y pregunto, ¿ha forma de que el propio sistema lo reinstale? (usando synaptic o asi)

por cierto, he usado tu xorg.conf (sin poner las seccion e de wacom ya que yo no tengo y nada, sigo en baja resolucion tras reiniciar. ya no se que mas probar

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Pues es raro tu caso. El módulo está bien cargado. No da errores. Pero aun así no funciona...

La sección wacom de mi xorg.conf estaba comentada, por tanto es como si no estuviera. Pero me parece bien que mires las cosas antes de hacerlas :).

Y como te da miedo hacerlo manual.. Pues, desinstala usando el comando de todas las veces anteriores :

sudo bash /usr/share/ati/fglrx-uninstall.sh

Y reinicia. Si te dice que no lo encuentra dime y te digo los pasos para hacerlo manualmente.
Una pregunta, ¿usaste envy-ng anteriormente? podrías probarlo, ese programa lo hace completamente automatizado. Yo no lo usé nunca, pero debe dar buenos resultados.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

sudo bash /usr/share/ati/fglrx-uninstall.sh

me dice fichero no existe.

¿como lo desintalo?

por cierto, despues de deinstalarlo si reinicio ¿podre entrar a modo grafico igual?

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Si deberías poder entrar, ya que debería saltar el driver libre. Aunque por si acaso nos aseguraremos de ello modificando el xorg.conf. Tienes que cambiar en la sección device:
Driver "fglrx"
por:
Driver "ati"

Hazlo y reinicia. Así nos aseguramos de que no esté en uso el privativo para poder desinstalarlo completamente. Mientras te voy escribiendo como desinstalarlo.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de wilmaforez
+1
0
-1

Para desinstalar:
sudo modprobe -r fglrx
sudo dpkg -r xorg-driver-fglrx
sudo dpkg -r fglrx-kernel-source
sudo dpkg -r fglrx-amdcccle
sudo rm -f /usr/src/fglrx-kernel-*.deb

Creo que no se me olvida ningun paso. Aunque quizá haya alguno de más, si te dice que no lo encuentra tranquilo, continua.

Para volver a instalarlo, esta vez lo haremos mediante envy-ng.
sudo apt-get install envyng-core envyng-gtk

Inicias el programa, y sigue los pasos. Es decir, escoges ati, luego instalar los ultimos drivers. y esperas. :)
A ver si así sale bien. Cruzaré los dedos :)

edito: me confundí en el nombre del paquete :S

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de wilmaforez
+1
0
-1

Edito, media hora sin querer enviarse y salió doble. :S

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

te pongo la salida por pantalla de cada comando y tu me diras si sigo con la instalacion o tengo que hacer algo mas antes.
por cierto para instalar ¿es necesario reiniciar o ya puedo despues de todo esto?

pc@pclinux ~ $ sudo modprobe -r fglrx
pc@pclinux ~ $ sudo dpkg -r xorg-driver-fglrx
dpkg: problemas de dependencias impiden la desinstalación de xorg-driver-fglrx:
fglrx-amdcccle depende de xorg-driver-fglrx.
dpkg: error al procesar xorg-driver-fglrx (--remove):
problemas de dependencias - no se desinstala
Se encontraron errores al procesar:
xorg-driver-fglrx
pc@pclinux ~ $ sudo dpkg -r fglrx-kernel-source
(Leyendo la base de datos ...
106397 ficheros y directorios instalados actualmente.)
Desinstalando fglrx-kernel-source ...
Removing all DKMS Modules

Error! There are no instances of module: fglrx
2:8.476 located in the DKMS tree.
Done.
pc@pclinux ~ $ sudo dpkg -r fglrx-amdcccle
(Leyendo la base de datos ...
106380 ficheros y directorios instalados actualmente.)
Desinstalando fglrx-amdcccle ...
pc@pclinux ~ $ sudo rm -f /usr/src/fglrx-kernel-*.deb
pc@pclinux ~ $

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Los puse en el orden equivocado.
Puse en primer lugar el que debe ser desinstalado el ultimo. Por tanto ahora tienes que volver a poner :
sudo dpkg -r xorg-driver-fglrx

Y no, no hace falta reiniciar, ya que no estaba en uso.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de wilmaforez
+1
0
-1

Probé envy para ver como lo instalaba. Resulta que instala los drivers 8-3. Por tanto seguramente tengas los mismos problemas que al principio. De todos modos, DEBERÍAS, tener aceleración grafica. Si no es así, algo se me está pasando por alto.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

pc@pclinux ~ $ sudo dpkg -r xorg-driver-fglrx
[sudo] password for paco:
(Leyendo la base de datos ...
106348 ficheros y directorios instalados actualmente.)
Desinstalando xorg-driver-fglrx ...
* Stopping atieventsd [ OK ]
rmdir: No se pudo eliminar `/usr/lib/fglrx': El directorio no está vacío
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
pc@pclinux ~ $

y, si instalo la version 8.3 ¿que problemas puedo tener?

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Los que describias, videos entrecortados. Un parpadeo negro con cualquier aplicación que requiera 3D si tienes compiz activado.
Aunque la verdad es que esos errores no se solucionan completamente en la versión 8-4. Sólo que son más estables.

Quizá podías probar con los drivers libres, creo que esos iban mejor. Y aunque dan menor rendimiento, lo compensan siendo más estables. Ahora deberías tenerlos activados.

Escribe:
glxinfo |grep direct
si dice : direct rendering: yes

Activa compiz y prueba a ver qeu te parece. Si no.. continuamos intentando cosas :).

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

paco@pacolinux ~ $ glxinfo |grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

sigo en baja resolucion, sin acceleracion etc

te dejo el xorg.conf
http://paste.ubuntu.com/13281/

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Es el que te pegué yo?. pues si que lo copié mal :S.

Bueno, lo primero, reconfigurar el xorg.conf
sudo dpkg-reconfigure -phigh xserver-xorg
y luego, tienes que cambiar un par de cosillas:
sudo gedit /etc/X11/xorg.conf
Section "Device" ## Lo tienes que dejar como está salvo por estas cosas: cambiar ati por fglrx, y añadir esas dos lineas
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Y luego, seguramente se haya cambiado el teclado a ingles (aunque quien sabe):
Busca donde diga:
Option "XkbLayout" "en"
y cambia el "en" por "es".

Luego reinicia.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de wilmaforez
+1
0
-1

Se me acaba de ocurrir cual podría ser el problema. Escribe:
sudo gedit /etc/default/linux-restricted-modules-common

Y quita fglrx, de modo que la linea quede así:
DISABLED_MODULES=""

Antes de que reinicies. Ya que estamos intentaremos instalar los drivers 8-4. Si no lo borraste deberías tenerlo por ahi. Doble click y escoge instalación automática.

Luego sí, reinicia.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

el DISABLED_MODULES="" ya estaba como me dices.
el driver anterior no puedo instalarlo porque como estoy en baja resolucion no puedo hacer click en los botones siguiente etc

siguiendo tus instrucciones el archivo xorg.conf:
http://paste.ubuntu.com/13286/

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Se fastidió mi idea.
Bueno, para instalarlos hay otro modo. Anteriormente generaste unos paquetes, que deberían estar en la misma carpeta que el .run.
(si no los tienes, abre la consola, navega hasta la carpeta y pon: sudo ./ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu/hardy)
Si haces click en ellos se van instalando igual, y la pantalla que sale es más pequeñaja.
Instalalos en este orden:
xorg-driver-fglrx_8.476-0ubuntu1_i386.deb
fglrx-kernel-source_8.476-0ubuntu1_i386.deb
fglrx-amdcccle_8.476-0ubuntu1_i386.deb
xorg-driver-fglrx-dev_8.476-0ubuntu1_i386.deb

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

al probar el primero de los paquetes me lo instala pero al final me da un error:
"Se produjo un fallo al instalar por completo todas las dependencias"

¿que hago?
;(

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Veamos, las dependencias que puedes necesitar son:

sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r) module-assistant

El último se supone que no se necesita, pero por si acaso. Instala esos, y vuelve a probar con el paso anterior.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

al probar el primero de los paquetes me lo instala pero al final me da un error:
"Se produjo un fallo al instalar por completo todas las dependencias"

¿que hago?
;(

+1
0
-1

Saludos a todos

Imagen de museoinformatico
+1
0
-1

pacolinux Desktop # sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r) module-assistant
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
build-essential ya está en su versión más reciente.
fakeroot ya está en su versión más reciente.
dh-make ya está en su versión más reciente.
debhelper ya está en su versión más reciente.
debconf ya está en su versión más reciente.
libstdc++5 ya está en su versión más reciente.
dkms ya está en su versión más reciente.
linux-headers-2.6.24-16-generic ya está en su versión más reciente.
module-assistant ya está en su versión más reciente.
Tal vez quiera ejecutar `apt-get -f install' para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
xorg-driver-fglrx-dev: Depende: xorg-driver-fglrx (= 1:7.1.0-8-3+2.6.24.12-16.34)
E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Puede ser que te hayas confundido de orden? Fijate que hay dos paquetes con nombres parecidos. Tienes que instalar primero xorg-driver-fglrx_8.476-0ubuntu1_i386.deb
el otro, ni siquiera es necesario, y como es el que te está dando problemas, directamente no lo instales.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

pacolinux Desktop # dpkg -i xorg-driver-fglrx_8.476-0ubuntu1_i386.deb
(Leyendo la base de datos ...
106450 ficheros y directorios instalados actualmente.)
Preparando para reemplazar xorg-driver-fglrx 2:8.476-0ubuntu1 (usando xorg-driver-fglrx_8.476-0ubuntu1_i386.deb) ...
* Stopping atieventsd [ OK ]
Desempaquetando el reemplazo de xorg-driver-fglrx ...
Configurando xorg-driver-fglrx (2:8.476-0ubuntu1) ...
* Starting atieventsd /usr/sbin/atieventsd: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
[fail]

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Prueba a instalar desde el controladores de hardware. Le pones el tick y que se instale solo.

Aunque sea la versión anterior, al menos habremos avanzado algo.
Si no te funciona.. me temo que yo te empezaría a recomendar reinstalar ubuntu completamente.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

no se como se instala desde donde me dices, pero si tu crees que es mejor..
si te parece, me cargo las particiones y reinstalo todo de cero.
pero, con sinceridad, ¿crees que la reproduccion de video a pantalla completa podra verse sin saltos? te lo pregunto porque con la instalacion por defecto tenia 3d y compiz pero no veia los videos bien (los veia realmente fatal). te pregunto esto porque sino, lamentablemente linux no funcionaria aun para mi escritorio. ya me fastidiaria porque llevo años (2 o 3 veces por año) probando a instalar un linux para intentar pasar de windows pero, siempre llego a un punto (la vez anterior creo recordar que no podia hacer funcionar de ninguna manera la tarjeta de red inalambrica), en que tengo que desistir de utilizar linux. no te imaginas lo que me fastidiaria llegar otra vez al mismo punto.

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Yo lo tengo instalado, de hecho acabo de poner los drivers 8-3. y me va de perlas, mucho mejor que en la versión anterior. Antes de reinstalar ubuntu prueba como te he dicho. Si me das unos minutos te saco una foticos para que no te pierdas.

El único problema que he visto por ahora, ha sido que los videos se quedaban negros. Pero antes, buscando informacion para ayudarte lo solucione.

Tu diras. Voy a ir haciendo los screenshot.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

si quieres hacemos esa ultima prueba. sino funciona. reinstalo todo y me ayudas a configurar bien el driver para no tener problemas. si aun asi no va pues, renuncio a linux hasta que me encaje con mi sistema.

tomatelo con calma pues he de salir (de vuelta en 1 hora)

gracias por todas las molestias que te estas tomando

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Bien, creo que te será fácil seguirlo:

1º- Entrar al gestor de controladores (sistema>administracion>controladores de hardware). la imagen por si te pierdes: Menú

2º- Meter contraseña.

3º Te saldrá una pantalla como la que adjunto. Pero en vez de salir en verde y en uso, a ti te saldra en rojo. Le pinchas en el cuadradito y se instalará. Te dice que debes reiniciar, NO lo hagas aún: gestor de controladores

4º Copia este xorg.conf. Si no volverás a iniciar con baja resolución, aunque tengas los drivers bien (no te preocupes por lo que falta, no es necesario) :xorg.conf

5º Ahora reinicia. Y vamos a asegurarnos de que tienes aceleración:
glxinfo |grep direct
debe decir: direct rendering: Yes

fglrxinfo
debe decir(la 2ª linea será diferente):
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X300
OpenGL version string: 2.1.7412 Release

lsmod |grep fglrx
debe decir algo semejante a:
fglrx 1545420 23
agpgart 33328 2 fglrx,intel_agp

6º Puedes intentar activar compiz. Pero seguramente te dirá que tienes un laptop con ati y que no le gustas :P. Para saltarte eso:
sudo gedit ~/.config/compiz/compiz-manager
Se abrirá un texto vacío, ahí escribes:
SKIP_CHECKS=yes

7º Para poder reproducir videos con Totem mientras tienes compiz activado:
gstreamer-properties
Vas a la pestaña video, y en salida predeterminada, escoges:
X Window System (No Xv)
La imagen:Gstreamer-propierties

Creo que no me dejo nada. A ver qué tal te va.

PD. A mi ahora se me ve así, a ver si conseguimos que te funcione igual :). (aunque no lo parezca, eso es un cubo :P): Cubo y video a pantalla completa

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

hago lo que me dices pero justo en el primer paso, el controlador ya me aparece marcado y en uso, en verde. de todas maneras he probado a desmarcarlo para que lo desinstale y volver a marcarlo. copio el xorg.conf tal cual, y reincio. sigo con baja resolucion y ademas

paco@pacolinux ~ $ glxinfo |grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect

ya no he seguido (¿para que?). esto es una maldicion o algo asi porque no entiendo que es lo que pasa

ni una pizca de suerte..

+1
0
-1

Saludos a todos

Imagen de wilmaforez
+1
0
-1

Pues no sé. Lo último que se me ocurre, es que reinstales ubuntu y vuelvas a seguir los pasos que te puse arriba. Si eso no te funciona, ya no sé.

Quizá tu tarjeta sea incompatible, no me explico otra :(.

Saludos y suerte.

______________________________________________________ 

 No es lo mismo el tiempo para Einstein que para Microsoft

+1
0
-1
Imagen de museoinformatico
+1
0
-1

tras hacer la ultima prueba, la tarjeta ati que incorpora este portatil no funciona o funciona a medias. lo maximo que hemos conseguido es tener 3d tras reinstalar completamente 2 veces, pero, si hay 3d no se reproduce bien los archivos de video (ni siquiere poniendo lo de Xv). sino, la mayor parte del tiempo no hay ni 3d y ademas arranca en baja resolucion.
por lo tanto, solo me queda agradecerte toda tu ayuda wilmaforez y tu tiempo, pero, definitivamente no funciona bien.

lo unico que he podido hacer es reparticionar el disco e instalar un güidos y dentro de el, sobre vmware el ubuntu (justo lo contrario de lo que queria hacer incialmente). aguantare asi hasta que los problemas con las ultimas ati se solucionen, probare cada cierto tiempo a ver si la cosa funciona.

saludos a todos y de nuevo, gracias

+1
0
-1

Saludos a todos