pc confundida con nVidia Corporation GeForce FX 5200 y con Intel 82845

Imagen de purcio
0 puntos

Hola a toda la comunidad espero no confundirme con las nuevas normas de Ubuntu-es por que en realidad no se como poner esta pregunta si es de harware o video en fin.

A mi pc meses (unos 2 aproximadamentre) le compre una tarjeta pc nVidia Corporation GeForce FX 5200, y ya contaba mi maquina con una tarjeta integrada Intel Corporation 82845G/GL el problema fue al instalar Hardy Heron (que curioso soy cetrero y cazo hairones) despues de actualizar mi ubuntu me quito la aceleración grafica, esto ya me habia ocurrido con 7.10 y lo solucionaba checando el pci en que se encontraba mi tarjeta con lspci y despues con #dpkg-reconfigure xserver-xorg pero en el hardy no configura la tarjeta de este modo, lo he intentado con el programa displayconfig-gtk pero no puedo y no tengo los conocimientos suficientes para mover mi xorg se los posteo a continuacion:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
SubSection "Display"
Modes "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "screen2" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "Intel 845"
Busid "PCI:0:2:0"
Driver "i810"
Screen 0
Vendorname "Intel"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "device" #
Identifier "device2"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nv"
Screen 0
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen2"
Device "device2"
Defaultdepth 24
Monitor "monitor2"
SubSection "Display"
Depth 24
Modes "1024x768@70" "1024x768@60" "1024x768@75" "1024x768@43" "1024x768@85" "1152x864@75" "832x624@75" "1280x960@60" "800x600@60" "1280x1024@60" "800x600@85" "1400x1050@60" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor2"
Vendorname "Gateway"
Modelname "Gateway EV730"
Horizsync 30.0-71.0
Vertrefresh 50.0-160.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

ahora esto es lo que me sale con lspci

00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller (rev 82)

intente tambien cambiar mi monitor a la tarjeta intel para solucionar el problema pero o sorpresa tampoco tenia aceleracion y sospecho que se trata de los identificadores (no se si se llaman asi)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

les agredecere mucho su ayuda y una sugerencia para los creadores de ubuntu

van por buen camino, han acercado linux a la gente pero regresen el #dpkg-reconfigure xserver-xorg

Imagen de pikaetas
+1
0
-1

No puedo ayudarte con la configuración de tu xorg, pero si podrías hacer dos cosas:

1.- Si no lo has probado ya, trata de recuperar una copia del xorg que te funcionaba, si lo guardastes, y copia sólo las lineas referentes a la gráfica.

2.- Si no tienes este xorg, y te encuentras más cómodo configurándolo con 7.10 (como me pasa a mí), podrías utilizar cualquier soft de maquinas virtuales, para instalar Gutsy Gibbon y configurar la gráfica como hacias antes.

Si nadie me corrrige, creo que así podriás copiar las lineas referentes a la gráfica y pégarlas en tu xorg.conf de Hardy.

+1
0
-1
Imagen de purcio
+1
0
-1

de hecho encontre una solucion solo que la solucion es al estilo Guindow$ y la verdad linux es otra cosa y no tendria por que ser asi, la solucion fue loa siguiente:
instale de nuevo linux desconectandole la targeta nvidia solo dejandole la intel 82845, la actualize le puse kernel 386, y cuando ya estaba lista la apago le inserto la tarjeta y entonces ahora si utilizo el envi, y la pc asi no se confunde.

respecto a copiar el xorg dias despues de postear esta pregunta lo hice pero parece que Hardy Heron no toma en cuenta el archivo xorg por que el xorg de el live es exactamente igual al de el sistema actualizado sin aceleracion y tampoco me fucionaron los xorg de versiones anteriores de ubuntu de hecho viene vacio solo con las opciones mas basicas (es increible) y aun asi tengo aceleración.

Este usuario no tiene firma, pero pareciera no afectarle.

+1
0
-1

Este usuario no tiene firma, pero pareciera no afectarle.