Problemas con actualizaciones y synaptic

Imagen de Tuluergo
0 puntos

Tengo roto el paquete libgcc1 y no puedo instalarlo por synaptic.Tampoco me deja descargar libc6. En el terminal me aparece esto:
sudo apt-get upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar `apt-get -f install' para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libc6-amd64: Depende: libc6 (= 2.7-10ubuntu3) pero no está instalado
libc6-dbg: Depende: libc6 (= 2.7-10ubuntu3) pero no está instalado
libc6-dev: Depende: libc6 (= 2.7-10ubuntu3) pero no está instalado
libgcc1: Depende: libc6 (>= 2.7-1) pero no está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.
vicente@ubuntuTuluergo:~$ apt-get -f install
E: No se pudo abrir el fichero de bloqueo '/var/lib/dpkg/lock' - open (13 Permiso denegado)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
vicente@ubuntuTuluergo:~$ sudo apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Se instalarán los siguientes paquetes extras:
libc6
Paquetes sugeridos:
locales glibc-doc libc6-i686
Se instalarán los siguientes paquetes NUEVOS:
libc6
0 actualizados, 1 se instalarán, 0 para eliminar y 0 no actualizados.
5 no instalados del todo o eliminados.
Se necesita descargar 0B/4308kB de archivos.
Se utilizarán 10,7MB de espacio de disco adicional después de desempaquetar.
¿Desea continuar [S/n]? s
E: No se puede encontrar la versión de debconf. ¿Está debconf instalado?
debconf: fallo al ejecutar «apt-extracttemplates»: Descriptor de archivo inválido
(Leyendo la base de datos ...
2082 ficheros y directorios instalados actualmente.)
Desempaquetando libc6 (de .../libc6_2.7-10ubuntu3_i386.deb) ...

A non-dpkg owned copy of the libc6-i686 package was found.
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library and try again.
dpkg: error al procesar /var/cache/apt/archives/libc6_2.7-10ubuntu3_i386.deb (--unpack):
el subproceso pre-installation script devolvió el código de salida de error 1
Se encontraron errores al procesar:
/var/cache/apt/archives/libc6_2.7-10ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Lo he intentado un montón de veces y no soy capaz. SOS