ubuntu + windows XP = Windows no arranca

hola, tenia unicamente instalado windowsXP y ahora he instalado ubuentu, q va bien, pero ya no puedo usar XP, no me arranca, al intentarlo me aparece esto:

Booting "Windows NT/2000/XP"
root (hd0,0)
filesystem type unknown,partition type 0x7
savedefault
makeactive
chainloader +1

y no pasa nada mas, no arranca...
espero q me podais ayudar...
gracias por adelantado...
JAVO

Imagen de Anónimo
+1
0
-1

lo primero que debes hacer es comprobar que el root este bien , hd0,0 corresponde a hda1 , y si no tienes la particion de windows ahi , no va a funcionar , por ejemplo si la tienes en hda4 seria root (hd0,3)

+1
0
-1
Imagen de hevria
+1
0
-1

> Sounds like the drive geometry issue has hit you. Was thought to be
> fixed in Warty, but seems like it still shows up for some people for
> some reason (me included). See
> a href="https://bugzilla.ubuntu.com/show_bug.cgi?id=1566 .
>
> A long explanation of the cause and a fix is here:
> http://lwn.net/Articles/86835/ . While referencing Fedora, it applies
> to Ubuntu as well. The core of the repair is here:
>
> 1) Try changing from AUTO to LBA mode in your BIOS for your hard drive.
>
> 2) Follow the instructions in the LWN article and use the sfdisk -d
> /dev/hda | sfdisk --no-reread -H255 /dev/hda commands to reset the
> drive geometry.
>
> No promises that this is your problem, but if it is, one of the two
> above should work.

Sin embargo, yo conseguí arreglar este problema cuando utilizaba Fedora Core 2 ( tienes la explicación aquí http://hevria.blogspot.com/2004/07/fedora-core-2-problema-hay-un-bug-en.html y no conseguí arreglarlo con Ubuntu, al final me cansé y formatee el disco duro ;)

Por cierto, Colin Watson ha puesto una nuevo iso de Warty con una versión actualizada de parted, que "se dice" no provoca este problema http://people.ubuntulinux.org/~cjwatson/warty-i386-new-parted.iso

Blog: http://hevria.blogspot.com
Mail: hevria _AT_ gmail.com

+1
0
-1

Blog: http://hevria.blogspot.com
Mail: hevria _AT_ gmail.com

Imagen de jlmontero
+1
0
-1

Hola Javo,

Tengo el mismo problema que tu. Tras probar ubuntu y ver que me gustaba decidi formatear instalar windows y ubuntu como tenia, pero con la particion de ubuntu con mas tamaño. Primero elimine particiones, formatee y luego desde windows con el partition magic cree las particiones swap y linux. Instale ubuntu como lo hice la primera vez y como lo hice con el portatil.Hasta ahi, todo perfecto. Pero al reiniciar e intentar cargar windows, me lleve la sorpresa de que no cargaba. No anote el error pero se que es el mismo (hice tres intentos, eliminando particiones, formateando y volviendo a instalar,y acabe harto de ese mensaje).
Ahora solo tengo ubuntu, no es que heche de menos windows, pero tengo un equipo multifuncion hp psc 1317 con el que no consigo escanear con ubuntu. Por lo demas, me encanta ubuntu.
Asi que, si consigues solucionarlo , te agradeceria que me contestases diciendo como lo has hecho.

Gracias y un saludo para todos.

+1
0
-1