Imposible (!?) instalar driver Nvidia!!!!!!!!

Imagen de gayuba
0 puntos

Hola a todos,
He instalado desde Cd original (Canonical Ltd) Ubuntu 8.04 LTS Desktop Edition en un ordenador de sobremesa antiguo(!)Intel Pentiun 4 a 400 MHz con 512 MB de memoria ram y con una targeta grafica Nvidia GeForce2 MX/MX 400 de 64MB.
Todo ha ido miel sobre hojuelas en lo tocante a instalacion, pero cuando he intentado habilitar el driver privativo que me ofrecia ubuntu, al reiniciar me ponia una resolucion de pantalla de 6oox400 y sin opcion de cambiarla.
He intentado instalar el driver a traves de Envy y idem de idem......... al final he optado por el manual : me he bajado el que corresponde a la grafica la version 1.0-7184 y en una consola pura Ctrl+Alt+F1 despues de logearme he seguido los pasos que me pedia Nvidia, al final me dice que hay un ERROR y que mire el archivo var/log/nvidia-installer.log y es lo que he hecho, pero aqui he topado con mi realidad pura y dura..... no entiendo nada,,,, lo copio a continuacion por si alguien puede darme alguna idea, gracias por adelantado y un saludo cordial.
Gayuba

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Jun 9 19:32:21 2008

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '7018'
of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.
For further details, please see the section INSTALLING THE NVIDIA DRIVER
in the README available on the Linux driver download page at
www.nvidia.com.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Saludos de nuevo y hasta siempre.

Imagen de cousteau
+1
0
-1

ERROR: You appear to be running an X server; please exit X before installing.

A lo mejor no te deja instalar los drivers de la tarjeta gráfica si tienes el entorno gráfico activado.
Prueba a cerrar antes la sesión (botón Salir del escritorio), y luego desde consola lo vuelves a instalar. (Para iniciar las X otra vez, usa startx)
Si ni aún así te deja, se me ocurre que reinicies y con el GRUB elijas recovery mode, así te aseguras de que no se cargan las X. Ya desde consola vuelves a instalar.


«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
+1
0
-1

«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
Imagen de gayuba
+1
0
-1

Me explico, desde consola pura salgo de las x, sudo /etc/init.d/gdm stop y despues cargo el driver. Tal vez este log corresponda a alguna vez que lo he hecho sin salir, pero siempre me da ese error.
Probare a ejecutar sudo dpkg --configure -a y si no da resultado, cargare los modulos manualmente en el archivo /etc/default/linux-restricted-modules-common ya que en DISABLED_MODULES=, he visto que no pone nada y he leido por ahi que deberia poner DISABLED_MODULES="nv nvidia_new". Aunque en mi portatil, en este archivo tampoco pone nada.
Estoy un poco confuso, seguire investigando y si lo solucione ya lo comunicare.
Si hay alguna idea mas, estoy completamente abierto.
Saludos cordiales
Gayuba

+1
0
-1
Imagen de anarhell
+1
0
-1

abre el archivo y copialo para mirar una cosa.. lo que pasa e sque a mi me sucedia que la resolucion me la dejaba en 1024 cuando deberia ser de 1280.. otra cosa cuando usabas el windows cuanto era la maxima resolucion de tu pantalla..

/etc/X11/xorg.conf

La vida es solo un paso hay que disfrutarla al maximo

+1
0
-1

El pasado es historia, el futuro no esta escrito,
el presente es un regalo no lo olvides.
unab99@gmail.com