Deshabilitar Grafica Integrada sin usar la BIOS [SOLUCIONADO]

Imagen de pikaetas
0 puntos

Hola a todos.Estoy muy pez en esto,pero intentare explicarme lo mejor posible.

Tengo una maquina vieja, de esas que no quieres tirar a la basura.Un Dell Optiplex g1 PIII 550 Mhz con 380Mb RAM y con una ATI Rage IIC 2Mb, y Ubuntu Hardy.
Funciona correctamente y lo tengo de MediaCenter.

Me he comprado un LCD de 40" y he querido aumentar la resolución, pero los 2 Mb de la grafica no me dejan pasar de 1024x768 (Color a 16).

Tengo un Slot PCI libre y he pensado ponerle otra grafica, una S3 de aquellas chungas.Aqui empiezan los problemas.

La tarjeta integrada no puede dehabilitarse por BIOS ni tiene Jumper alguno para anularla.Cuando arranco con las dos graficas,en el momento que carga el SO se cuelga, algo lógico porque el soft no sabe que grafica usar.

Lo lamentable es que SI la he hecho funcionar, pero solamente si instalo Windows.

El truco es cargar el XP,desistalar la grafica en Admin. Dispos., apagar, poner la PCI y arrancar con la otra funcionando al 100%.

Lo primero que he pensado... si se puede en Win, en ubuntu fijo que también.

Mi pregunta es:

¿Alguien ha conseguido algo parecido?
¿Sabeis como se arranca un linux ignorando un hardware expresamente?

Lo unico que se me ocurre es instalar Ubuntu server 7.10 , luego el Xorg y con un
# sudo dpkg-reconfigure xserver-xorg, montar el driver de la tarjeta S3 PCI y reiniciar a ver que pasa. Luego ya veria como actualizar a Ubuntu Hardy.

Gracias.

Imagen de Gabriel_M
+1
0
-1

Hola pik...:
Prueba:
Inicia ubuntu con la tarjeta integrada.
Ve si hace falta instalar controladores en el sistema para tu nueva gráfica.
En consola ejecuta:
sudo telinit 1
sudo dpkg-reconfigure -phigh xserver-xorg
elige la tarjeta nueva
sudo nano /etc/modprobe.d/blacklist
agrega la línea
blacklist ati-rage
Cambia ati-rage, por la denominación que le da tu sistema a la tarjeta incorporada.
Guarda el archivo
Reinicia

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de pikaetas
+1
0
-1

Ok. Lo probaré.

Entonces tengo que reconfigurar el xorg e introducir manualmente la tarjeta PCI [ "S3Trio" ]que luego montaré, que añada a la lista negra la integrada[ "ati" ]y reinicie con la PCI insertada.Parece sencillo.

Gracias. Ya te cuento.

+1
0
-1
Imagen de pikaetas
+1
0
-1

Gabriel, eres un CRACK !!!

Ha sido muy muy facil.

He tenido problemas con el dpkg-reconfigure porque en 8.04 no se me abre ningun menú donde elegir la tarjeta,resolucion y profundidad de color,etc...

Pero de casualidad recordaba que la fila era [ Driver "S3virge" ]
y ha colado.Era mas facil para mi en Gutsy, pero como tengo una particion con esta versión,reconfiguraré el xorg a mi manera y lo copiare en Hardy.

La tarjeta PCI que tenía era igual de mala (2Mb de video), pero ahora sé que se puede hacer y como tambien.

Abusando un poco mas,

¿Que tarjeta pci NORMAL, podrías a un pc que se conectará a una tele 40" fullhd?

Creo que tengo que excluir todas la ati, porque ahora estan en la blacklist.

He leido que aún se venden Geforce 6200 256Mb PCI.

Y otra cosa más.

tengo 2 slots PCI, y tengo que montar la trajeta de usb 2.0 (necesaria), la Soundblaster (mas necesaria aún) y la grafica que me voy a comprar fijo.

Tengo 2 slots ISA (puff la de años que tiene esto) ¿Donde puedo comprar una Blaster ISA? ¿O acudo a la caridad?

Mil gracias.

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Hola pik...:
Sin dudarlo Geforce, en Argentina aún se consiguen algunas PCi, algo más caras pero se consiguen.
las de sonido Isa no se si se pueden configurar fàcilmente, deberias buscar en el foro, en Argentina, no digo que las regalan, pero son muy baratas, casi no quedan mothers con slots Isa funcionando.

Saludos.


Equipo de Ubuntu-es
+1
0
-1
Imagen de lulope
+1
0
-1

Buenas tardes y feliz salida y entrada de año.
Tengo instalado Ubuntu 8.10 64 bits
Mi problema es muy parecido al tuyo, no puedo desactivar la gráfica integrada Nvidia en el BIOS, para instalar una ATI HD4350 en el zocalo PCI-E x1.
En mi caso cuando arranco con las dos gráficas, sólo reconoce la integrada.
También tengo problemas para inicializar el CCC (Centro de Control Catalyst e ATI), me indica que no hay controlador de gráficos ATI instalado o no funciona adecuadamente.
En consola al comando:
aticonfig --initial
Responde Fallo de segmentación.
He deshabilitado el hardware privativo de Nvidia y tampoco.
Me quedaría incluir la nvidia en el blacklist pero:
Como conozco el nombre que le da el sistema a la grafica integrada?
con el comando sudo dpkg-reconfigure -phigh xserver-xorg
no consigo ninguna lista de tarjetas nuevas.

Gracias.

+1
0
-1