problemas con Dev-c++ en ubuntu 7.10

Imagen de locovicen
0 puntos

hola llevo algo en ubuntu y ahora estoy enpezando a programar en c++ y no tengo muchos conocimientos todavia, estoy usando dev-c++ en windows, pero quiero pasarme a ubuntu, he encontrado la version para ubuntu pero no puedo compilarla, mas bien nose jej es un archivo /home/vicente/Desktop/dev-src_Jul_30_23h03.tar.gz lo descomprimi en una carpeta y puse en terminal esto:

vicente@VicentePortatil:~$ cd '/home/vicente/Desktop/dev-src_Jul_30_23h03' 
vicente@VicentePortatil:~/Desktop/dev-src_Jul_30_23h03$ ./configure
bash: ./configure: No existe el fichero ó directorio
vicente@VicentePortatil:~/Desktop/dev-src_Jul_30_23h03$ sudo make
tar czvf dev-src_`date | cut -d" " -f2,3,4 | sed s/":"/"h"/ | sed s/" "/"_"/g | cut -d"h" -f1,2 | cut -d: -f1`.tar.gz *.pas *.dpr *.dfm *.xfm *.res *.conf c++/ pas/ Makefile synedit/
about.pas
cpp_compoptions.pas
debugfrm.pas
dev_module.pas
editor.pas
enviropt.pas
firbfrm.pas
help.pas
infofrm.pas
line.pas
main.pas
newproject.pas
outputfrm.pas
pas_compoptions.pas
project.pas
projectoptions.pas
removeunit.pas
splash.pas
templatefrm.pas
tooleditfrm.pas
toolfrm.pas
utils.pas
version.pas
dev.dpr
tooleditfrm.dfm
about.xfm
cpp_compoptions.xfm
debugfrm.xfm
enviropt.xfm
firbfrm.xfm
help.xfm
infofrm.xfm
line.xfm
main.xfm
newproject.xfm
outputfrm.xfm
pas_compoptions.xfm
projectoptions.xfm
removeunit.xfm
splash.xfm
templatefrm.xfm
toolfrm.xfm
dev.res
dev.conf
c++/
c++/setup/
c++/setup/README~
c++/setup/install.sh~
c++/setup/install.sh
c++/setup/README
c++/setup/#install.sh#
c++/setup/INSTALL
c++/setup/.#install.sh
c++/setup/install.~sh
c++/docs/
c++/docs/index.html
c++/docs/compoptions.html
c++/docs/cpp/
c++/docs/cpp/linux/
c++/docs/cpp/win32/
c++/docs/mailinglist.html
c++/docs/pas/
c++/docs/pas/linux/
c++/docs/pas/win32/
c++/docs/TOPICS.txt~
c++/docs/TOPICS.txt
c++/docs/gpl.html
c++/docs/templates.html
c++/templates/
c++/templates/opengl.txt
c++/templates/opengl_cpp.txt
c++/templates/hello.template
c++/templates/gtk+.ico
c++/templates/test.template
c++/templates/gtk+_c.txt
c++/templates/hello.ico
c++/templates/test_cpp.txt
c++/templates/opengl.template
c++/templates/hello_c.txt
c++/templates/hello_cpp.txt
c++/templates/gtk+.template
pas/
pas/setup/
pas/setup/install.sh~
pas/setup/install.sh
pas/setup/README
pas/setup/INSTALL
pas/setup/install.~sh
pas/templates/
pas/templates/opengl.txt
pas/templates/gtk+.txt
pas/templates/hello.txt
pas/templates/hello.template
pas/templates/gtk+.ico
pas/templates/hello.ico
pas/templates/opengl.template
pas/templates/gtk+.template
Makefile
synedit/
synedit/SynHighlighterPython.pas
synedit/SynEditMiscClasses.pas
synedit/SynEditMiscProcs.pas
synedit/SynEditTextBuffer.pas
synedit/SynHighlighterVB.pas
synedit/SynEditPythonBehaviour.pas
synedit/SynEditPrintMarginsDialog.dfm
synedit/Contributors.txt
synedit/SynEditPropertyReg.pas
synedit/SynHighlighterInno.pas
synedit/SynEditPrintPreview.pas
synedit/SynEditAutoComplete.pas
synedit/SynEditKeyCmds.pas
synedit/Readme.txt
synedit/SynEditReg.res
synedit/SynHighlighterPas.pas
synedit/SynHighlighterDml.pas
synedit/SynEditPrint.pas
synedit/SynHighlighterTclTk.pas
synedit/SynHighlighterCAC.pas
synedit/SynEditExport.pas
synedit/SynHighlighterJava.pas
synedit/SynExportRTF.pas
synedit/SynHighlighterGalaxy.pas
synedit/SynHighlighterBat.pas
synedit/SynHighlighterXML.pas
synedit/SynEditKeyCmdsEditor.pas
synedit/SynHighlighterJScript.pas
synedit/SynHighlighterSml.pas
synedit/SynHighlighterHP48Utils.pas
synedit/SynHighlighterAWK.pas
synedit/SynEditReg.pas
synedit/SynEditPrinterInfo.pas
synedit/SynEdit.pas
synedit/synedit_kylix.kof
synedit/SynHighlighterPerl.pas
synedit/SynEditTypes.pas
synedit/SynHighlighterBaan.pas
synedit/SynHighlighterManager.pas
synedit/SynHighlighterModelica.pas
synedit/SynHighlighterAsm.pas
synedit/SynRegExpr.pas
synedit/SynEdit.res
synedit/SynEditKeyCmdEditor.dfm
synedit/SynHighlighterDfm.pas
synedit/SynHighlighterProgress.pas
synedit/SynHighlighterMPerl.pas
synedit/SynEditPrintMarginsDialog.pas
synedit/SynMemo.pas
synedit/SynEditKeyCmdsEditor.dfm
synedit/kTextDrawer.pas
synedit/SynHighlighterGeneral.pas
synedit/SynHighlighterFoxpro.pas
synedit/SynHighlighterCpp.pas
synedit/SynTextDrawer.pas
synedit/SynHighlighterHtml.pas
synedit/CVS/
synedit/CVS/Entries
synedit/CVS/Repository
synedit/CVS/Root
synedit/SynHighlighterHP48.pas
synedit/SynHighlighterPHP.pas
synedit/SynHighlighterADSP21xx.pas
synedit/SynHighlighterMulti.pas
synedit/synedit_kylix.dpk
synedit/synedit_kylix.res
synedit/SynEditStrConst.pas
synedit/SynHighlighterCss.pas
synedit/SynEditPrintHeaderFooter.pas
synedit/SynEditPrintTypes.pas
synedit/SynEditReg.dcr
synedit/synedit_kylix.dcp
synedit/SynEditSearch.pas
synedit/SynHighlighterHashEntries.pas
synedit/SynEditHighlighter.pas
synedit/Changelog.rtf
synedit/synedit_kylix.conf
synedit/SynHighlighterCache.pas
synedit/bplsynedit_kylix.so
synedit/SynHighlighterSQL.pas
synedit/SynEditPrintMargins.pas
synedit/SynEditPrint_Old.pas
synedit/SynCompletionProposal.pas
synedit/SynDBEdit.pas
synedit/SynEdit.inc
synedit/SynHighlighterIni.pas
synedit/SynHighlighterVBScript.pas
synedit/SynHighlighterHC11.pas
synedit/SynHighlighterFortran.pas
synedit/SynExportHTML.pas
synedit/SynEditKeyCmdEditor.pas
synedit/SynHighlighterM3.pas
synedit/Page.bmp
synedit/SynHighlighterKix.pas
vicente@VicentePortatil:~/Desktop/dev-src_Jul_30_23h03$ sudo make install
make: *** No hay ninguna regla para construir el objetivo `install'.  Alto.
vicente@VicentePortatil:~/Desktop/dev-src_Jul_30_23h03$ 


vamos que nose instalarlo, ¿alguien me puede ayudar?
tambien he probado anjuta en ubuntu pero para compilar hay que crear un proyecto y yo por ahora solo quiero compilar un simple archivo, al estilo de dev c++ que tan solo al darle a compilar y ejecutar te lo compila y lo ejecuta, es por eso por lo que m interesa dev c++ en ubuntu.
gracias espero que alguien me pueda ayudar

Imagen de patagonian18
+1
0
-1

¿Hay Dev-C++ para Ubuntu? esa si que es una buena noticia. Yo lo tengo instalado en Windbugs, pero no estaba enterado que tuviera versión para Linux.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de locovicen
+1
0
-1

si, me lo he bajado de aqui, si consigues instalarlo me dices como.
http://sourceforge.net/project/showfiles.php?group_id=10639&package_id=1...

uauuuuuu!!!! MIRA!!! pero si han introducido internet en los ordenadores!! cada dia avanzamos mas!

+1
0
-1
Imagen de patagonian18
+1
0
-1

Vale. Lo estoy bajando.

Edito:

Después de buscar un poco, logré dar con el archivo Install. Está dentro de la carpeta dev-src_Jul_30_23h03/c++/setup. Lo que dice el archivo en cuestión, es esto:

-- INSTALLATION INSTRUCTIONS --

* First you need to make sure you have a installed all the C/C++ development packages when installing your distribution (those packages contains gcc, g++, make, standard include files and libraries). You should be able to obtain them on you distribution CD/web site.

* You then need Qt libraries installed. If you don't you can download the Qt package at : ftp://ftp.trolltech.com/qt/source/qt-x11-2.3.0.tar.gz
Follow the Qt INSTALL file after unpacking it and you should be able to installit quite easily.

* Now that your system is ready to run Dev-C++, type (as root) :

$> sh install.sh
or :
$> ./install.sh

This will launch the installation script. Follow the instructions and after the installation finish, change to your dev-c++ directory ($HOME/dev-c++ by default) and type :

$> ./devcpp

Dev-C++ is now being launched, enjoy :)

...que traducido a la lengua de Cervantes sería algo más o menos así:

-- INSTRUCIONES DE INSTALACION --

* Necesita primero asegurarse que tiene instalado todos los paquetes de desarrollo de su distribución. En el caso de Ubuntu, build-essential.

* Es necesario tener instaladas las librerías QT. Si no es así, se pueden bajar desde: ftp://ftp.trolltech.com/qt/source/qt-x11-2.3.0.tar.gz. Siga las instrucciones del archivo Qt INSTALL después de extraerlo y debería ser capaz de instalarlo fácilmente. Yo revisaría primero en Synaptic si es que están disponibles las dichosas librerías, para evitarme todo el proceso de compilarlas.

* Ahora que su sistema está está listo para correr Dev-C++, escriba (como root):

$> sh install.sh
ó (cualquiera de las dos vale):
$> ./install.sh

Esto lanzará el script de instalación. Siga las instrucciones y después que acabe la instalación, canbie a su directorio dev-c++ ($HOME/dev-c++ por omisión) y escriba:

$> ./devcpp

Dev-C++ se ha lanzado, disfrute :)

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de moderno
+1
0
-1

Yo les recomiendo que usen Geany viene en los repositorios es perfecto para lo que nesesitan.

+1
0
-1
Imagen de locovicen
+1
0
-1

he probado con lo que tu me as dicho pero no se instalarlo, mira esto es lo que he hecho:

vicente@VicentePortatil:~$ su
Contraseña: 
root@VicentePortatil:/home/vicente# cd /home/vicente/Desktop/dev-src_Jul_30_23h03/c++/setup
root@VicentePortatil:/home/vicente/Desktop/dev-src_Jul_30_23h03/c++/setup# ./install.sh
** Dev-C++ installation script **

You must be root to install. Do you want to continue ?
 (Y/n) ? y
tar: binary.tar.gz: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Salida con error demorada desde errores anteriores
Where do you want to install Dev-C++ ? [/root/dev-c++] : /home/vicente/Dev c++
./install.sh: line 38: test: /home/vicente/Dev: se esperaba operador binario
mv: no se puede efectuar `stat' sobre `TODO': No existe el fichero ó directorio
mv: no se puede efectuar `stat' sobre `BUGS': No existe el fichero ó directorio
mv: no se puede efectuar `stat' sobre `/home/vicente/Dev': No existe el fichero ó directorio
mv: no se puede efectuar `stat' sobre `bin/devcpp': No existe el fichero ó directorio
mv: no se puede efectuar `stat' sobre `/home/vicente/Dev': No existe el fichero ó directorio
mv: no se puede efectuar `stat' sobre `bin/libqtintf.so*': No existe el fichero ó directorio

* This script will now guess your gcc and make paths
* Press enter if the path is correct for each program

make is located in : [/usr/bin/make] : 
gcc is located in : [/usr/bin/gcc] : 
g++ is located in : [/usr/bin/g++] : 
gdb (or your favourite debugger) is located in : [/usr/bin/gdb] : 
xterm, aterm or Eterm is located in : [/usr/bin/xterm] : 

* Configuration file is now been written in /root/.devcpp/config


* Installation terminated, you may now run /home/vicente/Dev c++/devcpp

root@VicentePortatil:/home/vicente/Desktop/dev-src_Jul_30_23h03/c++/setup# /home/vicente/Dev c++/devcpp
bash: /home/vicente/Dev: No existe el fichero ó directorio
root@VicentePortatil:/home/vicente/Desktop/dev-src_Jul_30_23h03/c++/setup# 


¿me puedes explicar detalladamente como se instala?
esque no tengo ni idea, gracias

el programa geany no es lo que busco, para utilizar geany utilizo anjuta, pero no es lo que busco, gracias por la respuesta.
uauuuuuu!!!! MIRA!!! pero si han introducido internet en los ordenadores!! cada dia avanzamos mas!

+1
0
-1
Imagen de patagonian18
+1
0
-1

Tranquilo. Sólo debes anteponer sudo al comienzo. Así:

sudo ./install.sh

A eso se refiere cuando dice que "debes hacerlo como root" :).

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de locovicen
+1
0
-1

te equivocas, no debo anteponer sudo ya que soy root, al poner su y la contraseña de root, de todas formas con mi usuario y añadiendo sudo delante tampoco funciona

uauuuuuu!!!! MIRA!!! pero si han introducido internet en los ordenadores!! cada dia avanzamos mas!

+1
0
-1
Imagen de patagonian18
+1
0
-1

¡ups! tienes razón, no leí la primera línea. Espera, que esta vez leo con más atención.

Creo que el error viene de acá:

tar: binary.tar.gz: No se puede open: No existe el fichero ó directorio

Está justo después de la línea donde te avisa que debes ser root para continuar.

EDITO:

Anduve buscando en Internet, y encontré un archivo que si trae el binary.tar.gz. Puedes encontrarlo acá.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de patagonian18
+1
0
-1

Hola:

Yo de nuevo. Dale una mirada a codeblocks. Se ve bastante similar a dev-cpp y tiene una versión más reciente que éste. De hecho las versiones para Linux que he encontrado de dev-cpp tienen ya varios años. La última versión de codeblocks es de febrero de 2008. Lo estoy bajando en este momento, a ver que tal.

EDITO:

Acabo de probar CodeBlocks. Va de lujo. Compilé y corrí el hola mundo sólo con apretar F9 (¿o F10? :p). Hasta ahora, es lo más fácil de usar que he encontrado en Linux.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de locovicen
+1
0
-1

¿de donde te has bajado CodeBlocks? en synaptic no esta, de mientras voy a probar a instalar dev c++

EDITO :-p
he instalado el paquete de dev c++ que me as dixo lo he instalado me dice que se ha instalado correctamente, sin ningun error se crea en mi carpeta personal en una carpeta que se llama dev-c++, con el terminal dentro de esa carpeta escribo ./devcpp y me dice que no existe el fichero o el directorio,no lo entiendo ya que dentro de esa carpeta ay un archivo que dice que es ejecutable que se llama devcpp y tambien ay un archivo de texto llamado bugs que pone:

** Dev-C++ bug list **

- Problem when trying to free the editor tabsheets
- Syntax highlight editor sometimes behaves strangely

parece que en ese archivo dice que ay un problema pero no se que es tabsheets, tu lo entiendes?
por si acaso te dejo lo que me dice al instaler el devc++ en el terminal:

vicente@VicentePortatil:~$ cd '/home/vicente/Desktop/devcpp-bin_070' 
vicente@VicentePortatil:~/Desktop/devcpp-bin_070$ sudo ./install.sh
** Dev-C++ installation script **

You must be root to install. Do you want to continue ?
 (Y/n) ? y
bin/devcpp
bin/libqtintf.so
README
README-BETA.txt
BUGS
templates/gtk+.ico
templates/gtk+.template
templates/gtk+_c.txt
templates/hello.ico
templates/hello.template
templates/hello_c.txt
templates/hello_cpp.txt
templates/opengl.template
templates/opengl.txt
templates/opengl_cpp.txt
templates/test.template
templates/test_cpp.txt
Where do you want to install Dev-C++ ? [/home/vicente/dev-c++] : 
mv: no se puede efectuar `stat' sobre `TODO': No existe el fichero ó directorio

* This script will now guess your gcc and make paths
* Press enter if the path is correct for each program

make is located in : [/usr/bin/make] : 
gcc is located in : [/usr/bin/gcc] : 
g++ is located in : [/usr/bin/g++] : 
gdb (or your favourite debugger) is located in : [/usr/bin/gdb] : 
xterm, aterm or Eterm is located in : [/usr/bin/xterm] : 

* Configuration file is now been written in /home/vicente/.devcpp/config


* Installation terminated, you may now run /home/vicente/dev-c++/devcpp

vicente@VicentePortatil:~/Desktop/devcpp-bin_070$ 

amm por cierto si me pasa el CodeBlocks y funciona como el devcpp, y tan bien como tu dices pues me kedo con ese jejeje
gracias por todo!!!

uauuuuuu!!!! MIRA!!! pero si han introducido internet en los ordenadores!! cada dia avanzamos mas!

+1
0
-1
Imagen de patagonian18
+1
0
-1

Me pasó lo mismo con el dev-c++, pero supuse que era por intentar instalarlo en ubuntu de 64 bits. En todo caso, ese paquete es del 2001, si mal no recuerdo (no estoy en mi computador ahora).

En cuanto al CodeBlocks, hay que bajarlo desde su página. Hay un .deb para Ubuntu. La página es www.codeblocks.org. Para instalar el .deb, primero tienes que instalar wxGTK-2.8.7. Al menos en gutsy es así. Tal vez en Hardy ya venga instalado. En la misma página te dan el repositorio que hay que instalar.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de locovicen
+1
0
-1

me as repondido tarde jeje esque en google he encontrado esta guia:

http://libreyabierto.cc/lawiki/index.php/Guia_de_instalaci%C3%B3n_code::...

y e instalado codeblock coo dice la guia con el terminal(para ubuntu 7.10) funciona perfectamente he compilado un ola mundoo con un archivo como en dev c++ sin proyecto ni nada jeje pero el problema que veo es que esta en ingles, ¿sabes como traducirlo?

¿entonces no me puedes ayudar con lo del dev ++? aunque parece que con codeblock me sobra y si se puede traducir perfecto, pero ya que he empezado a intentar instalar dev c++ estaria bien conseguirlo ejje
bueno si sabes algo me escribes y gracias tio!!

uauuuuuu!!!! MIRA!!! pero si han introducido internet en los ordenadores!! cada dia avanzamos mas!

+1
0
-1
Imagen de patagonian18
+1
0
-1

El problema con dev-c++ es que yo mismo no logré instalarlo, así que malamente puedo ayudar a alguien más a hacerlo. Además, me da la leve impresión que dev-c++ está estancado en su desarrollo. La última versión disponible en su página, Dev-C++ 4.9.9.2 es del 22 de febrero de 2005.

En cuanto a CodeBlocks, por lo que revisé en su página web, creo que sólo está localizado en inglés y alemán. Eso sí, hasta donde mi curiosidad alcanzó, los menúes de la versión en inglés no tienen ninguna palabra tan desconocida. Build, compile, clean, run, etc son de uso común.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta