HOWTO Instalar drivers de ATI

+1
0
-1

(Extraido de www.ubuntuforums.org , mas algunas partes añadidos probando)

1. sudo apt-get install linux-686 (o -loquecoincida con tu kernel)
2. sudo apt-get install fglrx-driver
3. echo fglrx | sudo tee -a /etc/modules
4. sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/XF86Config-4

Con eso ya estaria todo , pero a veces al reiniciar , la resolucion se te pone en 1600x1200 y no puedes cambiarla , la solucion es esta:

1. gedit /etc/X11/XF86Config-4
Buscamos esto :

...
Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon 9200 (RV280)"
Monitor "Flatron795FT"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x540" "720x400" "640x480"
EndSubSection
...

Nos saldran muchas secciones como esa , tenemos que eliminar las entradas correspondientes a resoluciones mas grandes que la nuestra . Por ejemplo si tenemos "1024x768" borramos "1600x1200" "1280x1024" "1152x864" de todas las secciones que salgan y reiniciamos gnome (Control + Alt + Backspace) y ya deberia funcionar ;)

Comentarios

Imagen de Anónimo

Pues eso, resulta que de momento me tengo que conformar con un winmodem y no puedo "salir" fuera con ubuntu o sea que me las apaño con wxp

¿qué puedo hacer?

Imagen de AlvaroBF

Deberias buscar la forma de bajarte esos dos paquetes (linux-686 o lo que uses y fglrx-driver) lo demas puedes hacerlo sin internet

Saludos

PD: Hago un glxgears

ATI Radeon 9200 Series 128MB
10368 frames in 5.0 seconds = 2073.600 FPS
10814 frames in 5.0 seconds = 2162.800 FPS
10736 frames in 5.0 seconds = 2147.200 FPS
10934 frames in 5.0 seconds = 2186.800 FPS
10958 frames in 5.0 seconds = 2191.600 FPS
10941 frames in 5.0 seconds = 2188.200 FPS
10902 frames in 5.0 seconds = 2180.400 FPS

Imagen de jlx

Las Radeon 9600 (o sea, la mía -cachis-) no tienen soporte 3D en Ubuntu. Es la única que se les resite, todas las demás funcionan bien. Podéis comprobarlo en este enlace:
Tarjetas Soportadas

Imagen de AlvaroBF

creo que esa es la lista de tarjetas soportadas por los drivers del cd , la mia 9200 no viene en esa lista y instalando los drivers funciona .
Sin embargo con la 9000 hay gente que recien instalado le vaya la 3d , un lio vamos

Imagen de jlx

Hola Álvaro.
He probado tu método (anteriormente probé algo parecido sin éxito) y sigo sin tener acelaración 3D. De hecho es que con el driver fglrx no me arranca el entorno gráfico. Afortunadamente aprendí la lección (tuve que reinstalar Ubuntu la anterior vez) e hice una copia de seguridad del XF86Config-4. ¿Alguien más tiene una 9600 (la mía es Shaphire) y ha conseguido que funcione la aceleración 3D?

Imagen de AlvaroBF

vaya , deberia haber dicho que siempre hagais copias de seguridad de vuestro XF86Config-4 (sudo cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.bak y para restaurarlo al reves) mmm los drivers de fglrx no te arrancan , podrias probar unos llamados DRI (drivers libres que funcionan tanto en ATI como en nVidia) yo los probe ayer , cuando instale X.Org tuve que desactivar estos (Xorg y fglrx no se llevan bien ) .
Creo que los drivers se instalan automaticamente al instalar xserver-xorg del repositorio de hoary , no se la verdad , pero dan muy buenos resultados

Imagen de Anónimo

Hola, yo tengo una ati 9600. Y por fin he conseguido instalarlo. La verdad es que nop se mucho de Linux, me estoy iniciando, y no se que he hecho pero ya me va el juego del tux racer a 46fps. Si necesitas algo te dejo mi msn:
eduardsanou(arroba)hotmail.com

Imagen de Anónimo

Me dice no screenfound tengo una mobility radeon U340.

Gracias

Imagen de AlvaroBF

revisa si cambiaste bien todo, en /etc/modules debe aparecer "fglrx" y en /etc/X11/XF86Config-4 debe salir driver "fglrx" , no ati no radeon y tener instalado el paquete fglrx-driver, si no es eso ni idea :S

Imagen de TheSen

Hola,

El otro día intenté ponerlo en marcha y el problema que tuve fue que el totem no me reproducía correctamente. Para revertirlo lo que hice fue:

$ sudo apt-get remove fglrx-driver
$ sudo gedit /etc/X11/XF86Config-4

Y ahi buscar 'fglrx' y reemplazarlo por 'ati'. Luego

$ sudo gedit /etc/modules

Y eliminar la línea que añadimos: 'fglrx'

A mí me resultó así, no había hecho un backup del XF86Config-4 y luego todo volvió a la normalidad.

Un saludo

---------------------------------------------
Mucho mundo por ver, muchas cosas por hacer

Mucho mundo por ver, muchas cosas por hacer

Imagen de takeishy

acabo de comprar una tarjeta de video 3d de 256mb chaingtech, yo la conecto directo al televisor porq no tengo monitor, instale ubuntu perfecto pero cuando va a cargar el windows no aparece nada, se queda el televisor negro, saben como puedo solucionar ese problema para ver mi escritorio de gnome en el televisor.

takeishyc aroba hotmail punto com
Takeishy Cardenas

Takeishy Cardenas