¿Cambiar resolución de la ventana de entrada? (Solucionado)

Imagen de danilo_herr
0 puntos

Hola amigos, quisiera saber si hay alguna forma de cambiar la resolución en la ventana de entrada de Ubuntu Hardy, ya que en mi escritorio y en el sistema en general utilizo 1024X768 pero en la de entrada siempre esta la de 1280X768 que era la antigua resolución que utilizaba y nunca la pude cambiar de la ventana de bienvenida, gracias de antemano por su ayuda.

Imagen de Sanguinario_Joe
+1
0
-1

Jajaja, yo tuve ese mismo problema hace nada, la solucion pasa por editar el archivo de configuracion, asi que vamos a hacer lo siguiente:

  1. Crear copia de seguridad del archivo
    Para crear una copia de seguridad del archivo (luego te contare que hacer si algo va mal) simplemente ejecuta esta orden:
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back
    

    Con eso te habra duplicado el archivo en la misma carpeta con el nombre "xorg.conf.back".

    • ¿Que pasa si algo va mal, y cuando arranque no tengo interfaz grafica?
      No hay problema, tan solo reinicia (con el boton si es necesario), y cuando este arrancando el grub (pulsa Esc si te lo pide) escoge la primera opcion "recovery mode" que veas, cuando te arranque (veras que es una terminal) ejecuta estas dos ordenes (apuntatelas en un papel ahora):
      sudo rm /etc/X11/xorg.conf
      
      sudo mv /etc/X11/xorg.conf.back /etc/X11/xorg.conf
      

      Con esto moveras (luego desaparecera el archivo de copia) el archivo de backup al lugar original

  2. Editar el archivo
    Ahora vamos a editar el susodicho archivo, para ello ejecuta la siguiente orden (yo pongo gedit porque uso ubuntu, si usas kubuntu, pues el que toque):
    sudo gedit /etc/X11/xorg.conf
    

    Bien, en el archivo, busca un apartado que ponga:

    Section "Screen"
    

    Igual te llevas la sorpresa de que tienes dos, en mi caso por ejemplo:

    Section "Screen"
    	Identifier	"Default Screen"
    (...)
    
    Section "Screen"
    	Identifier	"aticonfig-Screen[0]"
    (...)
    

    Bien, pues en mi caso yo me voy al segundo, que para algo es mi tarjeta grafica.
    Bueno, pues alli debes tener una subseccion llamada:

    	SubSection "Display"
    

    Si no la tienes añadela, y deberia quedarte parecido a esto:

    Section "Screen"
    	Identifier	"aticonfig-Screen[0]"
    	Device		"aticonfig-Device[0]"
    	Monitor		"aticonfig-Monitor[0]"
    	SubSection "Display"
    
    	EndSubSection
    	Defaultdepth	24
    EndSection
    

    Y ahora rellenemos esta subseccion, que deberia quedar algo asi como esto:

    	SubSection "Display"
    		Viewport	0	0
    		Depth	24
    		Modes		"1280x1024"	"1024x768"	"800x600"	"640x480"
    	EndSubSection
    

    Las dos primeras lineas son las predeterminadas, si tu tenias otras no las cambies.
    La tercera linea es la que nos interesa, donde como ves aparecen las resoluciones que le permites a tu monitor & tarjeta grafica, la primera que pongas sera la de la pantalla de bienvenida. Ten cuidado de no poner una que no soporte tu monitor, o no veras nada, si aun asi cometes el error, simplemente usa la backup tal y como te explique antes...

  3. Reinicia el entrono grafico
    Lo mejor siempre es directamente reiniciar, pero si eres un impaciente, y no te importa que te queden algunos procesos duplicados en la sesion actual, simplemente presiona "Ctrl+Alt+Backspace" donde backspace es la tecla de borrar encima del intro.

Ya veras como se soulcionan tus problemas...

Suerte!!! Saludos!!!

P.D.- Recuerda que si funciona debes cambiar el asunto a (solucionado). Ya nos comentas como te fue...

+1
0
-1
Imagen de ctwkkk
+1
0
-1

Hoal chicos, me parece estupenda la solución que le has dado a Sanguinario_Joe, jejej Me podriais hechar una mano por favor?

A mi me pasa justamente al revés, que la ventana de entrada tiene la resolución perfecta pero cada vez que entro a mi cuenta nada, que me cambia la resolución, y tengo que ir cada vez a nvidia-settings para cambiarlo manualmente.

Os cuento que tengo Ubuntu 8.04 y una geforce 6200 A a una resolusión de 1680 x 1050. Pero cada vez que abro la sesión se abre con una resolución de 1400 x 1050, y claro se me desajusta todo el escritorio.
os paso la sección de "screen" que tiene guardado el xorg.conf por si sirve de algo!

Section "Screen"
67 Identifier "Screen0"
68 Device "Videocard0"
69 Monitor "Monitor0"
70 DefaultDepth 24
71 Option "TwinView" "0"
72 Option "TwinViewXineramaInfoOrder" "CRT-0"
73 Option "metamodes" "1680x1050 +0+0"
74 SubSection "Display"
75 Depth 24
76 EndSubSection

Muchísimas gracias y un saludo a todos.

Jesús.

+1
0
-1

cuando la realidad no es sufiente...

Imagen de Sanguinario_Joe
+1
0
-1

Recuerda hacer un backup de tu archivo, por si la cagamos... (mira el original)

Si este es tu archivo de configuracion:

Section "Screen"
67 Identifier "Screen0"
68 Device "Videocard0"
69 Monitor "Monitor0"
70 DefaultDepth 24
71 Option "TwinView" "0"
72 Option "TwinViewXineramaInfoOrder" "CRT-0"
73 Option "metamodes" "1680x1050 +0+0"
74 SubSection "Display"
75 Depth 24
76 EndSubSection

(La proxima vez no pongas los numeritos :-D )
Deberia quedar asi:

Section "Screen"
67 Identifier "Screen0"
68 Device "Videocard0"
69 Monitor "Monitor0"
70 DefaultDepth 24
71 Option "TwinView" "0"
72 Option "TwinViewXineramaInfoOrder" "CRT-0"
73 Option "metamodes" "1680x1050 +0+0"
74 SubSection "Display"
75 Modes "1680x1050" "1400x1050" Y todas las demas que quieras
76 Depth 24
77 EndSubSection

Recuerda poner la primera la que quieras por defecto

Con esto en teoria te arreglaria dos cosas, una la resolucion por defecto, y otra es que no te cambiara solito la resolucion a la que el crea conveniente cada vez que reinicies, sino que se quedara la que tu establezcas...

Prueba a ver que tal!

Saludos y suerte!!!

+1
0
-1
Imagen de danilo_herr
+1
0
-1

La verdad es que no probe la solución que me enviaste, ya que a los 20min después de que mande este post me aparecio que habian actualizaciones disponibles, en las cuales venia un controlador xorg para mi ati e incluso la actualizacion para el kernel 2.6.24-19-generic, los aplique y solucione el problema, haciendo un analisis de esto una solucion práctica tambien seria reinstalar o instalar drivers de nuevo para la tarjeta gráfica, siempre agradezco que hayas tomado un poco de tu valioso tiempo para intentar resulver mi problema, gracias amigo.

+1
0
-1
Imagen de Sanguinario_Joe
+1
0
-1

Ayer fue dia de ayudas, y hoy de agradecimientos... :-D

Siempre me alegra se3rvir de ayuda (aunque tu caso no mucho)

Saludos!!!

+1
0
-1
Imagen de nfzambrano
+1
0
-1

Gracias sanguinario. Sirvió perfectamente con un monitor Envision H170L.

+1
0
-1
Imagen de nfzambrano
+1
0
-1

Gracias sanguinario. Sirvió perfectamente con un monitor Envision H170L.

+1
0
-1
Imagen de nfzambrano
+1
0
-1

Gracias sanguinario. Sirvió perfectamente con un monitor Envision H170L.

+1
0
-1
Imagen de nfzambrano
+1
0
-1

Gracias sanguinario. Sirvió perfectamente con un monitor Envision H170L.

+1
0
-1
Imagen de nfzambrano
+1
0
-1

Gracias sanguinario. Sirvió perfectamente con un monitor Envision H170L.

+1
0
-1