java en ubuntu x64

Imagen de cobreti
0 puntos

Buenas a todos.

Estoy intentando hacer funcionar el java 6 bajo firefox pero no encuentro manera. En synaptic solo encuentro el soporte para 32 bits y siguiendo el modo de instalarlo de la web de java solo consigo que me funcione el 1.6, el cual me dice que es obsoleto. :(.

¿Algun consejo para hacer funcionar la última versión de java?.

Muchas gracias.

Imagen de cousteau
+1
0
-1

El 1.6 y el 6 me suena que sea el mismo.

De todas formas tienes razón; acabo de mirar en Ubuntu Packages (http://packages.ubuntu.com/hardy/sun-java6-plugin) y no hay versión para 64 bits. Seguramente instalando a mano la versión para i386 (bajándote el .deb de esa página) te funciona, ya que no es más que un meta-paquete que te instala otros.


«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
+1
0
-1

«E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem» significa que dpkg se ha interrumpido y que tienes que ejecutar "sudo dpkg --configure -a" para corregir el problema.
Imagen de 1ukaz
+1
0
-1

Ok. Perdon por la ignorancia ... Como lo instalas a mano al .deb ??
Gracias.

Edito: ya lo quise instalar pero no le gusto !! :-(

sudo dpkg -i sun-java6-plugin_6-06-0ubuntu1_i386.deb
dpkg: error al procesar sun-java6-plugin_6-06-0ubuntu1_i386.deb (--install):
 la arquitectura del paquete (i386) no corresponde con la del sistema (amd64)

Con lo cual habra que esperar a que salga para 64 bits; o no instalar el plugin o instalar Ubuntu 32 :-P

+1
0
-1

--------------------------------------------------------------------------
El conocimiento le pertenece a la humanidad; no a un individuo.
Si no compartes el conocimiento, el conocimiento te parte

Imagen de patagonian18
+1
0
-1

instala icedtea. Está en Synaptic. Con eso tendrás java en firefox.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de jomaveger
+1
0
-1

Existe JSE 6 de 64 bits pero no existe plugin de Java para ningún navegador de 64 bits, ni en Linux ni en Windows, porque Sun no lo ha desarrollado. En Windows Vista lo que se hace es instalar JSE 6 de 32 bits porque automáticamente Windows instala el plugin para el IE 7 de 32 bits, ya que Vista tiene IE 7 de 32 y de 64 bits por defecto. De todos modos, como han dicho, al existir IcedTea de 64 bits, puedes instalarlo para tener plugin para el navegador de 64 bits y luego instalar JSE 6 para otras tareas si lo prefieres.

Lo que no sé es si se pueda tener, o cómo se hace, un navegador de 32 bits ejecutándose con Ubuntu de 64 bits.

Saludos.

+1
0
-1
Imagen de patagonian18
+1
0
-1

Si instalas iced-tea, te instala java en firefox. Es una implementación libre. Funciona en el 95% de los casos. Yo tengo el firefox de 64 y puedo ver la gran mayoría de los sitios java instalando ese paquete.

-------------------------------------------------------

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

+1
0
-1

 

mi blog: www.patagonianuser.blogspot.com

Ad augusta per angusta

Imagen de 1ukaz
+1
0
-1

Ok, lo tengo al icedTea, pero justo con el control remoto del LogMeIn se lleva para el carajo ....
Para todo lo demas [Aplicaciones que implementan Java, por ejemplo el Zend [que lo tengo instalado]] que se encargue el JRE :-P

+1
0
-1

--------------------------------------------------------------------------
El conocimiento le pertenece a la humanidad; no a un individuo.
Si no compartes el conocimiento, el conocimiento te parte

Imagen de cobreti
+1
0
-1

Instalé el icdtea y nada, sigue sin funcionar. ¿Conoceis otra manera para entrar en el chat de terra y similares?

Gracias.

+1
0
-1
Imagen de Teutonius
+1
0
-1

Yo tampoco puedo entrar en el chat de terra en 64 bits, y se de gente que en 32 bits tampoco. Sabeis que puede pasarP

+1
0
-1
Imagen de ketk
+1
0
-1

Pues yo puedo entrar sin problemas, tengo instalado ubuntu-restricted-extras, en este paquete se incluye java, flash, codecs, etc., etc. Para saber todo lo que incluye podéis echar un vistazo en synaptic.
Por cierto, tengo instalado 64bit.


Hay tres tipos de personas: las vivas, las muertas y las que caminan sobre el mar. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b