DNI electronico en Firefox 3.0 o 2

Imagen de monjope
0 puntos

Hola.

Pues hace un mes me compré un lector de DNI electrónico, y aunque tanto Ubuntu 7.10 como el 8.04 me lo reconocen bien, es el navegador Mozilla (tampoco Opera) el que no me reconoce el modulo de seguridad PKCS#11 que es necesario para activar el DNI y usarlo. En Win Xp no tengo ningún problema.

¿Alguien ha tenido este problema con Mozilla?

Imagen de ricreis
+1
0
-1

Funciona bien con Firefox 3. También lo probé con Firefox 2 hace tiempo. Lo que no funciona en absoluto (tampoco parece ir muy bien en Windows) son los sitios que usan Java en el proceso de la identificación.
¿Has configurado el dispositivo de seguridad?

+1
0
-1
Imagen de monjope
+1
0
-1

Yo con Windows no he tenido ningún problema en ninguno de los servicios, bueno, execpto en el de mirar el carné por puntos, que tienes razón y no me deja el Java.

¿Como se configura el dispositivo de seguridad?
Lo que hice fue bajar me de la pagina de descargas del DNI el deb del Hardy e instalarlo. Entonces me decia que era imposible instalar el modulo de seguridad, y si intento instalarlo manualmente en dispositivos de seguridad de Firefox me dice lo mismo.

Si me echaras una mano para hacer la configuración te lo agradecería ricreis.

Un saludo.

+1
0
-1
Imagen de ricreis
+1
0
-1

Lo único que te puedo decir es como lo hice yo:
En 'Dispositivos de seguridad' de Firefox le das a 'Cargar'.
El archivo del módulo es /usr/lib/opensc-pkcs11.so

Con eso ya te debería aparecer ahí un nuevo dispositivo llamado DNIe

+1
0
-1
Imagen de monjope
+1
0
-1

Gracias, pero eso ya lo habia hecho y siempre me sale el mismo mensaje: "Imposible añadir modulo".

Gracias de todos modos, y supongo que consultaré con la página del DNI a ver que me cuenta la Poli.

+1
0
-1
Imagen de oneko
+1
0
-1

A mí me daba siempre ese mensaje hasta que probé con introducir el DNI en el lector y seguidamente instalar el módulo y entonces funcionó.

+1
0
-1
Imagen de fmartagong
+1
0
-1

Hola:

Yo también tengo problemas con el Firefox 3 y el DNIe. A mi se me cuelga automáticamente en cuanto el lector lee la tarjeta.

Mediante consola y la orden:
pcsc_scan
compruebo que el lector funciona correctamente y la tarjeta la lee bien.

He probado a lanzar Firefox mediante consola para ver que error arroja y el mensaje que recibo es "Fallo de segmentación".

Si alguien puede ayudarme se lo agradecería enormemente.

Un saludo.

+1
0
-1
Imagen de niquitonipongo
+1
0
-1

Aqui os dejo un link sobre instalacion de lector de tarjetas en ubuntu.

Es para un modelo concreto, pero seguro que os aportará alguna idea a seguir para vuestro modelo de lector.

http://www.nacho-alvarez.es/?s=omnikey

Un saludo.

+1
0
-1
Imagen de yacaev
+1
0
-1

Buenas, a mí me pasa lo mismo que tu describes. Estoy utilizando:

- Ubuntu 8.04
- Firefox 3.0.8
- Lector integrado en teclado Cherry

A través de la opción de Ver certificados puedo acceder a los certificados del dnie, es a través de un applet cuando se queda colgado.

Mediante pcsc_scan compruebo que el lector funciona correctamente.

He comprobado que utilizando Opera 9.64 no se produce este problema

¿Alguien tiene alguna idea?

+1
0
-1
Imagen de neonigma
+1
0
-1

Hola, he escrito un nuevo post diferente al que hice relativo a la identificación de la tarjeta del Servicio Andaluz de Empleo. Ahora trata exclusivamente de la instalación y configuración del DNI electrónico en Ubuntu con el modelo de lector del que dispongo.

Me funciona todo sin problemas y me identifico correctamente en la página de prueba y en algunos servicios, pero tengo algún problema con los servicios que utilizan Java, tal y como comenta el usuario monjope.

El enlace por si le queréis echar un vistazo y os sirve de algo es http://www.nacho-alvarez.es/?p=371

Un saludo.

+1
0
-1
Imagen de niquitonipongo
+1
0
-1

Y si sigues las instrucciones que neonigma tiene en su blog funcionará seguro, que buena ayuda prestó tratandose del lector y tarjeta con certificado que proporcionó la Junta de Andalucía.

Un saludo.

+1
0
-1
Imagen de neonigma
+1
0
-1

Gracias, niquitonipongo. Comentarios como ese animan a todos los que formamos parte de esta gran comunidad.

Un saludo.

+1
0
-1
Imagen de macc30
+1
0
-1

En la siguiente dirección tienes la solución al problema.

+1
0
-1
Imagen de macc30
+1
0
-1

En la siguiente dirección tienes la solución al problema. http://axlinux.blogspot.com/2008/10/configuracion-del-dnie-en-firefox3-e...

+1
0
-1
Imagen de joimerus
+1
0
-1

hola
este es mi primer post. soy un orgulloso recién usuario de ubuntu netbook remix.
he podido solucionar mi problema con el lector de dni-e.
mi problema era que despues de instalar el paquete .deb en firefox 3 me decía el mismo mensaje "no reconoce el modulo de seguridad PKCS#11"
mi lector es un LTC31 USB
me dirigí a su web: http://www.c3po.es (made in Spain) y allí encontré esto:

Configurar LTC3x USB v2 en GNU/Linux

Los lectores LTC31 USB v2 y LTC32 USB v2 son compatibles con el driver genérico ccid disponible en cualquier distribución de GNU/Linux, en sus distintas versiones de kernel con soporte para USB (2.4 y 2.6).

Para que el driver reconozca el lector, será necesario modificar del fichero de configuración (Info.plist) de los lectores soportados por defecto. Esta modificación consiste en añadir el identificador de fabricante (Vid) y de producto (Pid) del lector al fichero.

Previamente a la modificación, será necesaria la instalación de los siguientes paquetes:

1. ccid
2. pcsc-tools

Una vez estén instalados los paquetes, será necesario modificar el fichero de configuración. Este fichero es Info.plist y se encuentra en la ruta /usr/lib/pcsc/drivers/ifd-ccid.bundle/Contents.

En la sección ifdVendorID, se deberá añadir otro identificador de C3PO 0x0783 debajo del ya existente

ifdVendorID

[...]
0x0783
0x0783

Si se dispone de un lector LTC31, en la sección ifdProductID, se deberá añadir el identificador del lector 0x0006 debajo del ya existente 0x0003.
ifdProductID < /key>

[...]
0x0003
0x0006

En el caso de disponer de un LTC32, el identificador del lector que se debe añadir es 0x0010.
ifdProductID < /key>

[...]
0x0003
0x0010

Por último, en la sección ifdFriendlyName, se deberá añadir el nombre del lector correspondiente LTC31USBv2 o LTC32USBv2 debajo del ya existente LTC31
ifdFriendlyName

[...]
LTC31
LTC31USBv2

Una vez realizados estas modificaciones, el lector será correctamente detectado por el driver.

la verdad es que lo único que hice fue instalar:
1. ccid
2. pcsc-tools

desde el Gestor de Paquetes Synaptic y funcionó.

Espero haber servido de ayuda a este foro al que tanto le debo.

+1
0
-1
Imagen de Ebeldur
+1
0
-1

En 8.10 instalé el lector con las instrucciones de Neonigma. Pues bien, en 9.04 tengo problemas. He instalado los programas como en 8.10, pero no me funciona de ninguna manera, al intentar comprobar que el DNI funciona me sale una página de error que dice que no se puede comprobar la veracidad.

Mi página personal:

http://franyv.wordpress.com/

+1
0
-1

Mi página personal:

http://franyv.wordpress.com/

Imagen de rsg75
+1
0
-1

A mi me pasa lo mismo. He instalado Lucid Lynx y el lector me funciona bien y me reconoce los certificados del DNIe, pero si lo tengo instalado el Firefox no me abre las páginas, se queda en modo descarga continua. Tampoco me deja ver los certificados ni abrir los dispositivos de seguridad. Vamos lo que se dice un señor cuelgue.

+1
0
-1