El apt-get no me coge los paquetes

Imagen de lagunalore
0 puntos

Hola, pues eso, no me funciona, he puesto el sudo apt-get y todo lo demás y me coge la contraseña, pero luego me dice:

E: Error. No existe el paquete kate, eso quiere decir que no está en el cd?? A alguien le ha pasado lo mismo??

Gracias!!

Imagen de Ardanbis
+1
0
-1

Pero si te as a Sistema\Administración\Origenes de software e habilitas(check) los main, universe, restricted y multiverse a lo mejor te funciona.

sudo apt-get update
sudo apt-get install kate

De hecho yo lo he probado y se me instaló sin hacerme esa pregunta: ¿Desea instalar (y/n)?



Linux#466973;Ubuntu#20815;Debian#100;Ante el error: 
dpkg was interrupted... debes ejecutar en una terminal: 
sudo dpkg --configure -a
+1
0
-1
Imagen de elgatogordo
+1
0
-1

¿estas usando kubuntu?
kate es el editor de textos del escritorio kde, si usas ubuntu en lugar de kate lo que tienes es gedit

www.offtopiqueando.foroactivo.com

+1
0
-1
Imagen de ZoeDoGaM
+1
0
-1

Hombre, puedes utilizar kate a pesar de tener gnome, pero claro, consumirás más recursos del pc y tendrás un puñado más de librerías :P
Saludos.

+1
0
-1
Imagen de elgatogordo
+1
0
-1

como poder claro que puede, el tema es que si usa kubuntu deberia tenerlo instalado, y si usa ubuntu no se si viene incluido en los paquetes del cd

www.offtopiqueando.foroactivo.com

+1
0
-1
Imagen de Ardanbis
+1
0
-1

Osea que es un editor de texto. Pero de todos modos utilizo "gnome" y me da error al arrancar:
root@ardanbis-desktop:~# kate
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permiso denegado
trying to create local folder /home/root/.kde/share: Permission denied
trying to create local folder /home/root/.kde/share: Permission denied
trying to create local folder /home/root/.kde/share: Permission denied
trying to create local folder /home/root/.kde/socket-ardanbis-desktop: Permission denied
trying to create local folder /home/root/.kde/socket-ardanbis-desktop: Permission denied
kdeinit: Aborting. bind() failed: : Permission denied
Could not bind to socket '/home/root/.kde/socket-maggy/kdeinit__0'
KCrash: Application 'kate' crashing...
Warning: connect() failed: : Permiso denegado
KCrash cannot reach kdeinit, launching directly.
root@ardanbis-desktop:~#
Es una broma, en realidad es una incongruencia. Leed los errores con atención y os darís cuenta de cosas raras. xD

Como iba yo a ejecutar como administrador una aplicación que nisiquiera conozco. xD


Linux#466973;Ubuntu#20815;Debian#100;Ante el error:
dpkg was interrupted... debes ejecutar en una terminal:
sudo dpkg --configure -a

Desvarios varios:
ardanbis@ardanbis-desktop:-$fakeroot /bin/bash
root@ardanbis-desktop:-#whoami
+1
0
-1
Imagen de elgatogordo
+1
0
-1
Imagen de lagunalore
+1
0
-1

si el caso es que el sudo apt-get no me coge nada, porque también he querido instalar el compilador de c++ y me dice lo mismo, E: no se encuentra el paquete, después de haber cogido bien la contraseña y eso. No puede ser que el compilador de c++ no esté en ubuntu 8 no?? Seguiré probando pero a ver si alguien sabe qué pasa. Un saludo!!

+1
0
-1
Imagen de joseluis
+1
0
-1

El compilador de C++ sí está en Ubuntu 8.04 (y anteriores) como puedes comprobar aquí.
¿Qué repositorios tienes activos?
¿Estás ejecutando Ubuntu desde el LiveCD o realmente lo tienes instalado?

Por cierto, modifica el título de este hilo (No me funciona el kate) porque obviamente tu problema no es que no te funcione el kate si no que no puedes instalar ciertas aplicaciones porque no te las encuentra apt.


Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de lagunalore
+1
0
-1

Ya está cambiado el título. El ubuntu lo tengo instalado, y lo de los repositorios no entiendo lo que es. Además, bibliotecas como stdio.h no me las coge tampoco el compilador, cómo puedo hacer para instalar todo esto?? No hay una pantalla como en la suse en la que se podían seleccionar los paquetes a instalar?? Gracias!!

+1
0
-1
Imagen de joseluis
+1
0
-1

Para instalar en modo gráfico tienes synaptic (Sistema -> Administración -> Gestor de Paquetes Synaptic). Echa también un vistazo a Instalar aplicaciones en la documentación de Ubuntu-es.

Para entender lo que son los repositorios, echa un vistazo a este Repositorios desde Ubuntu (también en la documentación de Ubuntu-es).


Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de lagunalore
+1
0
-1

Y en el gestor de paquetes synaptic, todo me viene como instalado, no hay ningún paquete que no esté instalado, y además está instalado el gcc, pero aún así no me funcionan las bibliotecas stdio.h, mem.h, stdlib.h, ninguna vamos, sabes que podría hacer? igual bajar de internet un repositorio con estas bibliotecas?? gracias!!

+1
0
-1
Imagen de joseluis
+1
0
-1

Instala el paquete build-essential y te instalará automáticamente todo lo que necesitas para compilar C y C++.


Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de lagunalore
+1
0
-1

Ya me he bajado el paquete build-essential de internet, concretamente build-essential_11.1.tar, lo he descomprimido pero me encuentro un montón de archivos y un install que no se ejecuta. Qué tengo q hacer para finalmente instalar el paquete?? hacer un sudo con todos o con uno en concreto?? Gracias!!

+1
0
-1
Imagen de medu69
+1
0
-1

Para qué te bajas de internet un paquete que tienes en los repositorios de Ubuntu? no te tenías que haber bajado nada se abría instalado con un:
sudo aptitude install build-essential
Has leído la documentación que te pasó Jose Luis?? porque creo que no, si lo has hecho no has entendido mucho creo.

+1
0
-1

Visita: <a href="http://www.guia-ubuntu.org/index.php?title=Portada">Guía Ubuntu</a>

Imagen de lagunalore
+1
0
-1

si lo he leído hombre, lo que pasa que me he bajado el paquete porque no tengo internet en linux y el sudo no me funciona, eso que has escrito tú tampoco funciona parece que hay q estar conectado a internet para que se instalen las cosas. Alguien sabe qué tengo q hacer con el paquete que me he bajado? Gracias!

+1
0
-1
Imagen de joseluis
+1
0
-1

Descargate el paquete .deb de los repositorios de Ubuntu.
Si accedes a esa web puedes buscar el paquete que te interese (selecciona antes la versión de Ubuntu que tengas). Por ejemplo para Ubuntu 8.04 buscando build-essential llegas a aquí. Y pinchando sobre el enlace del paquete te saldrá información del mismo junto a las dependencias (paquetes que te tendrás que bajar también pues si no no se instalará build-essential). Abajo de la página donde pone Download build-essential tienes los enlaces para bajar el .deb (según la arquitectura de tu máquina).

Según pone en esa página tendrás que bajarte también dpkg-dev, g++, gcc, libc6-dev o libc-dev y make (además de las dependencias de cada uno de esos paquetes), aunque es posible que algunos de esos paquetes ya los tengas.
Ya se que es pesado, pero ten en cuenta que eso te lo haría automáticamente las herramientas de instalación (apt, aptitude o synaptic) si tuvieras conexión a internet desde GNU/Linux.
Para hacer todo esto te puede ayudar sacar antes desde Ubuntu una lista de los paquetes instalados y tenerla accesible en el ordenador desde el que te conectas a internet, así cuando miras las dependencias, lo único que tendrías que hacer es mirar antes si el paquete está en la lista y únicamente descargarlo si no lo encuentras.

Edito: Se me olvidaba, una vez tengas todos los paquetes descargados (descargalos sobre un directorio en el que no tengas otros paquetes .deb) para instalarlos lo único que tendrías que hacer es abrir un terminal cambiarte al directorio donde tengas los paquetes e instalarlos con sudo dpkg -i *.deb. Si te has bajado todo lo que necesita te lo instalará sin problemas, como mucho a lo mejor da un error de configuración porque no lo haya instalado en el orden apropiado, pero si te dice algo de eso con un sudo dpkg --configure -a se debería solucionar.


Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de lagunalore
+1
0
-1

gracias por tu tiempo, he seguido tus instrucciones pero algunos de los paquetes requerían de otros, me los he ido bajando, pero me he encontrado con que dos paquetes que tengo que instalar dependen mutuamente de sí mismos, uno me dice que necesita el otro para instalar, y el otro me dice que necesita el uno para instalar, y no puedo seguir adelante, ya no sé que hacer, estoy por desistir, porque entre medias he intentado instalarle otra vez internet con el módem pero el modemscan me hace un fichero de texto muy enrevesado y no sé que tipo de módem tengo, en fin, si alguien sabe algo sino no sé ya que hacer... Por cierto, estos dos paquetes son "libstdc++6-4.2-dev" y "g++-4.2-4.2.3-2ubuntu7-i386". Un saludo!!

+1
0
-1
Imagen de Ardanbis
+1
0
-1

Mira, si tienes un problema en concreto deberías postear la duda que tienes, en otro hilo y especificar todos los detalles en ese hilo como por ejemplo:
Modem tal no funciona
y luego en el hilo especificas marca y modelo del modem, los componentes de tu pc con las que se conecta, usb u cable directo al modem, si es modem interno, que has intentado hacer para solucionarlo.

Nosotros no podemos leerte la mente para saber que te ocurre y tampoco podemos sacarte la información a patadas.

Y ademas, mira un miembro de la comunidad (me parece que lauchacba) incluso tiene una página en internet para configurar módems:

http://ar.geocities.com/novatocba/

Adémas linux es una asignatura de libre elección. :P

Ubuntu comes with no warranty. (Traducción: Ubuntu viene sin warantia.) ;)


static long metodo_para_obtener_un_numero_aleatorio(long x,double y){
/*Está linea de código la inutilizamos. . .
     x= y*Math.random();
. . .para depurar mejor el programa*/
     x=9;
  return x;}

¡Aleatoriedad asegurada!

+1
0
-1
Imagen de lagunalore
+1
0
-1

vale vale, ya no digo na, sólo quería contar lo que había hecho. Y eso de que es de libre elección nada de nada, si yo pudiera windows a muerte pero en informática nos obligan a programar casi siempre en linux así que hay que tragar :P

+1
0
-1
Imagen de Ardanbis
+1
0
-1

Por cierto si tienes TODOS los paquetes que son necesarios para una instalación tendrás que ponerselo mas a huevo a Ubuntu porque tiene un poco de "amnesía" aunque tengas los paquetes, si no se los metes a patadas en la cache el no se dará cuenta que los tiene.

He tenido que comerme el coco un poco para darme cuenta yo tambien de esta parida. Supongamos que tienes los paquetes preparados para la instalación en el escritorio: doble click en "libstdc++6-4.2-dev" y te pide "g++-4.2-4.2.3-2ubuntu7-i386", doble click en "g++-4.2-4.2.3-2ubuntu7-i386" y te pide "libstdc++6-4.2-dev" pues allá va como hacerselo saber.
Abres una terminal. Aplicaciones\Accesorios\Terminal y haces lo siguiente:

cd ~                         (Así te fijas en tu directorio personal)
cd Escritorio                (Así te metes en la carpeta del escritorio que hay en tu carpeta personal o si no funciona utilizas cd Desktop.)
sudo su                      (Para adquirir privilegios de administrador, escribes tu contraseña aunque no aparezcay pulsas intro, cuidado utiliza privilegios de administrador "root" SOLO si es necesario como en este caso.)
cp -uv *.deb /var/cache/apt/archives/       (Así copias todos los archivos que acaban en ".deb" a la cache de Ubuntu.)
cd /var/cache/apt/archives/        (Accedes a la cache de Ubuntu.)
apt-get update                     (Le haces recordar que tiene los paquetes.Esta vez no hace falta "sudo" porque ya eres administrador.)
ls                                 (Te enseña los paquetes.)
dpkg -i libstdc++6-4.2-dev.deb     (Instala el paquete en sí y esta vez también encontrará el otro. Dices que si a todo, y si dice que no sé ha encontrado paquete tal es porque el paquete ese no lo has metido en la caché.)
exit                               (Te quita los privilegios de administrador.)
exit                               (Cierra la terminal.)

Suerte.


Cuidado apt-get funciona SOLO con paquetes deb, (de Debian la madre de Ubuntu) si metes en la cache otra clase de paquetes como ".tar.gz" , ".tgz" o ".rpm" no sabrá que hacer con ellos.

Aunque si que existe una aplicación que se llama "alien" (como la pelicula) que transforma algunos paquetes en deb. Asin:
sudo alien -d foo.tgz donde "foo.tgz" es el paquete que quieres transformar.
sudo alien -d foo.rpm lo mismo.

De momento esa aplicación creo que no funciona con archivos ".tar.gz"


static long metodo_para_obtener_un_numero_aleatorio(long x,double y){
/*Está linea de código la inutilizamos. . .
     x= y*Math.random();
. . .para depurar mejor el programa*/
     x=9;
  return x;}

¡Aleatoriedad asegurada!

+1
0
-1
Imagen de lagunalore
+1
0
-1

Weno, ya he conseguido que funcione, no era exactamente como decías pero me dio la idea, la cosa era instalar los dos paquetes a la misma vez, uno detrás de otro así sí te los coge, y ya por fin puedo compilar, después de 1 día y medio perdido jeje. Muchas gracias a todos los que me habéis ayudado, ya se puede cerrar este post.

+1
0
-1
Imagen de Ardanbis
+1
0
-1

Mira si quieres instalarte algo y no tienes internet lo mejor es que te metas SOLO en estas 2 páginas:
http://packages.ubuntu.com/
y
http://getdeb.net/
Allí te metes buceas un rato porque la verdad es que te daras cuenta que el primer sitio es bastante "enorme", te buscas lo que quieres, te lo bajas a un disquette/pen drive/disco duro externo/cd te lo llevas a tu ordenador, lo copias en el escritorio le das doble click metes la contraseña de administrador(tu contraseña) y ya está.

Atención, algunos paquetes necesitan otros para funcionar, eso se llama dependencia, y durante la instalación te dirá exactamente lo que necesitas instalar, para que en conjunto funcione.


static long metodo_para_obtener_un_numero_aleatorio(long x,double y){
/*Está linea de código la inutilizamos. . .
     x= y*Math.random();
. . .para depurar mejor el programa*/
     x=9;
  return x;}

¡Aleatoriedad asegurada!

+1
0
-1