No se puede montar el volumen

Imagen de yeayu
0 puntos

Hola:
Estoy intentando conectar mi mp3 (creative muvo) a ubuntu, pero por no se cual motivo me sale un mensaje diciendome:

No se puede montar el volumen
Opcion de montaje invalida al intentar montar el volumen

He intentado volver a windows para quitarlo con seguridad, pero ni aún así.

¿Que puedo hacer?

Un saludo

Imagen de BlouBlou
+1
0
-1

Instalate los controladores del mp3 con el wine y nos cuentas.

Menuda chapuza que te he mandado hacer, pero intenta, mas que quitarlo luego. XD

+1
0
-1
Imagen de barlovento
+1
0
-1

Con la información que aportas dificilmente se te puede ayudar.

-Modo de conexión
-Distribución que usas

Todos los datos que puedas aportar son de ayuda para ver qué ocurre.

Si el modo de conexión es por USB, escribe en el terminal

lsusb

copia y pega la salida.

Saludos

+1
0
-1

Utilizar el buscador es un sano ejercicio

Imagen de yeayu
+1
0
-1

Utilizo Ubuntu 8.04

El mp3 lo conecto por usb.
Esta es la salida de lsusb

chechu@chechu-laptop:~$ lsusb
Bus 005 Device 005: ID 041e:4129 Creative Technology, Ltd
Bus 005 Device 002: ID 046d:0896 Logitech, Inc.
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

+1
0
-1
Imagen de helius2
+1
0
-1

Arrancas con el mp3 conectado o lo conectas luego de arrancar?
Prueba a arrancar el pc con el conectado y nos cuentas.

+1
0
-1
Imagen de yeayu
+1
0
-1

He arrancado con él conectado y tengo el mismo problema

+1
0
-1
Imagen de gotxa
+1
0
-1

Me pasaba algo parecido con un Ipod-nano.
Lee
http://www.ubuntu-es.org/index.php?q=node/88522
para saber cómo averiguar esa opción no correcta en el montaje.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de yeayu
+1
0
-1

He leido el post y esto es la salida de:

chechu@chechu-laptop:~$ gnome-mount -vtd /dev/sdb1
gnome-mount 0.8
** (gnome-mount:6999): DEBUG: Mounting /org/freedesktop/Hal/devices/volume_part1_size_513512960
El dispositivo /dev/sdb1 está en /etc/fstab con punto de montaje «/media/cdrom0»
** Message: /bin/mount said error 8192, stdout='', stderr='mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
missing codepage or helper program, or other error
En algunos casos se encuentra información en syslog, pruebe
dmesg | tail o algo parecido

+1
0
-1
Imagen de barlovento
+1
0
-1

con sudo fdisk -l
Tu dispositivo sdb1 es el cd rom y el que nos interesa es:

.......

+1
0
-1

Utilizar el buscador es un sano ejercicio

Imagen de gotxa
+1
0
-1

como te dice el sistema, en tu caso /dev/sdb1 es tu CD-DVD y debes cambiarlo por el del mp3. ¿Cuál es en tu caso? pues no se a priori...

Inserta el dispositivo y haz

$ sudo fdisk -l

te listará los dispositivos insertados (montados o no), uno de ellos debe ser tu volumen de almacenamiento mp3.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de yeayu
+1
0
-1

aqui teneis la salida de fdisk -l

Disco /dev/sda: 120.0 GB, 120034123776 bytes
255 cabezas, 63 sectores/pista, 14593 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0xb8f0ffa4

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 2 2822 22659682+ f W95 Ext'd (LBA)
/dev/sda2 * 2823 6646 30716280 c W95 FAT32 (LBA)
/dev/sda3 6647 7177 4265257+ 82 Linux swap / Solaris
/dev/sda4 7178 14593 59569020 83 Linux
/dev/sda5 2 2822 22659651 7 HPFS/NTFS

Disco /dev/sdb: 513 MB, 513540096 bytes
32 cabezas, 48 sectores/pista, 653 cilindros
Unidades = cilindros de 1536 * 512 = 786432 bytes
Identificador de disco: 0x39fa710f

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 * 1 653 501477+ e W95 FAT16 (LBA)

Creo que mi mp3 es el sdb no?
Bueno suponiendo que es ese aquí adjunto la salida:

chechu@chechu-laptop:~$ gnome-mount -vtd /dev/sdb
gnome-mount 0.8
** Message: La unidad /dev/sdb no contiene ningún soporte.

+1
0
-1
Imagen de barlovento
+1
0
-1

de que no lee nada en el soporte.
Los motivos pueden ser muchos. El más tonto es no conectar el mp3, si está apagado no leerá nada.
Puede ser por faltar algún codec.
Simplemente que no reconozca el dispositivo y si es así más arriba recomendaron instalar los drivers
con wine. Podría funcionar pero no lo he intentado nunca así que no puedo ayudar. Otra vez será.

Saludos y suerte.

+1
0
-1

Utilizar el buscador es un sano ejercicio

Imagen de gotxa
+1
0
-1

parece que si, que sdb1 es tu dispositivo mp3 pero a la vez es el detectado como CD... eso es bastante extraño... antes de más acciones a ciegas, mejor recopilar más info.

Conecta el dispositivo y, tras un par de segundos o tres haces en la consola:

$ dmesg

como el resultado es largo, postealo en http://paste.ubuntu.com y el enlace que te dé lo posteas aquí, así este hilo se queda limpio. Esta instrucción muestra los mensajes del núcleo y es de suponer que te dirá qué pasa con el dispositivo.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de yeayu
+1
0
-1

En uno de mis intentos para que empezase a funcionar, actualicé el firmware del mp3 desde windows, y ha dejado de funcionar.. no se enciende, al conectarlo ni windows ni ubuntu lo detecta..

Estaba ya muy baqueteado pero me servía..:(

+1
0
-1
Imagen de gotxa
+1
0
-1

Con respecto al pingüino, nada ha cambiado hasta que no hagas las comprobaciones adecuadas. A veces basta con formatear. Es verdad que cambiar el firmware no es moco de pavo pero yo probaría varias opciones antes de tirarlo... más de una sorpresa ha habido. Por lo pronto, conectalo y haz un dmesg como te dije antes. También haz un lsusb antes y después de conectarlo y compara lo que te dice.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de yeayu
+1
0
-1

Acabo de actualizar correctamente el firmware y ha vuelto a la normalidad; pero sigo teniendo el mismo problema en ubuntu.
Aquí está el link de dmesg:
http://paste.ubuntu.com/32589/

Ya me contais

+1
0
-1
Imagen de gotxa
+1
0
-1

el sistema te detecta tu Creative MuVo V200 pero lo intenta montar en /dev/sdb1, que según parece por tus comentarios anteriores también es el CD-DVD... por eso no lo monta quejándose en la línea 496.

Vas a probar una cosilla fácil... con el mp3 quitado, edita /etc/fstab (como root)

$ gksu gedit /etc/fstab

y comenta la línea del CD poniendo un # delante (hará que no se interprete dicha línea). Guardas el archivo y conectas el mp3.

Posteas resultados. Te lo debe montar. Date cuenta que el CD-DVD no te pitará hasta que no dejes esa línea como estaba.

Si no te lo monta, vuelve a postear dmesg como antes.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de Flypp
+1
0
-1

Saludos, apenas llevo una semana con Ubuntu y también he tenido el mismo problema (no se puede montar volumen-> cambios en el fstab-> se monta pero no tengo permisos de escritura,... y etc).

La solución es bien sencilla, y hasta ahora me ha funcionado con todos los dispositivos de almacenamiento usb (pendrive Sandisk U3, Pendrive Kingston Travel y MP3 HP).

Lo principal es identificar correctamente tu dispositivo. Yo utilicé Sistema>Administración>Editor de particiones (si no lo tienes instalado, pídeselo a San Synaptic).

Una vez reconocida la partición de tu dispositivo (en mi caso me la detecta como dev/sdb1) extraemos el dispositivo y editamos el fstab desde la terminal con privilegios de administrador:

sudo gedit /etc/fstab

Ahora viene lo curioso: Si encuentras una linea que se corresponde con tu dispositivo bórrala.

Sí, sí... como lo oyes. Recuerda siempre que antes de hacer cualquier cambio debes guardar una copia de seguridad (copias todo el texto del fstab y lo pegas en un fichero de texto plano).

Una vez borrada la linea, cierras el fstab y guardas los cambios.

Lo siguiente que deberás hacer es simplemente volver a insertar tu dispositivo y dejar que se te dibuje una sonrisa en la cara (a menos que no te funcione, en tal caso desahógate y cantame las cuarenta).

Un saludo.

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

+1
0
-1

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

Imagen de chikijulio
+1
0
-1

despues de tres dias leyendo foro tras foro e hilo tras hilo, y hacer mil y una cosa.... vienes tu y me dices q solo era borrar la linea del fstab. Que baje Dios y lo vea jajajaja.... me rio por no llorar de verdad.... muchisimas gracias... de verdad. me he registrado solo para darte las gracias... ya q no suelo postear, solo leer... pero la ocacion lo merecia. gracias de nuevo, por q con personas como tu se hace mas grande gente como yo.

+1
0
-1

lo fisico es efimero, cultiva la mente....

Imagen de Flypp
+1
0
-1

Saludos, apenas llevo una semana con Ubuntu y también he tenido el mismo problema (no se puede montar volumen-> cambios en el fstab-> se monta pero no tengo permisos de escritura,... y etc).

La solución es bien sencilla, y hasta ahora me ha funcionado con todos los dispositivos de almacenamiento usb (pendrive Sandisk U3, Pendrive Kingston Travel y MP3 HP).

Lo principal es identificar correctamente tu dispositivo. Yo utilicé Sistema>Administración>Editor de particiones (si no lo tienes instalado, pídeselo a San Synaptic).

Una vez reconocida la partición de tu dispositivo (en mi caso me la detecta como dev/sdb1) extraemos el dispositivo y editamos el fstab desde la terminal con privilegios de administrador:

sudo gedit /etc/fstab

Ahora viene lo curioso: Si encuentras una linea que se corresponde con tu dispositivo bórrala.

Sí, sí... como lo oyes. Recuerda siempre que antes de hacer cualquier cambio debes guardar una copia de seguridad (copias todo el texto del fstab y lo pegas en un fichero de texto plano).

Una vez borrada la linea, cierras el fstab y guardas los cambios.

Lo siguiente que deberás hacer es simplemente volver a insertar tu dispositivo y dejar que se te dibuje una sonrisa en la cara (a menos que no te funcione, en tal caso desahógate y cantame las cuarenta).

Un saludo.

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

+1
0
-1

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

Imagen de gotxa
+1
0
-1

es lo que se le ha dicho que haga a grandes rasgos, sólo que el dispositivo a insertar se detecta como la misma partición que su unidad de CD/DVD y, en vez de borrar la línea de /etc/fstab, más bien comentarla para que sea fácil volver a la situación inicial.

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de Flypp
+1
0
-1

Saludos, apenas llevo una semana con Ubuntu y también he tenido el mismo problema (no se puede montar volumen-> cambios en el fstab-> se monta pero no tengo permisos de escritura,... y etc).

La solución es bien sencilla, y hasta ahora me ha funcionado con todos los dispositivos de almacenamiento usb (pendrive Sandisk U3, Pendrive Kingston Travel y MP3 HP).

Lo principal es identificar correctamente tu dispositivo. Yo utilicé Sistema>Administración>Editor de particiones (si no lo tienes instalado, pídeselo a San Synaptic).

Una vez reconocida la partición de tu dispositivo (en mi caso me la detecta como dev/sdb1) extraemos el dispositivo y editamos el fstab desde la terminal con privilegios de administrador:

sudo gedit /etc/fstab

Ahora viene lo curioso: Si encuentras una linea que se corresponde con tu dispositivo bórrala.

Sí, sí... como lo oyes. Recuerda siempre que antes de hacer cualquier cambio debes guardar una copia de seguridad (copias todo el texto del fstab y lo pegas en un fichero de texto plano).

Una vez borrada la linea, cierras el fstab y guardas los cambios.

Lo siguiente que deberás hacer es simplemente volver a insertar tu dispositivo y dejar que se te dibuje una sonrisa en la cara (a menos que no te funcione, en tal caso desahógate y cantame las cuarenta).

Un saludo.

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

+1
0
-1

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

Imagen de Flypp
+1
0
-1

No sé que ha pasado. Se han publicado un montón de posts. Admin, yo no puedo borrarlos. Si el administrador puede hacerlo se lo agradecería. Perdón por la chapuza chicos.

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

+1
0
-1

Un hombre con un reloj siempre sabrá la hora que es. Uno con dos relojes nunca estará seguro.

Imagen de yeayu
+1
0
-1

Hola:
como me dijisteis comenté la linea del cd en el archivo /etc/fstab y ya el mp3 se monta perfectamente.
Me gustaría saber como solucionarlo, ya que puedo montar el mp3 pero al tener comentada esa línea el cd no lo puedo utilizar.
Un saludo y gracias

+1
0
-1
Imagen de gotxa
+1
0
-1

¿nos pones qué tienes en /etc/fstab?
y mientras leo por ahí

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto

Imagen de yeayu
+1
0
-1

# /etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
# /dev/sda4
UUID=8ef865b7-c412-4af7-b74a-c7a8044e6d8e / ext3 relatime,errors=remount-ro 0 1
# /dev/sda3
UUID=b9f54066-b2fa-4fdd-974f-99b536b041d1 none swap sw 0 0
#/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd0 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

el sdb1 lo tengo comentado para poder conectar el mp3

+1
0
-1
Imagen de gotxa
+1
0
-1

cuando conectas otro dispositivo USB de almacenamiento (disco duro, memoria), ¿te pasa lo mismo? O sea, ¿esto te ha ocurrido sólo con este mp3 en concreto?

P.D. Asumo que ciertamente tienes 2 unidades de CD/DVD ¿correcto?

EDITADO: aparte de las 2 cuestiones anteriores, proporciona por este orden,

  • con el mp3 puesto:
    $ gnome-mount -vtd /dev/sdb1
    $ sudo blkid
    $ ls -l /dev/disk/by-path/
    
  • con el mp3 quitado, restaurado /etc/fstab a como estaba, con un CD puesto y montado:
    $ ls -l /dev/disk/by-path/
    

Lecturas [no] de almohada:
http://ubuntuforums.org/showthread.php?t=236230
https://wiki.ubuntu.com/DebuggingRemovableDevices
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/36846

GoTXa
linux counter #116453
Si cree que la capacitación es cara, pruebe con la ignorancia.

+1
0
-1

GoTXa
linux counter #116453
Klaatu barada nikto