Xubuntu no se apaga

Imagen de Stendhal
0 puntos

Hola, mi problema es que Xubuntu no me apaga el ordenador. Cuando le doy a apagar, cierra la sesión, ace todo e incluso se nota el sonido que hace antes de apagarse (por lo menos mi ordenador) y se iluminan las luces del teclado (como cuando se apaga), pero sigue encendido y tengo que apagarlo manualmente. Tengo WindowsXP en otra partición, y me lo apaga sin problemas, pero Xubuntu no.

Imagen de PabliNet
+1
0
-1

Entrá a la consola o el terminal e ingresá:

sudo halt

El comando halt es para apagar la PC y reboot para reiniciar.

Con deseos de Paz
Pablo Alejandro

+1
0
-1

"No hay nada más hermoso que hacer algo por alguien,
y no hay nada más tonto que no hacer nada por nadie".
León Gieco®

Veni veni canta conmigo
que un amigo vas a encontrar,
que de la mano de Google
tus problemas vas a solucionar.

Imagen de Stendhal
+1
0
-1

SI le doy a sudo Halt se empieza a apagar pero se queda en la pantalla de carga con el logo de Xubuntu en medio, se queda parado y ay no tira.

+1
0
-1
Imagen de PabliNet
+1
0
-1

+1
0
-1

"No hay nada más hermoso que hacer algo por alguien,
y no hay nada más tonto que no hacer nada por nadie".
León Gieco®

Veni veni canta conmigo
que un amigo vas a encontrar,
que de la mano de Google
tus problemas vas a solucionar.

Imagen de conanrealm
+1
0
-1

Yo he tenido el problema del apagado durante mucho tiempo y estuve como como loco probando todas esas soluciones para el ACPI y no habia manera, al final un dia me encontre con que el problema era un modulo de sonido de intel HDA que no se cerraba bien o algo asi. Te copio la solucion que encontre por alguna pagina que no logro localizar ahora (menos mal que me lo guarde en el correo XD). Son dos soluciones, la segunda segun dice es un poco mas limpia, aunque tampoco hay mucha diferencia, la solucion en principio es para un Eeepc pero si te fijas tiene que funcionar igual en cualquier pc con este problema (en mi Pentium IV funciona), incluso puedes usar los mismos nombres, copy-paste y ale tirando:

Fixing the shutdown hardy (may work on older versions of ubuntu)

When you install, Ubuntu doesn't shut down properly. Shutting down your Eee will make the screen turn off, but does not cut the power. So

Add: rmmod snd_hda_intel

at the beginning of the /etc/init.d/halt script in order to make the Eee shutdown properly.

A slightly cleaner solution

* Open a new terminal window,
* Create a new script as /etc/init.d/eeepc, for example with the command

sudo nano /etc/init.d/eeepc

* Add the following contents to the script (use ctrl+o to save, ctrl+x to exit nano):

#!/bin/bash
case $1 in
stop)
rmmod snd-hda-intel
;;
*)
esac

* Make it executable

sudo chmod +x /etc/init.d/eeepc

* Now in /etc/rc0.d (scripts run at shutdown), create a symbolic link named K60eeepc, pointing to ../init.d/eeepc

By renaming the symbolic link, one can control exactly when the module is removed.

sudo ln -s /etc/init.d/eeepc /etc/rc0.d/K60eeepc

That script can also be used for running other Eee-specific stuff at startup, shutdown...

Pressing on the shutdown button should now power off completly the Eee Pc.

Espero que esto te ayude a ti o a alguien mas que ande buscando la solucion a este problema y no se vuelva loco buscando como yo XD

+1
0
-1