Xubuntu no reconoce el segundo disco duro (Solucionado)

Imagen de Cuajoman
0 puntos

Hola a todos.
Es la primera vez que me atrevo a plantear un problema en estas páginas, ya que hasta ahora las dificultades con las que me encontraba las solucionaba con la gran ayuda de San Google, pero en este caso no he podido encontrar nada, por eso recurro a vosotros. Mi problema es el siguiente:
Tengo un PIII 700 con 313,1 Mb de memoria ram, un disco duro de 40 Gb en el que tengo tres particiones, una de 11,72 Gb para raíz, otra de 23,59 Gb para home, y otra de 1,95 Gb para swap, también tengo instalado otro disco duro de 40 Gb formateado como ext3 y que utilizo para almacenar diferentes datos. Hasta ahora venía utilizando Ubuntu con Gnome sin problema, lo reconocía todo, pero como el sistema iba un poco lento decidí cambiar el escritorio a Xubuntu, procedí a hacer una instalación limpia y, después de instalar el idioma y las actualizaciones, mi sorpresa fue que no existía mi segundo disco duro; intenté arreglarlo con las soluciones que aportabais a otros casos parecidos al mío pero sin ningún resultado, por eso espero que me ayudéis en mi problema.

Esta es mi configuración haciendo "fdisk -l"

Disco /dev/sda: 40.0 GB, 40020664320 bytes
255 cabezas, 63 sectores/pista, 4865 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x7b466f5c

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 1530 12289693+ 83 Linux
/dev/sda2 1531 4610 24740100 83 Linux
/dev/sda3 4611 4865 2048287+ 82 Linux swap / Solaris

Disco /dev/sdb: 40.0 GB, 40020664320 bytes
255 cabezas, 63 sectores/pista, 4865 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x433b6583

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 1 4865 39078081 83 Linux

Y esta es el contenido del archivo fstab

# /etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
# /dev/sda1
UUID=64acf1f2-c383-4c7a-a392-f48ab48f14fc / ext3 relatime,errors=remount-ro 0 1
# /dev/sda2
UUID=5b923d69-e614-4629-a32c-1ba77aab200a /home ext3 relatime 0 2
# /dev/sda3
UUID=60b80b78-25d4-491f-9230-d003420a1af5 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

Sin más, y agradeciendo de antemano, recibid un cordial saludo.

Imagen de Gabriel_M
+1
0
-1

Hola cua...:
1) Crea el directorio donde montaras la partición por ejemplo /home/usuario/datos

sudo mkdir /home/usuario/datos

2) Dale permisos de lectura escritura por todos

sudo chmod -Rf 777 /home/usuario/datos

3) Averigua la UUID de la partición y anótala

sudo vol_id --uuid /dev/sdb1

Editado: en Karmic vol_id ha sido descartado
la orden sería:

sudo blkid /dev/sdb1

4) Edita el fstab para agregar las líneas de montaje

sudo gedit /etc/fstab

5) Agrega las líneas para que se monte la partición, cambiando los datos por los tuyos

# /dev/sdb1
UUID=xbxxxdxx-exxx-4xxx-axxc-1baxxaabxxxa /home/usuario/datos ext3 relatime 0 2

6) Ejecuta para que se monte ya, sin tener que reiniciar

sudo mount -a

A partir de los próximos inicios se montará automáticamente
Saludos.
Gabriel.



Solo doy soporte a Ubuntu - 6666 - Más malo que el diablo.
+1
0
-1
Imagen de Cuajoman
+1
0
-1

Muchas gracias Gabriel por la solución, ha sido hacer exactamente lo que me has indicado y automáticamente ha resucitado el HD. No esperaba una respuesta tan rápida.

Recibe un cordial saludo.

+1
0
-1
Imagen de migueldeltoro
+1
0
-1

Buenas a todos. Llevo unos años con Linux pero todavía me falta mucho por aprender. Tenía montado en el PC un disco en el que no podía escribir porque no lo reconocía. Gracias a Gabriel ya me funciona.
Lo único que aporto es que yo el paso 6 (tengo Ubuntu 9.04) no lo podía realizar, así que reinicié el ordenador y ya está, disco activo.

Gente como tú hace que gente como yó pueda tener Linux.

Fco. Miguel del Toro
Aprendiendo sobre Linux
Gracias

+1
0
-1

Fco. Miguel del Toro
Aprendiendo sobre Linux
Gracias