Problemas con grub

Imagen de gli_2
0 puntos

Hola:

Hace un par de dias instale ubuntu en mi disco duro. Cuando el ubuntu ya me funcionaba bien, instale winxp en el mismo disco duro, en un espacio libre que havia dejado para este. Se instalo todo correcto, y luego solo me entraba en el windows cuando reiniciaba. Segui lo que pone aqui http://www.ubuntu-es.org/node/view/862 y recuperé el grub. Cual es el problema? Que el grub solo me aparece el linux, i no el windoze. No se que tengo que poner para poderlo iniciar. Creo que tengo que editar el archivo /boot/grub/menu.lst pero no se que tengo que poner exactamente.

Alguna sugerencia? Gracias ;)

Imagen de joseluis
+1
0
-1

Modifica /boot/grub/menu.lst

#sudo gedit /boot/grub/menu.lst

Si suponemos que instalaste XP en la segunda partición del primer disco duro, añade algo parecido a:

 title HasefrochXP
 rootnoverify (hd0,1)
 makeactive
 chainloader +1

Si la partición del XP fuera la tercera tendrías que cambiar hd0,1 por hd0,2
Si en lugar de ser el primer disco duro fuera un disco esclavo tendrías que poner hd1,N (siendo N el número de partición - 1, ya que grub comienza a numerar las particiones por 0).
Por supuesto a la derecha de title puedes poner la etiqueta que quieras.
Tienes más información sobre grub en http://wiki.hispalinux.es/moin/STecnicoHLGrub

+1
0
-1

Fdo. Forense asesino, Censor fundamentalista, Fustigador de novatos y Patético maleducado

Imagen de gli_2
+1
0
-1

Muchas gracias :D mi error era que no ponia (hd0,1) sino (hd0,0) que es la del ubuntu.

+1
0
-1