Es realmente imposible instalar Flash y Java en Ubuntu amd64!!!

Hola, algun usuario de Ubuntu al igual que yo ha tenido este problema alguna vez?? es realmente imposible instalar estos 2 "programas" tan utiles por lo menos para mi lo son... he tratado de una u otra manera de instalar el java y el flash en ubuntu amd64 pero e llegado a un punto en que lo creo realmente imposible...

existe alguien que haya salido victorioso de esta tortuosa labor????

Imagen de Anónimo
+1
0
-1

Buenas!
Java en teoría sí se puede instalar (siguiendo las instrucciones que vienen en la página de Sun). Y digo en teoría, yo cuando lo intenté no lo conseguí. Cierto que no insistí mucho porque en ese momento no lo necesitaba, y al primer error (creo recordar que era solucionable) abandoné el intento.

Lo de Flash lo veo más complicado, que yo sepa no existe solución mientras los de Macromedia no saquen una versión para Linux de 64 bits?

Siento no poder ayudarte más. Yo de hecho me estoy planteando instalarme en otra partición la distribución para I-386, para además poder correr Wine y otras cosillas que en la de AMD64 de momento creo que son imposibles...

+1
0
-1
Imagen de Anónimo
+1
0
-1

Gracias tio jejeje ya tengo instalado el java de echo no fue nada dificil :P ahora solo falta el flash pero tendre que esperar " como to2 lol" a que macromedia c decida y lo sake....

Gracias tio...!!

+1
0
-1
Imagen de Anónimo
+1
0
-1

La solucion para poder instalar flash es instalar un navegador de 32 bits, por ejemplo el firefox, pero en la version de 32 bits. La unica de momento porque no parece que estos ca****** de macromedia vayan a sacar version 64 bits para Linux. Todavia estamos esperando el shockwave.

+1
0
-1
Imagen de DiSKuN
+1
0
-1

es posible instalar un programa compilado en 32bits en un S.O. de 64bits como el navegador q copmentais?

+1
0
-1
Imagen de Anónimo
+1
0
-1

Se puede pero hay problemas de librerias. No puede usar librerias de 64 bits.
El Firefox no se puede usar directamente.
O acá o en el foro en inglés dice como instalar el de 32 bits cambiando el root para poder funcionar bien.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Mirad a ver este artículo. Yo particularmente no lo he probado todavía. a ver si hay alguien que diga si funciona.

http://bulma.net/body.phtml?nIdNoticia=2255

+1
0
-1
Imagen de Anónimo
+1
0
-1

Utilizando el crossover podeis instalar el firefox en la version para moco$oft y se acabaron los problemas,crossover es una version avanzada del wine que funciona perfectamente en ubuntu para amd64. Que donde lo consigo? pues donde ya sabemos todos.

saludos.

+1
0
-1
Imagen de Javier C
+1
0
-1

Como administrador entras en
Sistema - Administracion - gestor de paquetes synaptic
Hay que añadir a la lista de repositorios la línea
" deb http://ubuntu.tower-net.de/ubuntu/ hoary java "
Luego sólo hay que seleccionar el paquete "j2sdk4" o algo similar... mas o menos ... yo no lo he promado en amd64, pero en intel32 va de maravilla.

Para Flash ... no se ... la version 32 no la coje ... en Windos creo que las cosas a 32 corren igual q bien ( claro q teniendo 64 pa que andar con medias tintas )

+1
0
-1
Imagen de Anónimo
+1
0
-1

deb http://l.simonneau.free.fr/ubuntu breezy main multiverse
e instalar ia32-firefox, ia32-flashplugin-nonfree et ia32-realplayer

con eso os funcionará ; )

+1
0
-1
Imagen de Anónimo
+1
0
-1

checate esta liga y solo sigue las instrucciones ,
debes de saber que version tienes de ubuntu Hoary o Breeze
http://www.milmazz.com/archivos/2005/07/03/instalar-java-en-ubuntu/
o en esta liga:
http://www.ubuntu-es.org/node/6795

+1
0
-1
Imagen de coolerfun
+1
0
-1

Mira he probado eso pero el problema es que en la version de sun java no existe plugin para mozilla firefox, yo he conseguido instalar la version de java para 64 bit y funciona pero claro en firefox no.
De todas formas he descubierto por ahi que existe un java alternativo y en 64 de un grupo llamado Blackdown, he descubierto tambien que en los multiverse existe este paquete ademas de un paquete especifico para instalar el plugin de java para firefox, el caso es que he probado esto y cuando intento entrar en una web java con firefox este se cierra y e probado varias webs. en fin si alguien sabe como solucinarlo lo agradeceria.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Lo más fácil es usar el Firefox de 32 bits, que además está más actualizado.
Según un mensaje del foro oficial de Ubuntu en inglés, hay que hacer lo siguiente:

sudo apt-get install ia32-libs ia32-libs-gtk linux32

Crear el archivo /etc/pango32/pangorc sin olvidarnos que necesitamos derechos de root.
Y le insertamos el siguiente código:

[Pango]
ModuleFiles=/etc/pango32/pango.modules
[PangoX]
AliasFiles=/etc/pango/pangox.aliases

Creamos un script que podemos llamar firefox32 con el siguiente código:

#!/bin/sh
export GTK_PATH=/usr/lib32/gtk-2.0
export PANGO_RC_FILE=/etc/pango32/pangorc
linux32 /path/to/firefox/firefox $@

reemplazando donde dice /path/to/firefox por la ruta donde tengamos instalado el firefox de 32 bits.
Y no nos olvidamos de darle derechos de ejecución:

sudo chmod +x firefox32

Y listo, ejecutando firefox32 en lugar de firefox ya podemos usar el navegador compatible con todo.
Lo mismo puede aplicarse al Thunderbird.

+1
0
-1
Imagen de Charlie Brown
+1
0
-1

De echo hay una buena guia sin el método 'chroot' que hace funcionar las versiones oficiales (de 32 bits) en sistemas Ubuntu Breezy de 64 bits (amd64). Este es el link

https://wiki.ubuntu.com/FirefoxAMD64FlashJava

Yo estoy usando esta instalación en estos momentos y funciona a la perfección.

+1
0
-1
Imagen de Anónimo
+1
0
-1

Tengo ubuntu Breezy.
Instalé firefox32 siguiendo estas instrucciones

https://wiki.ubuntu.com/FirefoxAMD64FlashJava

y luego el mismo firefox instaló Flash y todo anda de diez ;-)

Probaré que pasa con Java...

+1
0
-1
Imagen de ScKaLiBuR
+1
0
-1

Pues eso, leí por este mismo foro cómo instalar flash en Firefox para AMD64. Instalando el paquete "libflash-mozplugin" tenemos solucionado el problema. El tema es el Java, he instalado el paquete "sun-java5-jre" que vienen en los repositorios de dapper (Uso Kubuntu Dapper) pero sigo sin poder usar Java en Firefox para AMD64. Alguna solución??

+1
0
-1
Imagen de albertodv
+1
0
-1

Hay varias alternativas para reproducir Flash, desde instalar Firefox de 32 bits y luego el plugin como se hace normalmente o usar el reproductor libre Gnash entre otras, yo uso esta última opción y me funciona bastante bien, es estable y lo poco que no me suele reproducir desde Firefox normalmente lo hago con Mplayer y la extensión VideoDownloader para Firefox (por ejemplo, youtube.com)

Sin embargo libflash-mozplugin es una versión inestable y poco potente comparado a Gnash que no te recomiendo usar.

Para Java creo que lo puedes encontrar en Automatix.

Te paso mis repositorios "extra" que uso para amd64:

# Automatix (http://getautomatix.com/)
## Firefox-32 bits, flash-32 bits, dvdrip, audacity, gnomebaker, acrobat reader, rar ace unrar archive support, mplayer, avidemux, non-free multimedia codecs ..

deb http://www.beerorkid.com/automatix/apt dapper main

# Janvitus Amd64 Repository (http://www.janvitus.netsons.org/)
## Update Amule, Bonfire, Gwget, Gxine, Listen, Music-applet..

deb http://janvitus.interfree.it/ ./

# Falcon generated repository (http://raof.dyndns.org/falcon/)
## XGL-Compiz, Gnash, MythTV, date (usually CVS HEAD) versions of multimedia packages

deb http://raof.dyndns.org/falcon/ dapper eyecandy flash misc mono multimedia mythtv tracker all

Saludos!
----
¿Novato? lee
¿Ayuda? guía 1, guía 2, Linux + Juegos

+1
0
-1