Tuve un problema Con apt y paquetes de debian, me apunto la solución.

+1
0
-1

Despues de instalar un paquete de debian (gcc-4.2) tuve graves problemas con las dependencias:

gcc-4.2: Depende: gcc-4.2-base (= 4.2.3-2ubuntu7) pero 4.2.4-3 va a ser instalado

E: Dependencias incumplidas. Intente 'apt-get -f install' sin paquetes (o especifique una solución).

Solución:

sudo dpkg --force-depends -r gcc-4.2-base
sudo aptitude -f install
dpgk -l gcc*

Y listo.