Video SiS

Imagen de rays
0 puntos

Buenas a todos! Paso a comentarles que a llegado a mis manos un laptop de la marca Olvivetti (ensambladas en Argentina), especificamente el modelo Olibook 520; el que posee un procesador Intel DualCore T2330, 1 Gb de ram, etc.
Despues de hacer algunos truquillos (mandandole esta directiva al kernel: pci=assign-busses apic miantimer idle=poll reboot=cold,hard) he logrado instalar Ubuntu 8.04 en el laptop, lo primero que me a pasado es que no he podido solucionar es que me tome bien la resolucion de pantalla, la que primero se encontraba a 800x600 despues la pude cambiar a 1024x768 usando la herramienta displayconfig-gtk, pero esta no es la optima ya que debe trabajar a 1280x800. Lo que he notado es que usa los drivers genericos vesa, no eh podido hacer que use los de SiS.
Me gustaria que me ayuden a solucionar este problema, me conformo con esto ya que por lo que he estado leyendo es casi imposible lograr aceleracion 3D con las placas SiS.
Les dejo el resultado del lspci, para que conozcan bien el modelo de la placa.

raymundo@rays-laptop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

Desde ya les dejo las gracias por tomarse este momento y leer esto.
Raymundo - RBU Team

Imagen de espartan001
+1
0
-1

modifica xorg.conf
sudo gedit /etc/X11/xorg.conf

busca las lineas que pongo abajo..... o Similares y agregarle la resolucion a la que necesitas trabajar "1280x800" (Con las comillas) por ejemplo mira que yo se la puse, despues guarda y reinicia

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter"
Monitor "776s"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1280x800" "1024x768" "832x624" "800x600" "720x400" "640x480" "1x1"
EndSubSection
EndSection

espero que te sirva de algo

+1
0
-1

Carlos -/Sephiroth/-

Imagen de fernando-eguia-mx
+1
0
-1

En primer lugar, estás en lo cierto, las tarjetas gráficas o los chips de video SiS no tienen soporte 3D, aunque algunos modelos lo emulan. Por esta razón no puedes activar los efectos de escritorio.

Sobre la resolución de tu pantalla, quizá necesites editar tu xorg.conf manualmente para probar si con eso puedes subir la resolución.

Ve a terminal y escribe lo siguiente:

ssudo gedit /etc/X11/xorg.conf

Se te pedirá tu contraseña de administrador, así que escríbela aunque no la veas en pantalla.

y, antes que otra cosa, guarda ese archivo como xorg.conf.backup por si metes la pata al manipular el archivo de configuración. Luego, cierra el editor de texto, vuelve a ejecutar el comando y ahora sí, mete mano en la sección "Screen". Te pongo un ejemplo de mi archivo xorg.conf:

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation NV34 [GeForce FX 5200]"
	Monitor		"Acer AL1714"
	Defaultdepth	24
	SubSection "Display"
		Depth	1
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	4
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	8
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	15
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	16
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	24
		Modes		"1280x1024"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection

Como lo notarás, hallarás entrecomilladas las resoluciones que tu equipo puede manejar. En este punto, puedes eliminar las resoluciones más bajas o las que consideres que no necesitas y puedes añadir la resolución que deseas en tu equipo. Hazlo. A continuación, guarda los cambios, cierra el editor de texto, cierra tu sesión y reiníciala.

Esto debería resolver el problema. Espero te sirva.


Si quieres un buscador orientado a Linux, prueba con www.google.com/linux

+1
0
-1
Imagen de rays
+1
0
-1

Antes que nada pido perdon por la tardanza de la respuesta, lo que ha pasado es que he tenido un nuevo inconveniente, Firefox no se conecta a la web, no se que ah pasado (he probado todo, pero sin resultado).
Bueno, seguimos con lo que estabamos discutiendo. No he podido modificar la resolucion de pantalla, modifique el xorg.conf pero no me aparece la opcion de ponerle una resolucion mas alta. A continuacion les muestro como me a quedado el archivo de configuracion:

Section "Monitor"
	Identifier	"Configured Monitor"
	Vendorname	"Generic LCD Display"
	Modelname	"LCD Panel 1280x800"
	Horizsync	31.5-50.0
	Vertrefresh	56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  modeline  "1280x800@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
	Gamma	1.0
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Configured Video Device"
	Monitor		"Configured Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes	"1280x800@60"	"1024x768@60"	"800x600@60"	"800x600@56"	"640x480@60"
	EndSubSection
EndSection

Como veran esta usando drivers genricos, sera por esa razon que no puedo cambiar la resolucion.
Muchas gracias
Raymundo.-

+1
0
-1
Imagen de rays
+1
0
-1

Hola gente, ayer estuve jugando un poco con el xorg.conf y he logrado una resolucion aproximada a la que yo deseo (1280x800); ahora esta trabajando a 1280x768, me toma la configuracion del monitor como panoramico, creo que es por eso que no me da la resolucion de 1280x800. A continuacion les muestro 2 capturas del xorg.conf

Section "Monitor"
        Identifier      "Configured Monitor"
        Vendorname      "Generic LCD Display"
        Modelname       "LCD Panel 1280x800"
        Horizsync       31.5-50.0
        Vertrefresh     56.0 - 65.0
        modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
        modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
        modeline  "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
        modeline  "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
        modeline  "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
        Gamma   1.0
EndSection
Section "Screen"
        Identifier      "Default Screen"
        Device          "Configured Video Device"
        Monitor         "Configured Monitor"
        Defaultdepth    24
        SubSection "Display"
        Depth   24
        Modes           "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"    "800x600@56"
        EndSubSection
EndSection

Seguire luchando hasta que pueda lograrlo, y si es con la ayuda de uds mejor. Gracias.
Raymundo

+1
0
-1
Imagen de fernando-eguia-mx
+1
0
-1

Fíjate en la línea "Modes" de la sección "Screen". Ya tienes varias resoluciones como estas:

        Modes           "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"    "800x600@56"

Ahora añade "1280x1024@60", con lo que esta línea debería quedar así:

        Modes           "1280x1024@60"   "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"    "800x600@56"

Y podrás quitar la resolución de 800 por 600 si te conviene. Te felicito por tu avance.


Si quieres un buscador orientado a Linux, prueba con www.google.com/linux

+1
0
-1
Imagen de fernando-eguia-mx
+1
0
-1

Fíjate en la línea "Modes" de la sección "Screen". Ya tienes varias resoluciones como estas:

        Modes           "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"    "800x600@56"

Ahora añade "1280x1024@60", con lo que esta línea debería quedar así:

        Modes           "1280x1024@60"   "1280x800@60"   "1280x720@60"   "1280x768@60"   "800x600@60"    "800x600@56"

Y podrás quitar la resolución de 800 por 600 si te conviene. Te felicito por tu avance.


Si quieres un buscador orientado a Linux, prueba con www.google.com/linux

+1
0
-1
Imagen de fernando-eguia-mx
+1
0
-1

Se me chispoteó, repetí el mensaje xD

+1
0
-1
Imagen de rays
+1
0
-1

Estoy muy feliz he logrado obtener la resolucion deseada, de 1280x800. Les comento, ayer le pedi a un Sr. llamado Barros Lee (creo que es desarrolador de drivers para linux de SiS) que me enviara el driver para mi Ubuntu 8.04, pasadas un par de horas ya lo tenia en mi casilla de correo. Seguido copie los archivos que me envio en /usr/lib/xorg/modules/drivers/, y modifique mi xorg.conf en la seccion "Device" puse en Driver "sis"; reinicie y ya tenia solucionado el problema.
Costo pero al fin lo logre.
Ahora le voy a preguntar a Barros Lee, si hay algun avance en cuanto a los drivers 3D para SiS, aunque creo que ya sé la respuesta. :(
Gracias a todos.
Raymundo.-

+1
0
-1
Imagen de delnitro
+1
0
-1

Hola Rays me alegro mucho que lograras solucionar ese inconveniente, que por cierto es el mismo que yo tengo. Entre en la pagina de barros lee y quizas no mire bien pero no encontre el mail de este hombre en ningun lado. Pero con mi pobre ingles entendi que ya habia desarrollado drivers sis 3d para mandriva 2007 y ubuntu 7.10 no quiero meter la pata ya que como dije antes mi ingles es muy pobre. Me podes decir como es el mail de este hombre? si se puede por aca por supuesto soy nuevo en este mundo de linux y en el foro tambien y no me tome el trabajo de leer todo el reglamento, desde ya muchas gracias y espero sepan disculpar si cometi un error.

+1
0
-1

La libertad es un estado en la mente

Imagen de rays
+1
0
-1

Hola delnitro, es verdad lo que tu has dicho de los drivers para las otras districiones, pero precisamente para Ubuntu 8.04 no ha desarrollado ningun driver.
Te cuento que yo entre a su blog y deje un mensaje para que me envira el drv 3d para 8.04; el mail del cual me lo mando no se si es correcto ponerlo aqui, por el momento no lo hago ya que tampoco eh leido todas las condiciones del foro.
Si quieres me escribes un mail a mi direccion: rayzavala (at) gmail (dot) com, y te la envio.
Nos leemos. Suerte.
Raymundo

+1
0
-1
Imagen de delnitro
+1
0
-1

HOla Rays muchas gracias por responder ante todo. Ya encontre el mail de barros lee. Le mande un correo Asi que que ahora a esperar. Te cuento algo y de paso se lo cuento a los demas en el foro: alla por mayo instale ubuntu 8.04 en mi notebook despues de googlear y buscan en foros logre hacerla andar en 1280 por 800. lo que ocurrio es que hace pocos dias me mande una macanita y tuve que reinstalar el sistema. el tema es que desde que reinstale el sistema, nunca mas pude hacer funcionar la pantalla en 1280 por 800.Pero esa ves que logre la resolucion tan preciada fue con drivers de ubuntu 7.04 que consegui en una pagina. Y yo tengo 8.04.Mi pregunta es si alguien intento usar los drivers 3D de versiones anteriores? (7.04 o 7.10) en 8.04. Creo que lo voy a intentar yo y cualquier cosa les digo como me fue.Saludos

+1
0
-1

La libertad es un estado en la mente

Imagen de hafa
+1
0
-1

hola tengo una computadora yo creo parecida a la de ray es una lanix lx4si comprada en mexico yo creo que es igual por que al hacer lspci obtengo algo igual a lo de ray pero ya intente modificando xorg.conf y no logro nada, al reiniciar solamente me marca algun problema con el servidor x y dice que iniciara en baja resolucion, solo puedo poner 800x600 y 640x480 si algo me falta hacer alguien ayudeme soy algo nuevo en esto, envio el resultado de lspci:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

+1
0
-1
Imagen de hafa
+1
0
-1

tambien les envio el xorg.conf

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60"

+1
0
-1
Imagen de rays
+1
0
-1

Hola Hafa, bueno si estuviste siguiendo el tema, veras que solo logre la resolución que estaba buscando luego de usar los drivers específicos para Ubuntu 8.04. Primero querría saber si estas usando estos drivers, y luego vemos. Espero que te pueda ayudar.
Raymundo.

+1
0
-1
Imagen de jjgomera
+1
0
-1

y habeis probado modificando el xorg añadiendo en la sección monitor tras las direferentes resoluciones la resolución preferida:

en mi caso está así:

Section "Monitor"
Identifier "Configured Monitor"
Option "PreferredMode" "1152x864"
EndSection

+1
0
-1
Imagen de hafa
+1
0
-1

disculpen que me alla tardado tando en contestar es que andaba ocupado en otros asuntos

bueno ya probe moviendo el xorg.conf pero no logre nada bueno y no he probado utilizado los driver para linux no se donde encontrarlos si me los puedes mandar o pasarme un link me seria muy util

+1
0
-1
Imagen de lean2804
+1
0
-1

Ray, yo tengo la misma notebook olivetti que tenes solo que es la T2370 con2GB de ram, el resto es (me imagino) todo igual, mi tema es que siguiendo todo este post y otros logre como lo hiciste vos hacer que la resolución llegue a 1280x768, pero tengo el problema que no logro configurar ni el compiz fusion, ni el avant window navigator, y por sobre todo el wireless (realtek 8187B) que segui varios post de como hacerlo pero no logro conectarme con la inalámbrica, del compiz y el avant segui todos los pasos habidos y por haber pero tampoco, por lo que se no tengo aceleración 3D por el chipset que nos toco (maldito SIS), como hiciste para que la resolución te de 1280x800? me podras pasar el driver que comentas que te pasaron? te confirmaron si se puede lograr la aceleración 3D en esta pc? entre al enlace que pones de barros lee pero esta casi todo en chino, la verdad que no se si vos le escribiste en ingles o la verdad que ya tengo la cabeza tan quemada de hace varias semanas que estoy con esto de ubuntu y que no puedo avanzar en nada (ni en los screeshots) que ya me estoy rindiendo. Bueno, a cualquiera que me pueda ayudar un poco al menos se lo voy a agradecer. Les mando un saludo.

Leandro

+1
0
-1